summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/mailx
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing/mailx')
-rw-r--r--abs/core-testing/mailx/PKGBUILD24
-rw-r--r--abs/core-testing/mailx/mailx-8.1.1.patch32
-rw-r--r--abs/core-testing/mailx/mailx-gcc4.patch12
3 files changed, 0 insertions, 68 deletions
diff --git a/abs/core-testing/mailx/PKGBUILD b/abs/core-testing/mailx/PKGBUILD
deleted file mode 100644
index 0041d2a..0000000
--- a/abs/core-testing/mailx/PKGBUILD
+++ /dev/null
@@ -1,24 +0,0 @@
-# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
-# Maintainer: judd <jvinet@zeroflux.org>
-# Committer: Judd Vinet <jvinet@zeroflux.org>
-pkgname=mailx
-pkgver=8.1.1
-pkgrel=14
-pkgdesc="A commandline utility for sending email"
-arch=(i686 x86_64)
-url="http://www.opengroup.org/onlinepubs/007908799/xcu/mailx.html"
-license=('BSD')
-groups=('base')
-depends=('glibc')
-source=(ftp://ftp.archlinux.org/other/mailx/$pkgname-$pkgver-fixed.tar.gz \
- mailx-$pkgver.patch mailx-gcc4.patch)
-md5sums=('63cad526ac64b57bcba2c0daaa1f3048' '905cfa35b5131524bfec0c677d456bd3'\
- '8716c7c7b3f5d348443230e2fe543bf6')
-
-build() {
- cd $startdir/src/$pkgname-$pkgver-fixed
- patch -Np1 -i ../mailx-$pkgver.patch || return 1
- patch -Np0 -i ../mailx-gcc4.patch || return 1
- make all || return 1
- make DESTDIR=$startdir/pkg install
-}
diff --git a/abs/core-testing/mailx/mailx-8.1.1.patch b/abs/core-testing/mailx/mailx-8.1.1.patch
deleted file mode 100644
index 2c0b777..0000000
--- a/abs/core-testing/mailx/mailx-8.1.1.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-diff -Naur mailx-8.1.1-fixed-orig/Makefile mailx-8.1.1-fixed/Makefile
---- mailx-8.1.1-fixed-orig/Makefile Thu Mar 16 09:30:36 2000
-+++ mailx-8.1.1-fixed/Makefile Wed Feb 27 12:50:09 2002
-@@ -7,18 +7,20 @@
- BINOWN = root
- BINGRP = mail
-
-+DESTDIR =
-+
- all:
- gcc $(SRCS) -o $(PROG)
-
- install:
-- mkdir -p /usr/share/misc
-- mkdir -p /usr/share/man/man1
-- mkdir -p /etc
-- mkdir -p /usr/bin
-- install -o $(BINOWN) -g $(BINGRP) -m 2755 $(PROG) /usr/bin
-- install -o root -g root -m 644 mail.1 /usr/share/man/man1
-+ mkdir -p $(DESTDIR)/usr/share/misc
-+ mkdir -p $(DESTDIR)/usr/man/man1
-+ mkdir -p $(DESTDIR)/etc
-+ mkdir -p $(DESTDIR)/usr/bin
-+ install -o $(BINOWN) -g $(BINGRP) -m 2755 $(PROG) $(DESTDIR)/usr/bin
-+ install -o root -g root -m 644 mail.1 $(DESTDIR)/usr/man/man1
- cd misc; install -c -o ${BINOWN} -g ${BINGRP} \
-- -m 444 ${SFILES} /usr/share/misc
-+ -m 444 ${SFILES} $(DESTDIR)/usr/share/misc
- cd misc; install -c -o root -g root \
-- -m 644 ${EFILES} /etc
-+ -m 644 ${EFILES} $(DESTDIR)/etc
-
diff --git a/abs/core-testing/mailx/mailx-gcc4.patch b/abs/core-testing/mailx/mailx-gcc4.patch
deleted file mode 100644
index 54740a2..0000000
--- a/abs/core-testing/mailx/mailx-gcc4.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-K. Piche: Unofficial patch for mailx.
-
---- dotlock.c.orig 2005-09-18 20:28:20.000000000 -0400
-+++ dotlock.c 2005-09-18 20:26:59.000000000 -0400
-@@ -47,6 +47,7 @@
- #include <errno.h>
- #include <signal.h>
-
-+#include "def.h"
- #include "extern.h"
-
- #ifndef O_SYNC