summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/mythtv/stable/mythgame/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing/mythtv/stable/mythgame/PKGBUILD')
-rw-r--r--abs/core-testing/mythtv/stable/mythgame/PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/abs/core-testing/mythtv/stable/mythgame/PKGBUILD b/abs/core-testing/mythtv/stable/mythgame/PKGBUILD
new file mode 100644
index 0000000..33fb9a5
--- /dev/null
+++ b/abs/core-testing/mythtv/stable/mythgame/PKGBUILD
@@ -0,0 +1,31 @@
+# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# Maintainer: Juergen Hoetzel <juergen@archlinux.org>
+# Contributor: kleptophobiac@gmail.com
+
+pkgname=mythgame
+pkgver=0.21
+pkgrel=1
+pkgdesc="Emulation plugin for MythTV"
+arch=('i686' 'x86_64')
+url="http://www.mythtv.org"
+license=('GPL')
+depends=("mythtv>=${pkgver}" 'zlib')
+source=("ftp://ftp.knoppmyth.net/R6/sources/mythplugins-$pkgver-fixes.tar.bz2")
+md5sums=('af20a78ac66719feddf9a39f1a799ded')
+groups=('mythtv-extras')
+
+build() {
+ cd $startdir/src/mythplugins-$pkgver
+ export QMAKESPEC='linux-g++'
+ source /etc/profile.d/qt3.sh
+
+ ./configure --prefix=/usr --disable-all --enable-opengl --enable-mythgame
+
+ qmake mythplugins.pro
+ make qmake || return 1
+# make -j 2 || return 1
+ make || return 1
+
+ make INSTALL_ROOT=$startdir/pkg install
+}
+