summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/mythtv/stable/mythvideo/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing/mythtv/stable/mythvideo/PKGBUILD')
-rw-r--r--abs/core-testing/mythtv/stable/mythvideo/PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/abs/core-testing/mythtv/stable/mythvideo/PKGBUILD b/abs/core-testing/mythtv/stable/mythvideo/PKGBUILD
new file mode 100644
index 0000000..21f2a22
--- /dev/null
+++ b/abs/core-testing/mythtv/stable/mythvideo/PKGBUILD
@@ -0,0 +1,36 @@
+# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# Maintainer: Juergen Hoetzel <travis@archlinux.org>
+# Contributor: kleptophobiac@gmail.com
+
+pkgname=mythvideo
+pkgver=0.21
+pkgrel=2
+pkgdesc="Video playback and browsing plugin for MythTV"
+arch=('i686' 'x86_64')
+url="http://www.mythtv.org"
+license=('GPL')
+depends=("mythtv>=${pkgver}" 'mplayer' 'perlxml' 'perl-libwww' 'perl-uri' 'perl-xml-simple' 'ffmpeg')
+source=("ftp://ftp.knoppmyth.net/R6/sources/mythplugins-$pkgver-fixes.tar.bz2"\
+ mtd)
+md5sums=('af20a78ac66719feddf9a39f1a799ded' '476c12ba074794ad7f4ae092bdf949d6')
+replaces=('mythdvd')
+groups=('mythtv-extras')
+
+build() {
+ cd $startdir/src/mythplugins-${pkgver}
+ . /etc/profile.d/qt3.sh
+
+ # use QT3 qmake
+ export PATH=$QTDIR/bin:$PATH
+
+ ./configure --prefix=/usr --disable-all --enable-mythvideo
+
+ qmake mythplugins.pro
+ make qmake || return 1
+ make -j 2 || return 1
+
+ make INSTALL_ROOT=$startdir/pkg install
+ install -D -m755 ../mtd $startdir/pkg/etc/rc.d/mtd
+}
+
+