summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/mythtv/stable/mythvideo
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing/mythtv/stable/mythvideo')
-rw-r--r--abs/core-testing/mythtv/stable/mythvideo/PKGBUILD36
-rw-r--r--abs/core-testing/mythtv/stable/mythvideo/mtd36
2 files changed, 72 insertions, 0 deletions
diff --git a/abs/core-testing/mythtv/stable/mythvideo/PKGBUILD b/abs/core-testing/mythtv/stable/mythvideo/PKGBUILD
new file mode 100644
index 0000000..21f2a22
--- /dev/null
+++ b/abs/core-testing/mythtv/stable/mythvideo/PKGBUILD
@@ -0,0 +1,36 @@
+# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# Maintainer: Juergen Hoetzel <travis@archlinux.org>
+# Contributor: kleptophobiac@gmail.com
+
+pkgname=mythvideo
+pkgver=0.21
+pkgrel=2
+pkgdesc="Video playback and browsing plugin for MythTV"
+arch=('i686' 'x86_64')
+url="http://www.mythtv.org"
+license=('GPL')
+depends=("mythtv>=${pkgver}" 'mplayer' 'perlxml' 'perl-libwww' 'perl-uri' 'perl-xml-simple' 'ffmpeg')
+source=("ftp://ftp.knoppmyth.net/R6/sources/mythplugins-$pkgver-fixes.tar.bz2"\
+ mtd)
+md5sums=('af20a78ac66719feddf9a39f1a799ded' '476c12ba074794ad7f4ae092bdf949d6')
+replaces=('mythdvd')
+groups=('mythtv-extras')
+
+build() {
+ cd $startdir/src/mythplugins-${pkgver}
+ . /etc/profile.d/qt3.sh
+
+ # use QT3 qmake
+ export PATH=$QTDIR/bin:$PATH
+
+ ./configure --prefix=/usr --disable-all --enable-mythvideo
+
+ qmake mythplugins.pro
+ make qmake || return 1
+ make -j 2 || return 1
+
+ make INSTALL_ROOT=$startdir/pkg install
+ install -D -m755 ../mtd $startdir/pkg/etc/rc.d/mtd
+}
+
+
diff --git a/abs/core-testing/mythtv/stable/mythvideo/mtd b/abs/core-testing/mythtv/stable/mythvideo/mtd
new file mode 100644
index 0000000..1f46dfe
--- /dev/null
+++ b/abs/core-testing/mythtv/stable/mythvideo/mtd
@@ -0,0 +1,36 @@
+#!/bin/bash
+
+. /etc/rc.conf
+. /etc/rc.d/functions
+
+PID=`pidof -o %PPID /usr/bin/mtd`
+case "$1" in
+ start)
+ stat_busy "Starting Myth Transcoding Daemon"
+ [ -z "$PID" ] && /usr/bin/mtd -d
+ if [ $? -gt 0 ]; then
+ stat_fail
+ else
+ echo $PID > /var/run/mtd.pid
+ add_daemon mythtranscode
+ stat_done
+ fi
+ ;;
+ stop)
+ stat_busy "Stopping Myth Transcoding Daemon"
+ [ ! -z "$PID" ] && kill $PID &>/dev/null
+ if [ $? -gt 0 ]; then
+ stat_fail
+ else
+ rm_daemon mtd
+ stat_done
+ fi
+ ;;
+ restart)
+ $0 stop
+ $0 start
+ ;;
+ *)
+ echo "usage: $0 {start|stop|restart}"
+esac
+exit 0