summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/mythtv/trunk/mythphone/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing/mythtv/trunk/mythphone/PKGBUILD')
-rw-r--r--abs/core-testing/mythtv/trunk/mythphone/PKGBUILD42
1 files changed, 0 insertions, 42 deletions
diff --git a/abs/core-testing/mythtv/trunk/mythphone/PKGBUILD b/abs/core-testing/mythtv/trunk/mythphone/PKGBUILD
deleted file mode 100644
index f6bf3ec..0000000
--- a/abs/core-testing/mythtv/trunk/mythphone/PKGBUILD
+++ /dev/null
@@ -1,42 +0,0 @@
-pkgname=mythphone-svn
-pkgver=16153
-pkgrel=3
-pkgdesc="Plugin that allows phone calls to be made to MythTv"
-url="http://www.mythtv.org"
-arch=('i686')
-depends=('mythtv-svn')
-conflicts=('mythtv-plugins-svn')
-groups=('mythtv-all-plugins-svn')
-license="GPL"
-source=()
-_svntrunk=http://cvs.mythtv.org/svn/trunk/mythplugins
-_svnmod=mythplugins
-
-
-build() {
- cd $startdir/src/
- echo svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
- svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
- cd $startdir/src/mythplugins
- make distclean
- PLUGIN=mythphone
- grep -q programs-libs.pro $PLUGIN/$PLUGIN/$PLUGIN.pro
- if [ $? != 0 ]
- then
- echo "include ( ../../programs-libs.pro )" >> $PLUGIN/$PLUGIN/$PLUGIN.pro
- msg "appending program lib"
- fi
-
- msg "Correcting configure kde3 to kde"
- sed -i 's#kde3#kde#' configure || return 1
- ./configure --enable-opengl --disable-all --enable-mythphone || return 1
- qmake mythplugins.pro || return 1
- make qmake || return 1
-
- msg "Correcting Makefile kde3 to kde"
- sed -i 's#kde3#kde#' ./mythphone/mythphone/Makefile || return 1
-
- make -j 2 || return 1
- make INSTALL_ROOT=$startdir/pkg install
-}
-