summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/runit-scripts
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing/runit-scripts')
-rwxr-xr-xabs/core-testing/runit-scripts/PKGBUILD2
-rwxr-xr-xabs/core-testing/runit-scripts/runitscripts/services/mysql/run4
2 files changed, 3 insertions, 3 deletions
diff --git a/abs/core-testing/runit-scripts/PKGBUILD b/abs/core-testing/runit-scripts/PKGBUILD
index ccd0d1f..8deb06f 100755
--- a/abs/core-testing/runit-scripts/PKGBUILD
+++ b/abs/core-testing/runit-scripts/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=runit-scripts
pkgver=1.8.0
-pkgrel=26
+pkgrel=27
pkgdesc="collection of startup scripts for runit"
url="http://smarden.org/runit/"
license="BSD"
diff --git a/abs/core-testing/runit-scripts/runitscripts/services/mysql/run b/abs/core-testing/runit-scripts/runitscripts/services/mysql/run
index 10b1c75..bfb367f 100755
--- a/abs/core-testing/runit-scripts/runitscripts/services/mysql/run
+++ b/abs/core-testing/runit-scripts/runitscripts/services/mysql/run
@@ -17,8 +17,8 @@ if [ ! `egrep '^mysql:' /etc/passwd` ]; then
fi
if [ ! -d $MYSQLD_ROOT ]; then
- mkdir $MYSQLD_ROOT
- /usr/bin/mysql_install_db --datadir=$MYSQLD_ROOT --user=mysql
+ mkdir -p $MYSQLD_ROOT
+ /usr/bin/mysql_install_db --datadir=$MYSQLD_ROOT --user=mysql 2>/dev/null 1>/dev/null
chown -R mysql.mysql $MYSQLD_ROOT
fi