summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/splashy/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing/splashy/PKGBUILD')
-rw-r--r--abs/core-testing/splashy/PKGBUILD46
1 files changed, 0 insertions, 46 deletions
diff --git a/abs/core-testing/splashy/PKGBUILD b/abs/core-testing/splashy/PKGBUILD
deleted file mode 100644
index be38e8c..0000000
--- a/abs/core-testing/splashy/PKGBUILD
+++ /dev/null
@@ -1,46 +0,0 @@
-# Contributor: Lexiw <llexiw@gmail.com>
-# Contributor: Angel 'angvp' Velasquez <angvp[at]archlinux.com.ve>
-# Contributor: dongiovanni <dongiovanni@archlinux.de>
-# Contributor: Darwin Bautista <djclue917@gmail.com>
-# Contributor: Jeremy Sands <cto@jeremysands.com>
-# Contributor: Tons of people here http://bbs.archlinux.org/viewtopic.php?id=48978
-
-pkgname=splashy
-pkgver=0.3.13
-pkgrel=1
-pkgdesc="A next-generation user-space boot splashing system for Linux systems"
-arch=('i686' 'x86_64')
-url="http://splashy.alioth.debian.org/"
-license=('GPL')
-depends=('file' 'glib2' 'initscripts-splashy' 'directfb')
-makedepends=('perl' 'pkgconfig' 'procps' 'gcc' 'make')
-options=('!libtool')
-source=(https://alioth.debian.org/frs/download.php/2691/splashy-0.3.13.tar.gz
- splashy.initcpio_install
- splashy.initcpio_hook
- splashy.install
- splashy-functions)
-md5sums=('03b7ee4f31c56ee61463772f74bad8a0'
- '89ab896c3b6d8edc70f7233d4f447897'
- 'f2d1b7ca4560a2888b08c5580dc8afae'
- 'c22046f52421e0663e02375e399ef37a'
- '91972fc154635806923befe3a70a1299')
-
-build() {
- cd ${startdir}/src/${pkgname}-${pkgver}
-
- ./configure --prefix=/usr --libdir=/usr/lib --sysconfdir=/etc --sbindir=/sbin --datarootdir=/usr/share --mandir=/usr/share/man --includedir=/usr/include
- make || return 1
- make DESTDIR=${startdir}/pkg install
-
- # Remove unnecessary files
- rm -rf ${startdir}/pkg/etc/{console-tools,default,init.d,lsb-base-logging.sh}
- rm -rf ${startdir}/pkg/usr/share/initramfs-tools
-
- install -D -m644 ${startdir}/splashy.initcpio_install ${startdir}/pkg/lib/initcpio/install/splashy
- install -D -m644 ${startdir}/splashy.initcpio_hook ${startdir}/pkg/lib/initcpio/hooks/splashy
- install -D -m644 ${startdir}/splashy-functions ${startdir}/pkg/etc/rc.d/splashy-functions
-
- sed -e 's|>/etc/splashy/themes<|>/usr/share/splashy/themes<|' -i ${startdir}/pkg/etc/splashy/config.xml
-}
-install=${pkgname}.install