summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/tiacx/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing/tiacx/PKGBUILD')
-rw-r--r--abs/core-testing/tiacx/PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/abs/core-testing/tiacx/PKGBUILD b/abs/core-testing/tiacx/PKGBUILD
new file mode 100644
index 0000000..d1bffc7
--- /dev/null
+++ b/abs/core-testing/tiacx/PKGBUILD
@@ -0,0 +1,23 @@
+# $Id: PKGBUILD 5944 2008-07-21 20:26:41Z thomas $
+# Maintainer: James Rayner <iphitus@gmail.com>
+
+pkgname=tiacx
+pkgver=20080210
+pkgrel=6
+pkgdesc="OpenSource module for Texas Instruments ACX100/ACX111 wireless chips. For stock arch 2.6 kernel"
+arch=(i686 x86_64)
+url="http://acx100.sourceforge.net/"
+license=('MPL')
+depends=('wireless_tools' 'kernel26>=2.6.26-1' 'kernel26<2.6.27' 'tiacx-firmware')
+install=acx.install
+source=(http://downloads.sourceforge.net/sourceforge/acx100/acx-$pkgver.tar.bz2)
+md5sums=('7d5ce3215708e4e9f95cf567a9ee3a12')
+
+_kernver=2.6.26-ARCH
+
+build() {
+ cd $startdir/src/acx-$pkgver
+ make -C /lib/modules/${_kernver}/build M=`pwd` || return 1
+ install -D acx.ko $startdir/pkg/lib/modules/${_kernver}/kernel/drivers/net/wireless/tiacx/acx.ko
+ sed -i -e "s/KERNEL_VERSION='.*'/KERNEL_VERSION='${_kernver}'/" $startdir/*.install
+}