summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/tk/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing/tk/PKGBUILD')
-rw-r--r--abs/core-testing/tk/PKGBUILD37
1 files changed, 0 insertions, 37 deletions
diff --git a/abs/core-testing/tk/PKGBUILD b/abs/core-testing/tk/PKGBUILD
deleted file mode 100644
index 3c75949..0000000
--- a/abs/core-testing/tk/PKGBUILD
+++ /dev/null
@@ -1,37 +0,0 @@
-# $Id: PKGBUILD 22248 2008-12-24 10:55:13Z allan $
-# Maintainer: Allan McRae <allan@archlinux.org>
-# Contributor: Judd Vinet <jvinet@zeroflux.org>
-
-pkgname=tk
-pkgver=8.5.6
-pkgrel=1
-pkgdesc="A windowing toolkit for use with tcl"
-arch=('i686' 'x86_64')
-url="http://tcl.sourceforge.net/"
-license=('custom')
-depends=("tcl=${pkgver}" 'libxss' 'libxft')
-source=(http://downloads.sourceforge.net/sourceforge/tcl/tk${pkgver}-src.tar.gz)
-md5sums=('7da2e00adddc7eed6080df904579d94e')
-
-build() {
- cd ${srcdir}/tk${pkgver}/unix
- if [ "$CARCH" = "x86_64" ]; then
- ./configure --prefix=/usr --mandir=/usr/share/man --enable-threads --enable-64bit
- else
- ./configure --prefix=/usr --mandir=/usr/share/man --enable-threads --disable-64bit
- fi
-
- make
- make INSTALL_ROOT=${pkgdir} install install-private-headers
- ln -sf wish8.5 ${pkgdir}/usr/bin/wish
- # install license
- install -Dm644 ../license.terms ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
-
- # remove buildroot traces / fixes #3602
- sed -i \
- -e "s,^TK_BUILD_LIB_SPEC='-L.*/unix,TK_BUILD_LIB_SPEC='-L/usr/lib," \
- -e "s,^TK_SRC_DIR='.*',TK_SRC_DIR='/usr/include'," \
- -e "s,^TK_BUILD_STUB_LIB_SPEC='-L.*/unix,TK_BUILD_STUB_LIB_SPEC='-L/usr/lib," \
- -e "s,^TK_BUILD_STUB_LIB_PATH='.*/unix,TK_BUILD_STUB_LIB_PATH='/usr/lib," \
- ${pkgdir}/usr/lib/tkConfig.sh
-}