summaryrefslogtreecommitdiffstats
path: root/abs/core-testing/util-linux-ng/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing/util-linux-ng/PKGBUILD')
-rw-r--r--abs/core-testing/util-linux-ng/PKGBUILD19
1 files changed, 7 insertions, 12 deletions
diff --git a/abs/core-testing/util-linux-ng/PKGBUILD b/abs/core-testing/util-linux-ng/PKGBUILD
index 35207fd..d7c396d 100644
--- a/abs/core-testing/util-linux-ng/PKGBUILD
+++ b/abs/core-testing/util-linux-ng/PKGBUILD
@@ -1,30 +1,24 @@
-# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# $Id: PKGBUILD 10319 2008-08-26 04:36:19Z allan $
# Maintainer: judd <jvinet@zeroflux.org>
pkgname=util-linux-ng
pkgver=2.14
-pkgrel=10
+pkgrel=1
pkgdesc="Miscellaneous system utilities for Linux"
arch=('i686' 'x86_64')
groups=('base')
-depends=('bash' 'ncurses' 'zlib' 'e2fsprogs')
+depends=('bash' 'ncurses>=5.6-7' 'zlib' 'e2fsprogs')
replaces=('linux32' 'util-linux')
conflicts=('linux32' 'util-linux')
provides=('linux32' 'util-linux')
license=('GPL')
source=(ftp://ftp.kernel.org/pub/linux/utils/${pkgname}/v2.14/${pkgname}-${pkgver}.tar.bz2
- util-linux-ng-2.14-20080624.diff)
+ http://loop-aes.sourceforge.net/updates/util-linux-ng-2.14-20080624.diff.bz2)
md5sums=('23f227da49df36f33fe47e917e332cd8'
- 'acb7bf692d239eb9872b0f00de437b7e')
-
-# The cryptoloop-support.patch comes from the boys at Rock Linux
-# (http://www.rocklinux.net/packages/util-linux.html)
-
-# Newer crypt support is here:
-# http://loop-aes.sourceforge.net/updates/util-linux-${_realver}.diff.bz2
+ 'e76c888bd140d7bd5bbd5f5b098bc1e7')
build() {
cd ${startdir}/src/${pkgname}-${pkgver}
- ./autogen.sh
+ #./autogen.sh
# cryptoloop support
patch -Np1 -i ${startdir}/src/util-linux-ng-2.14-20080624.diff || return 1
sed -e 's%etc/adjtime%var/lib/hwclock/adjtime%' -i hwclock/hwclock.c
@@ -35,4 +29,5 @@ build() {
rm -f ${startdir}/pkg/bin/kill
rm -f ${startdir}/pkg/usr/share/man/man1/kill.1
rm -f ${startdir}/pkg/usr/share/man/man5/nfs.5
+ rm -f ${pkgdir}/usr/share/info/dir
}