summaryrefslogtreecommitdiffstats
path: root/abs/core-testing
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing')
-rwxr-xr-xabs/core-testing/LinHES-config/PKGBUILD2
-rwxr-xr-xabs/core-testing/LinHES-config/install_proxy.sh7
-rwxr-xr-xabs/core-testing/LinHES-config/mv_install.py49
-rwxr-xr-xabs/core-testing/LinHES-config/mv_ir.py21
-rwxr-xr-xabs/core-testing/LinHES-config/systemconfig.sh5
5 files changed, 59 insertions, 25 deletions
diff --git a/abs/core-testing/LinHES-config/PKGBUILD b/abs/core-testing/LinHES-config/PKGBUILD
index 76d3d43..676c13f 100755
--- a/abs/core-testing/LinHES-config/PKGBUILD
+++ b/abs/core-testing/LinHES-config/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=LinHES-config
pkgver=2.0
-pkgrel=17
+pkgrel=25
conflicts=(MythVantage-config MythVantage-config-dev LinHES-config-dev )
pkgdesc="Install and configure your system"
depends=(bc libstatgrab mysql-python expect curl dnsutils parted sg3_utils nmbscan system-templates rsync python-parted ddcxinfo)
diff --git a/abs/core-testing/LinHES-config/install_proxy.sh b/abs/core-testing/LinHES-config/install_proxy.sh
index ef13f6c..bedacbf 100755
--- a/abs/core-testing/LinHES-config/install_proxy.sh
+++ b/abs/core-testing/LinHES-config/install_proxy.sh
@@ -31,6 +31,13 @@ progress () {
case $1 in
full_install_it )
mv_install.py --rootdisk=$disk --rootfs=$rootfs --rootsize=$rootsize --datafs=$datafs --datasize=$datasize --datadisk=$disk --swapsize=$swapsize -c full_install
+ rc=$?
+ echo "mv_install.py exit code $rc"
+ if [ $rc != 0 ]
+ then
+ echo "mv_install error" >> /tmp/.install_error
+ fi
+ exit $rc
;;
NETBOOT)
diff --git a/abs/core-testing/LinHES-config/mv_install.py b/abs/core-testing/LinHES-config/mv_install.py
index 97fbae5..87fbaae 100755
--- a/abs/core-testing/LinHES-config/mv_install.py
+++ b/abs/core-testing/LinHES-config/mv_install.py
@@ -15,6 +15,17 @@ def usage():
def clean_upgrade():
return False
+def error_out(errmsg):
+ cmd = '''echo %s >> /tmp/.install_error ''' %errmsg
+ runcmd(cmd)
+ logging.critical("***********************************")
+ logging.critical("error: %s",errmsg)
+ print "***********************************"
+ print "ERROR: mv_install.py: %s" %errmsg
+ print "***********************************"
+ sys.exit(1)
+
+
def update_db(value, data):
db = MySQLdb.connect(host="localhost", user="mythtv", passwd="mythtv", db="mythconverg")
try:
@@ -175,7 +186,7 @@ def runcmd(cmd):
else:
cmd = "echo "+cmd
logging.debug(" %s", cmd)
- cmdout = commands.getoutput(cmd)
+ cmdout = commands.getstatusoutput(cmd)
logging.debug(" %s", cmdout)
return cmdout
@@ -185,7 +196,7 @@ def mysqldb(cmd, inchroot):
elif cmd == "stop":
mycmd = " /etc/rc.d/mysqld stop"
if inchroot == "chroot":
- mycmd = " chroot %s" %mycmd
+ mycmd = " chroot /newboot %s" %mycmd
runcmd(mycmd)
@@ -261,7 +272,8 @@ def create_partitions(diskdevice, size, ptype, startsector):
geom = parted.Geometry(device=device, start=newstart, length=length)
except:
logging.info("An error occured, probably invalid parition size")
- return
+ error_out("invalid parition size")
+
#collect device constraint
constraint = device.getConstraint()
# new partition
@@ -303,7 +315,7 @@ def fscmd(fstype):
rc = fscmds[fstype]
except:
logging.critical(" %s is not a valid fs type, exiting now", fstype)
- sys.exit(3)
+ error_out("Error mvinstall during format")
return rc
@@ -489,7 +501,7 @@ def create_fstab(extralines):
def find_uuid(partition):
logging.info("Finding the UUID for %s...", partition)
cmd = "blkid -s UUID /dev/%s" %partition
- tmpuuid = runcmd(cmd)
+ tmpuuid = runcmd(cmd)[1]
splituuid = tmpuuid.partition("=")
uuid = splituuid[2].replace('"', "")
logging.info("The uuid is %s", uuid)
@@ -903,8 +915,11 @@ def full_install(hostoptions):
runcmd(cmd)
logging.info("Running systemconfig in chroot")
#cmd = " chroot %s %s/bin/systemconfig.sh misc, hostype, network, advanced, user, this_is_install" %(data_config.MOUNTPOINT, MVROOT)
- cmd = " chroot %s %s/bin/systemconfig.sh all , this_is_install" %(data_config.MOUNTPOINT, MVROOT)
- runcmd(cmd)
+ cmd = "chroot %s %s/bin/systemconfig.sh all , this_is_install" %(data_config.MOUNTPOINT, MVROOT)
+ rc = runcmd(cmd)[0]
+ if rc != 0 :
+ error_out("Running systemconfig")
+
mysqldb("stop", "chroot")
kill_dhcp_chroot()
logging.info("____End Database in CHROOT____")
@@ -922,9 +937,11 @@ def full_install(hostoptions):
logging.debug("touching /tmp/.dbsysfailed")
else:
#cmd = " chroot %s %s/bin/systemconfig.sh misc, hostype, network, advanced, user, this_is_install" %(data_config.MOUNTPOINT, MVROOT)
- cmd = " chroot %s %s/bin/systemconfig.sh all , this_is_install" %(data_config.MOUNTPOINT, MVROOT)
- runcmd(cmd)
- cmd = " chroot %s %s/bin/restore_default_settings.sh -c ACCESSCONTROL " %(data_config.MOUNTPOINT, MVROOT)
+ cmd = "chroot %s %s/bin/systemconfig.sh all , this_is_install" %(data_config.MOUNTPOINT, MVROOT)
+ rc = runcmd(cmd)[0]
+ if rc != 0 :
+ error_out("Running systemconfig")
+ cmd = "chroot %s %s/bin/restore_default_settings.sh -c ACCESSCONTROL " %(data_config.MOUNTPOINT, MVROOT)
runcmd(cmd)
umount_bind_chroot()
#cmd = " chroot %s %s/bin/systemconfig.sh advanced, user" %(data_config.MOUNTPOINT, MVROOT)
@@ -1127,8 +1144,10 @@ def upgrade(hostoptions):
mount_bind_chroot()
logging.info("Running systemconfig in chroot")
#cmd = " chroot %s %s/bin/systemconfig.sh misc, hostype, network, advanced, user, this_is_install" %(data_config.MOUNTPOINT, MVROOT)
- cmd = " chroot %s %s/bin/systemconfig.sh all , this_is_install" %(data_config.MOUNTPOINT, MVROOT)
- runcmd(cmd)
+ cmd = "chroot %s %s/bin/systemconfig.sh all , this_is_install" %(data_config.MOUNTPOINT, MVROOT)
+ rc = runcmd(cmd)[0]
+ if rc != 0 :
+ error_out("Running systemconfig")
mysqldb("stop", "")
if ( systemconfig["SystemType"] == "Master_backend" or systemconfig["SystemType"] == "Standalone" ):
if clean_upgrade() or not backup_sql_check():
@@ -1154,8 +1173,10 @@ def upgrade(hostoptions):
logging.info("Running systemconfig in chroot 2nd time")
#cmd = " chroot %s %s/bin/systemconfig.sh misc, hostype, network, advanced, user, this_is_install" %(data_config.MOUNTPOINT, MVROOT)
- cmd = " chroot %s %s/bin/systemconfig.sh all , this_is_install" %(data_config.MOUNTPOINT, MVROOT)
- runcmd(cmd)
+ cmd = "chroot %s %s/bin/systemconfig.sh all , this_is_install" %(data_config.MOUNTPOINT, MVROOT)
+ rc = runcmd(cmd)[0]
+ if rc != 0 :
+ error_out("Running systemconfig")
#logging.info("Running systemconfig in chroot")
#cmd = " chroot %s %s/bin/systemconfig.sh advanced" %(data_config.MOUNTPOINT, MVROOT)
#runcmd(cmd)
diff --git a/abs/core-testing/LinHES-config/mv_ir.py b/abs/core-testing/LinHES-config/mv_ir.py
index b8e9741..5734642 100755
--- a/abs/core-testing/LinHES-config/mv_ir.py
+++ b/abs/core-testing/LinHES-config/mv_ir.py
@@ -31,17 +31,20 @@ def setup_lirc_links(mythhome):
mv_common.runcmd(cmd)
pass
- if not os.path.exists(mythhome+"/.mythtv/lircrc"):
- logging.debug(" Creating symlink for myth lircrc")
- os.symlink("/etc/lircrc",mythhome+"/.mythtv/lircrc")
- else:
- logging.debug(" %s/lircrc already present",mythhome)
+ if os.path.exists("/etc/lircrc"):
+ if not os.path.exists(mythhome+"/.mythtv/lircrc"):
+ logging.debug(" Creating symlink for myth lircrc")
+ os.symlink("/etc/lircrc",mythhome+"/.mythtv/lircrc")
+ else:
+ logging.debug(" %s/lircrc already present",mythhome)
- if not os.path.exists(mythhome+"/.lircrc"):
- logging.debug(" Creating symlink for lircrc")
- os.symlink("/etc/lircrc",mythhome+"/.lircrc")
+ if not os.path.exists(mythhome+"/.lircrc"):
+ logging.debug(" Creating symlink for lircrc")
+ os.symlink("/etc/lircrc",mythhome+"/.lircrc")
+ else:
+ logging.debug(" %s/.lircrc already present",mythhome)
else:
- logging.debug(" %s/.lircrc already present",mythhome)
+ logging.debug(" /etc/lircrc does not exisit, can not link it")
def scrub_modules(filename,module):
logging.debug(" scrubbing %s from %s",module,filename)
diff --git a/abs/core-testing/LinHES-config/systemconfig.sh b/abs/core-testing/LinHES-config/systemconfig.sh
index 57bff5a..218f705 100755
--- a/abs/core-testing/LinHES-config/systemconfig.sh
+++ b/abs/core-testing/LinHES-config/systemconfig.sh
@@ -11,6 +11,9 @@ echo "----------------------start of systemconfig $@ ----------------------"
postfix=`cat ${BASE}/usr/local/share/mythtv/.releasetype`
systemconfig.py -m $@
-echo "exit code $?"
+rc=$?
+echo "systemconfig.py exit code $rc"
+exit $rc
+