summaryrefslogtreecommitdiffstats
path: root/abs/core-testing
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing')
-rwxr-xr-xabs/core-testing/LinHES-config/mv_software.py38
-rw-r--r--abs/core-testing/fftw2/PKGBUILD4
-rw-r--r--abs/core-testing/glib/PKGBUILD4
-rw-r--r--abs/core-testing/glib/__changelog2
-rw-r--r--abs/core-testing/gtk/PKGBUILD2
-rw-r--r--abs/core-testing/gtk/__changelog1
6 files changed, 35 insertions, 16 deletions
diff --git a/abs/core-testing/LinHES-config/mv_software.py b/abs/core-testing/LinHES-config/mv_software.py
index e5b96b2..7421e08 100755
--- a/abs/core-testing/LinHES-config/mv_software.py
+++ b/abs/core-testing/LinHES-config/mv_software.py
@@ -4,29 +4,47 @@ import os, re
def setup_software(systemconfig, data_config):
logging.info("____Start of Software install____")
- default_disabled = ("mythphone", "mytharchive", "mythbrowser", "mythnews",
- "mythgame", "mythflix", "mythweather",
- "mythappletrailers", "mythstream", "mythvodka")
+ postfix=''
+ if data_config.SYSTEMTYPE == "MythVantage":
+ #look for the installed prefix
+ cmd="pacman -Q mythtv-release-fixes"
+ rc = mv_common.runcmd(cmd)
+ if rc == 0:
+ postfix = "-release-fixes"
+ else:
+ postfix = "-svn"
- default_installed=("mythcontrols", "mythgallery", "mythmovies",
- "mythmusic", "mythsmolt", "mythvideo")
- other_pkg=("miro", "xe", "romdb", "xine", "dvdcss", "webmin" , "fuppes")
+ default_disabled = ("mythphone", "mytharchive", "mythbrowser", "mythnews",
+ "mythgame", "mythflix", "mythweather" )
+
+ default_installed=("mythcontrols", "mythgallery", "mythmovies",
+ "mythmusic", "mythsmolt", "mythvideo")
+ other_pkg=("miro", "xe", "romdb", "xine", "dvdcss", "webmin" , "fuppes", "mythappletrailers", "mythstream", "mythvodka")
+ else:
+ default_disabled = ("mythphone", "mytharchive", "mythbrowser", "mythnews",
+ "mythgame", "mythflix", "mythweather",
+ "mythappletrailers", "mythstream", "mythvodka")
+
+ default_installed=("mythcontrols", "mythgallery", "mythmovies",
+ "mythmusic", "mythsmolt", "mythvideo")
+ other_pkg=("miro", "xe", "romdb", "xine", "dvdcss", "webmin" , "fuppes")
for pkg in default_disabled:
+ pkgname=pkg+postfix
try:
if systemconfig[pkg] == "1":
- mv_common.pacinstall(pkg)
+ mv_common.pacinstall(pkgname)
else:
- mv_common.pacremove(pkg)
+ mv_common.pacremove(pkgname)
except:
logging.debug(" ERROR-- %s is not defined", pkg)
for pkg in default_installed:
try:
if systemconfig[pkg] == "0":
- mv_common.pacremove(pkg)
+ mv_common.pacremove(pkgname)
else:
- mv_common.pacinstall(pkg)
+ mv_common.pacinstall(pkgname)
except:
logging.debug(" ERROR-- %s is not defined", pkg)
diff --git a/abs/core-testing/fftw2/PKGBUILD b/abs/core-testing/fftw2/PKGBUILD
index 4b95f97..18aa473 100644
--- a/abs/core-testing/fftw2/PKGBUILD
+++ b/abs/core-testing/fftw2/PKGBUILD
@@ -3,13 +3,13 @@
pkgname=fftw2
pkgver=2.1.5
-pkgrel=8
+pkgrel=9
pkgdesc="FFTW is a C subroutine library for computing the discrete Fourier transform (DFT) in one or more dimensions, of both real and complex data, and of arbitrary input size. This is package is offering backwards compatibility version 2.x.y. of fftw."
arch=(i686 x86_64)
url="http://www.fftw.org/"
license=('GPL2')
depends=('glibc')
-options=(!libtool !emptydirs)
+options=(!libtool !emptydirs !docs)
source=(http://www.fftw.org/fftw-${pkgver}.tar.gz)
md5sums=('8d16a84f3ca02a785ef9eb36249ba433')
diff --git a/abs/core-testing/glib/PKGBUILD b/abs/core-testing/glib/PKGBUILD
index cb97a5b..42f4420 100644
--- a/abs/core-testing/glib/PKGBUILD
+++ b/abs/core-testing/glib/PKGBUILD
@@ -4,13 +4,13 @@
pkgname=glib
pkgver=1.2.10
-pkgrel=8
+pkgrel=10
pkgdesc="Common C routines used by Gtk+ and other libs"
arch=('i686' 'x86_64')
url="http://www.gtk.org/"
license=('LGPL')
depends=('glibc')
-options=('!libtool' '!emptydirs')
+options=('!libtool' '!emptydirs' '!docs' )
source=(ftp://ftp.gtk.org/pub/gtk/v1.2/$pkgname-$pkgver.tar.gz \
gcc340.patch \
aclocal-fixes.patch)
diff --git a/abs/core-testing/glib/__changelog b/abs/core-testing/glib/__changelog
index 93f6b06..f2439db 100644
--- a/abs/core-testing/glib/__changelog
+++ b/abs/core-testing/glib/__changelog
@@ -1 +1 @@
-added !emptydir to options
+added !emptydir !docs to options
diff --git a/abs/core-testing/gtk/PKGBUILD b/abs/core-testing/gtk/PKGBUILD
index bb47b2b..48c4972 100644
--- a/abs/core-testing/gtk/PKGBUILD
+++ b/abs/core-testing/gtk/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=gtk
pkgver=1.2.10
-pkgrel=10
+pkgrel=11
pkgdesc="The GTK+ toolkit"
arch=('i686' 'x86_64')
url="http://www.gtk.org/"
diff --git a/abs/core-testing/gtk/__changelog b/abs/core-testing/gtk/__changelog
index 014bc64..5d6d4d6 100644
--- a/abs/core-testing/gtk/__changelog
+++ b/abs/core-testing/gtk/__changelog
@@ -1,2 +1,3 @@
added !emptydir to options
+!docs