summaryrefslogtreecommitdiffstats
path: root/abs/core-testing
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing')
-rw-r--r--abs/core-testing/LinHES-system/LinHES-run6
-rw-r--r--abs/core-testing/LinHES-system/LinHES.install5
-rw-r--r--abs/core-testing/LinHES-system/PKGBUILD60
-rw-r--r--abs/core-testing/LinHES-system/smolt.cron11
-rw-r--r--abs/core-testing/LinHES-system/unclutter-toggle.sh5
-rw-r--r--abs/core-testing/lighttpd/PKGBUILD4
-rw-r--r--abs/core-testing/lighttpd/__changelog3
-rw-r--r--abs/core-testing/lighttpd/lighttpd.conf2
-rw-r--r--abs/core-testing/linhes-scripts/PKGBUILD56
-rw-r--r--abs/core-testing/linhes-scripts/linhes-scripts.install7
-rw-r--r--abs/core-testing/linhes-scripts/remove_php_mythvideo.sh6
-rw-r--r--abs/core-testing/local-website/PKGBUILD2
-rw-r--r--abs/core-testing/local-website/htdocs/rrd/index.html2
-rw-r--r--abs/core-testing/mythinstall/PKGBUILD2
-rwxr-xr-xabs/core-testing/mythtv/stable-0.22/mythtv/PKGBUILD9
-rwxr-xr-xabs/core-testing/mythtv/stable-0.22/mythtv/pretty11
-rwxr-xr-xabs/core-testing/mythtv/trunk/mythtv/PKGBUILD5
-rwxr-xr-xabs/core-testing/mythtv/trunk/mythtv/pretty11
-rw-r--r--abs/core-testing/php/PKGBUILD2
-rw-r--r--abs/core-testing/php/php.install4
-rwxr-xr-xabs/core-testing/runit/PKGBUILD9
-rwxr-xr-xabs/core-testing/runit/shutdown.script5
-rwxr-xr-xabs/core-testing/unclutter/PKGBUILD12
-rw-r--r--abs/core-testing/unclutter/unclutter.cfg2
24 files changed, 213 insertions, 28 deletions
diff --git a/abs/core-testing/LinHES-system/LinHES-run b/abs/core-testing/LinHES-system/LinHES-run
index 959fe84..8f235e8 100644
--- a/abs/core-testing/LinHES-system/LinHES-run
+++ b/abs/core-testing/LinHES-system/LinHES-run
@@ -1,13 +1,15 @@
#!/bin/sh
. /etc/profile
. /etc/systemconfig
-
+idle=1
+jitter=200
+. /etc/unclutter.cfg
#keylaunch &
#/usr/bin/tilda &
#move mouse to corner
xdotool mousemove -10 -10
-/usr/X11R6/bin/unclutter -root -idle 1 -jitter 200 -noevents &
+/usr/X11R6/bin/unclutter -root -idle $idle -jitter $jitter -noevents &
if [ x"$Screensavertype" = "xgscreensaver" ]
then
gnome-screensaver &
diff --git a/abs/core-testing/LinHES-system/LinHES.install b/abs/core-testing/LinHES-system/LinHES.install
index 2d2bdf2..9f6a1c1 100644
--- a/abs/core-testing/LinHES-system/LinHES.install
+++ b/abs/core-testing/LinHES-system/LinHES.install
@@ -12,7 +12,10 @@ MVDIR=/usr/LH/bin
# ln -s $MVDIR/backup_job /etc/cron.daily/backup_cron
# ln -s $MVDIR/update_system /etc/cron.daily/xupdate_system_cron
# ln -s $MVDIR/repo_sync.sh /etc/cron.daily/zrepo_sync.sh
- ln -s $MVDIR/myth_mtc.sh /etc/cron.daily/myth_mtc.sh
+ if [ ! -e /etc/cron.daily/myth_mtc.sh ]
+ then
+ ln -s $MVDIR/myth_mtc.sh /etc/cron.daily/myth_mtc.sh
+ fi
#LINE="mythtv ALL = NOPASSWD: /sbin/sv stop mythbackend"
LINE="mythtv ALL=(ALL) NOPASSWD: ALL"
diff --git a/abs/core-testing/LinHES-system/PKGBUILD b/abs/core-testing/LinHES-system/PKGBUILD
index cca8500..f775314 100644
--- a/abs/core-testing/LinHES-system/PKGBUILD
+++ b/abs/core-testing/LinHES-system/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=LinHES-system
-pkgver=1.0
-pkgrel=74
+pkgver=1.1
+pkgrel=11
arch=('i686')
MVDIR=$startdir/pkg/usr/LH
BINDIR=$startdir/pkg/usr/bin
@@ -8,7 +8,7 @@ install=LinHES.install
pkgdesc="scripts and things related to having a automated system"
depends=(linhes-sounds xdotool)
backup=(etc/modprobe.d/alsa-base)
-binfiles="LinHES-start optimize_mythdb.py myth_mtc.py myth_mtc.sh LinHES-run firstboot.sh load-modules-mythvantage.sh unclutter-toggle.sh myth_mtc.lr"
+binfiles="LinHES-start optimize_mythdb.py myth_mtc.py myth_mtc.sh LinHES-run firstboot.sh load-modules-mythvantage.sh unclutter-toggle.sh myth_mtc.lr smolt.cron "
source=(LinHES-session LinHES-profile.sh $binfiles alsa-base)
@@ -36,7 +36,61 @@ do
done
install -m755 -D $startdir/src/alsa-base $startdir/pkg/etc/modprobe.d/alsa-base
+install -m755 -D $startdir/src/smolt.cron $startdir/pkg/etc/cron.weekly/smolt.cron
mkdir $startdir/pkg/etc/logrotate.d
cp $startdir/myth_mtc.lr $startdir/pkg/etc/logrotate.d
}
+
+md5sums=('19934a456d0e112298b8aac3279f9a16'
+ '5881bdb43d578ec3a79d1f77ea58a3db'
+ 'a875ee97f86e46f34a741c2bc455f894'
+ 'cdcbc530224215f8fcf7ebcd93d7eb0b'
+ 'c60b6c66f498809a6e5ca18a8c97d336'
+ 'ccae1296ef248fa52ec3a7cb820a476e'
+ '6112f32c48763a057341ccfb18d2375a'
+ '18a884a73344ff6eb74f63b49745e0f5'
+ 'dc3eef2a624754e16805d72bbe488b67'
+ '72eb4117bb7d523691233c40e7535752'
+ 'f1870a9522c79e6b248fcbf81dec3280'
+ '90a5d903e11e8bb457855d2ffd657e1e'
+ 'eb879fee9603a05d5420d4ce8ed9e450')
+md5sums=('19934a456d0e112298b8aac3279f9a16'
+ '5881bdb43d578ec3a79d1f77ea58a3db'
+ 'a875ee97f86e46f34a741c2bc455f894'
+ 'cdcbc530224215f8fcf7ebcd93d7eb0b'
+ 'c60b6c66f498809a6e5ca18a8c97d336'
+ 'ccae1296ef248fa52ec3a7cb820a476e'
+ '6112f32c48763a057341ccfb18d2375a'
+ '18a884a73344ff6eb74f63b49745e0f5'
+ 'dc3eef2a624754e16805d72bbe488b67'
+ '72eb4117bb7d523691233c40e7535752'
+ 'f1870a9522c79e6b248fcbf81dec3280'
+ 'f891f01eac77a1a9cd3d638c28ae4b3a'
+ 'eb879fee9603a05d5420d4ce8ed9e450')
+md5sums=('19934a456d0e112298b8aac3279f9a16'
+ '5881bdb43d578ec3a79d1f77ea58a3db'
+ 'a875ee97f86e46f34a741c2bc455f894'
+ 'cdcbc530224215f8fcf7ebcd93d7eb0b'
+ 'c60b6c66f498809a6e5ca18a8c97d336'
+ 'ccae1296ef248fa52ec3a7cb820a476e'
+ '6112f32c48763a057341ccfb18d2375a'
+ '18a884a73344ff6eb74f63b49745e0f5'
+ 'dc3eef2a624754e16805d72bbe488b67'
+ '72eb4117bb7d523691233c40e7535752'
+ 'f1870a9522c79e6b248fcbf81dec3280'
+ 'abe887472a170bd1a8e6da6a7b7e93e4'
+ 'eb879fee9603a05d5420d4ce8ed9e450')
+md5sums=('19934a456d0e112298b8aac3279f9a16'
+ '5881bdb43d578ec3a79d1f77ea58a3db'
+ 'a875ee97f86e46f34a741c2bc455f894'
+ 'cdcbc530224215f8fcf7ebcd93d7eb0b'
+ 'c60b6c66f498809a6e5ca18a8c97d336'
+ 'ccae1296ef248fa52ec3a7cb820a476e'
+ '6022095f05d0428de926bb81b1693d56'
+ '18a884a73344ff6eb74f63b49745e0f5'
+ 'dc3eef2a624754e16805d72bbe488b67'
+ 'dc0be354ce77ba2b89868fc29b942c43'
+ 'f1870a9522c79e6b248fcbf81dec3280'
+ 'abe887472a170bd1a8e6da6a7b7e93e4'
+ 'eb879fee9603a05d5420d4ce8ed9e450')
diff --git a/abs/core-testing/LinHES-system/smolt.cron b/abs/core-testing/LinHES-system/smolt.cron
new file mode 100644
index 0000000..f418df1
--- /dev/null
+++ b/abs/core-testing/LinHES-system/smolt.cron
@@ -0,0 +1,11 @@
+#!/bin/bash
+. /etc/profile
+if [ -f /home/mythtv/.mythtv/MythSmolt/hw-uuid ]
+then
+ cd /usr/share/mythtv/mythsmolt/scripts
+ touch /var/log/smolt.update
+ chown mythtv /var/log/smolt.update
+ random=$((RANDOM%2000))
+ sleep $random
+ su mythtv -c "./sendProfile.py -a" > /var/log/smolt.update
+fi
diff --git a/abs/core-testing/LinHES-system/unclutter-toggle.sh b/abs/core-testing/LinHES-system/unclutter-toggle.sh
index 0ead751..aadce50 100644
--- a/abs/core-testing/LinHES-system/unclutter-toggle.sh
+++ b/abs/core-testing/LinHES-system/unclutter-toggle.sh
@@ -1,8 +1,11 @@
#!/bin/bash
PIDUNC=`pidof unclutter`
+jitter=200
+idle=1
+. /etc/unclutter.cfg
if [ -n "${PIDUNC}" ];
then
killall -9 unclutter
else
- /usr/X11R6/bin/unclutter -root -idle 1 -jitter 200 -noevents &
+ /usr/X11R6/bin/unclutter -root -idle $idle -jitter $jitter -noevents &
fi
diff --git a/abs/core-testing/lighttpd/PKGBUILD b/abs/core-testing/lighttpd/PKGBUILD
index c31e924..bbb0a39 100644
--- a/abs/core-testing/lighttpd/PKGBUILD
+++ b/abs/core-testing/lighttpd/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=lighttpd
pkgver=1.4.26
-pkgrel=8
+pkgrel=9
pkgdesc='a secure, fast, compliant and very flexible web-server'
license=('custom')
arch=('i686' 'x86_64')
@@ -72,6 +72,6 @@ build() {
md5sums=('a682c8efce47a2f4263a247ba0813c9b'
'bd690eee0d9e51857448770a151023b0'
'857e174643fd7761a2f0d8431a679f6c'
- 'fe078f9b8ee701ed21278789cad90acf'
+ '07b8459b54fb2e70280064c2a275b176'
'c6e361131000ceec085f40b310ef4a2c'
'84c884b8dadd724afe2bc6529e9d4485')
diff --git a/abs/core-testing/lighttpd/__changelog b/abs/core-testing/lighttpd/__changelog
index a96d942..63bc373 100644
--- a/abs/core-testing/lighttpd/__changelog
+++ b/abs/core-testing/lighttpd/__changelog
@@ -4,3 +4,6 @@ modified auth to require valid user (include auth-inc.conf)
# by mihanson:
upgraded to 1.4.26 to address http://linhes.org/flyspray/index.php?do=details&task_id=624
Added -e 's|"^/mythweb|"^/{1,2}mythweb|' \ to the sed command to work around lighttpd no longer honoring // in a url and/or to work around mythweb producing url's with a // for streaming and downloading.
+
+changed lightttpd.conf to user perl for .cgi (needed for monx)_
+
diff --git a/abs/core-testing/lighttpd/lighttpd.conf b/abs/core-testing/lighttpd/lighttpd.conf
index 0c55f52..af7d134 100644
--- a/abs/core-testing/lighttpd/lighttpd.conf
+++ b/abs/core-testing/lighttpd/lighttpd.conf
@@ -235,7 +235,7 @@ server.groupname = "http"
)
#### CGI module
cgi.assign = ( ".pl" => "/usr/bin/perl",
- ".cgi" => "/bin/bash" )
+ ".cgi" => "/usr/bin/perl" )
url.rewrite-once = (
"^/mythweb/(css|data|images|js|themes|skins|[a-z_]+\.(php|pl)).*" => "$0",
diff --git a/abs/core-testing/linhes-scripts/PKGBUILD b/abs/core-testing/linhes-scripts/PKGBUILD
index af152c1..f721fee 100644
--- a/abs/core-testing/linhes-scripts/PKGBUILD
+++ b/abs/core-testing/linhes-scripts/PKGBUILD
@@ -3,12 +3,13 @@
pkgname=linhes-scripts
pkgver=1
-pkgrel=51
+pkgrel=55
pkgdesc="Various scripts that help to make LinHES, LinHES."
arch=('i686' 'x86_64')
license=('GPL2')
depends=('xosd' 'cpulimit')
url="http://linhes.org/"
+install="linhes-scripts.install"
source=(
myth2xvid
shootscreens.sh
@@ -35,6 +36,7 @@ linhes_update3.sh
install_hulu.sh
update_schema_021_to_022.sh
upgrade_to_0.22.sh
+remove_php_mythvideo.sh
)
build() {
@@ -48,3 +50,55 @@ build() {
mkdir -p $startdir/pkg/etc/logrotate.d/
cp pause_mythcommflag $startdir/pkg/etc/logrotate.d/
}
+md5sums=('f56985b2d602e11dc1e10d3e7848b2a5'
+ '623b6e9ba6cc4a19771005e750f337a7'
+ '9ae2cd7a0c42d57ad8b5f515d7d60196'
+ '1274bad3fb7296f00acd2d44804bad14'
+ 'b4f858834ea92418208ab496ca39ad32'
+ '6b6e7d34a4bda6d608d150039adefd07'
+ '3fe554dbbf7d09e1f9925032ba888bf5'
+ '18263972b6326e140bbef0bb7dfa2da9'
+ '410795ef9039e4c6c0484e706ecfd567'
+ '0750d7c65109d12aa536f312a38410d1'
+ 'ac2a4a6b4100f4d7bfb9ecd9356c8c6e'
+ 'd2b475821f902c5e081e7da43a35e6ac'
+ '26a194301b0cfc4ca212d462a0899077'
+ '3b776bbff68906ddc2f62b7e0dde3fe4'
+ '85706c981e8ec2c5bb49a33538782d4c'
+ '3d0adf26280cde55a0c47188fff34826'
+ '93aaa2940e33ec9ebb305b839ac46a3e'
+ '972e42e02a11575da91f5e051d4de1d2'
+ 'b527b01d119d3bc33b8fa69bdf1082bb'
+ 'c537c44156d8404016cc4b405b092d45'
+ '4e66f302a77f1a857476e7f289d0c157'
+ 'be324dba44ae96676973a74421944853'
+ 'c9dc0dd07369622879a000247ac55074'
+ '3256a968ea4c06b2f6bfb68d7bb1a8f5'
+ 'ea5492d4dab8271db20cb84416c001dc'
+ 'fc9c3858a30891f159267123b007c0ea')
+md5sums=('f56985b2d602e11dc1e10d3e7848b2a5'
+ '623b6e9ba6cc4a19771005e750f337a7'
+ '9ae2cd7a0c42d57ad8b5f515d7d60196'
+ '1274bad3fb7296f00acd2d44804bad14'
+ 'b4f858834ea92418208ab496ca39ad32'
+ '6b6e7d34a4bda6d608d150039adefd07'
+ '3fe554dbbf7d09e1f9925032ba888bf5'
+ '18263972b6326e140bbef0bb7dfa2da9'
+ '410795ef9039e4c6c0484e706ecfd567'
+ '0750d7c65109d12aa536f312a38410d1'
+ 'ac2a4a6b4100f4d7bfb9ecd9356c8c6e'
+ 'd2b475821f902c5e081e7da43a35e6ac'
+ '26a194301b0cfc4ca212d462a0899077'
+ '3b776bbff68906ddc2f62b7e0dde3fe4'
+ '85706c981e8ec2c5bb49a33538782d4c'
+ '3d0adf26280cde55a0c47188fff34826'
+ '93aaa2940e33ec9ebb305b839ac46a3e'
+ '972e42e02a11575da91f5e051d4de1d2'
+ 'b527b01d119d3bc33b8fa69bdf1082bb'
+ 'c537c44156d8404016cc4b405b092d45'
+ '4e66f302a77f1a857476e7f289d0c157'
+ 'be324dba44ae96676973a74421944853'
+ 'c9dc0dd07369622879a000247ac55074'
+ '3256a968ea4c06b2f6bfb68d7bb1a8f5'
+ 'ea5492d4dab8271db20cb84416c001dc'
+ 'd7c7914225ec86bf3ea46104a364f977')
diff --git a/abs/core-testing/linhes-scripts/linhes-scripts.install b/abs/core-testing/linhes-scripts/linhes-scripts.install
new file mode 100644
index 0000000..f554bd0
--- /dev/null
+++ b/abs/core-testing/linhes-scripts/linhes-scripts.install
@@ -0,0 +1,7 @@
+
+post_upgrade() {
+ . /etc/profile
+ /usr/LH/bin/remove_php_mythvideo.sh
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/abs/core-testing/linhes-scripts/remove_php_mythvideo.sh b/abs/core-testing/linhes-scripts/remove_php_mythvideo.sh
new file mode 100644
index 0000000..5320756
--- /dev/null
+++ b/abs/core-testing/linhes-scripts/remove_php_mythvideo.sh
@@ -0,0 +1,6 @@
+#!/bin/bash
+
+mysql mythconverg <<EOF
+delete from videotypes where extension='php';
+insert into videotypes(extension,f_ignore) values('php','1');
+EOF
diff --git a/abs/core-testing/local-website/PKGBUILD b/abs/core-testing/local-website/PKGBUILD
index 1f1faa9..5a84b2b 100644
--- a/abs/core-testing/local-website/PKGBUILD
+++ b/abs/core-testing/local-website/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=local-website
pkgver=2
-pkgrel=15
+pkgrel=16
pkgdesc="Contents of http://localhost"
arch=(i686 x86_64)
license=('GPL')
diff --git a/abs/core-testing/local-website/htdocs/rrd/index.html b/abs/core-testing/local-website/htdocs/rrd/index.html
index 5f595b2..c60692f 100644
--- a/abs/core-testing/local-website/htdocs/rrd/index.html
+++ b/abs/core-testing/local-website/htdocs/rrd/index.html
@@ -13,7 +13,7 @@
<tbody>
<tr>
<td style="vertical-align: top;">
- <p class="headerimage" align="center"><b>KnoppMyth R5.5</b></p>
+ <p class="headerimage" align="center"><b>The Linux Home Entertainment System Release 6</b></p>
<p align=center>
<font size="+2">RRD Tool</font><br>
<font size="+1">Is <font color="#CC0000">disabled</font>
diff --git a/abs/core-testing/mythinstall/PKGBUILD b/abs/core-testing/mythinstall/PKGBUILD
index c84c9de..f97541b 100644
--- a/abs/core-testing/mythinstall/PKGBUILD
+++ b/abs/core-testing/mythinstall/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jams
pkgname=mythinstall
pkgver=2
-pkgrel=26
+pkgrel=28
pkgdesc="LinHES installer/systemconfig GUI."
arch=i686
depends=()
diff --git a/abs/core-testing/mythtv/stable-0.22/mythtv/PKGBUILD b/abs/core-testing/mythtv/stable-0.22/mythtv/PKGBUILD
index 87dbbb5..4718d8d 100755
--- a/abs/core-testing/mythtv/stable-0.22/mythtv/PKGBUILD
+++ b/abs/core-testing/mythtv/stable-0.22/mythtv/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=mythtv
pkgver=0.22
-pkgrel=22012
+pkgrel=22013
pkgdesc="A personal video recorder for Linux"
url="http://www.mythtv.org"
license="GPL"
@@ -100,4 +100,9 @@ build() {
mkdir -p $startdir/pkg/etc/cron.hourly/
install -m0755 $startdir/src/pretty $startdir/pkg/etc/cron.hourly/
}
-
+md5sums=('7ef6de58240e7aad389a0b13d91b1cf6'
+ '2babd4b8e146a7538d18dcd55695b0be'
+ 'aa50bfa75ceceb0bdd5c1e4508690693'
+ 'f735805a80b0d1180dee01f9df1b7004'
+ 'f407d6af23e74a49540755420f84fa58'
+ 'f944c51c40208fdb3d8e3dd3d8c60bf3')
diff --git a/abs/core-testing/mythtv/stable-0.22/mythtv/pretty b/abs/core-testing/mythtv/stable-0.22/mythtv/pretty
index 1cfc57b..8b0e051 100755
--- a/abs/core-testing/mythtv/stable-0.22/mythtv/pretty
+++ b/abs/core-testing/mythtv/stable-0.22/mythtv/pretty
@@ -1,2 +1,11 @@
#!/bin/bash
-su - mythtv -c "perl /usr/share/mythtv/contrib/user_jobs/mythrename.pl --link /myth/pretty"
+#!/bin/bash
+if [ -f /usr/share/mythtv/contrib/user_jobs/mythlink.pl ]
+then
+ su - mythtv -c "perl /usr/share/mythtv/contrib/user_jobs/mythlink.pl --link /myth/pretty"
+elif [ -f /usr/share/mythtv/contrib/user_jobs/mythrename.pl ]
+then
+ su - mythtv -c "perl /usr/share/mythtv/contrib/user_jobs/mythrename.pl --link /myth/pretty"a
+fi
+
+
diff --git a/abs/core-testing/mythtv/trunk/mythtv/PKGBUILD b/abs/core-testing/mythtv/trunk/mythtv/PKGBUILD
index 2a6f2a4..8d27f31 100755
--- a/abs/core-testing/mythtv/trunk/mythtv/PKGBUILD
+++ b/abs/core-testing/mythtv/trunk/mythtv/PKGBUILD
@@ -89,3 +89,8 @@ build() {
install -m0755 $startdir/src/pretty $startdir/pkg/etc/cron.hourly/
}
+md5sums=('7ef6de58240e7aad389a0b13d91b1cf6'
+ '2babd4b8e146a7538d18dcd55695b0be'
+ 'f735805a80b0d1180dee01f9df1b7004'
+ 'f407d6af23e74a49540755420f84fa58'
+ 'f944c51c40208fdb3d8e3dd3d8c60bf3')
diff --git a/abs/core-testing/mythtv/trunk/mythtv/pretty b/abs/core-testing/mythtv/trunk/mythtv/pretty
index 1cfc57b..8b0e051 100755
--- a/abs/core-testing/mythtv/trunk/mythtv/pretty
+++ b/abs/core-testing/mythtv/trunk/mythtv/pretty
@@ -1,2 +1,11 @@
#!/bin/bash
-su - mythtv -c "perl /usr/share/mythtv/contrib/user_jobs/mythrename.pl --link /myth/pretty"
+#!/bin/bash
+if [ -f /usr/share/mythtv/contrib/user_jobs/mythlink.pl ]
+then
+ su - mythtv -c "perl /usr/share/mythtv/contrib/user_jobs/mythlink.pl --link /myth/pretty"
+elif [ -f /usr/share/mythtv/contrib/user_jobs/mythrename.pl ]
+then
+ su - mythtv -c "perl /usr/share/mythtv/contrib/user_jobs/mythrename.pl --link /myth/pretty"a
+fi
+
+
diff --git a/abs/core-testing/php/PKGBUILD b/abs/core-testing/php/PKGBUILD
index 65862a9..9e297f0 100644
--- a/abs/core-testing/php/PKGBUILD
+++ b/abs/core-testing/php/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=php
pkgver=5.2.6
-pkgrel=29
+pkgrel=31
_suhosinver=0.9.6.2
pkgdesc='A high-level scripting language'
arch=('i686' 'x86_64')
diff --git a/abs/core-testing/php/php.install b/abs/core-testing/php/php.install
index 469db4a..1981a63 100644
--- a/abs/core-testing/php/php.install
+++ b/abs/core-testing/php/php.install
@@ -4,7 +4,7 @@ post_install() {
. /etc/systemconfig
if [ -f /etc/php/php.ini ]
then
- sed -i 's/^.*date.timezone.*$/date.timezone='${timezone}'/' /etc/php/php.ini
+ sed -i 's|^.*date.timezone.*$|date.timezone='${timezone}'|' /etc/php/php.ini
fi
fi
}
@@ -40,7 +40,7 @@ post_upgrade() {
. /etc/systemconfig
if [ -f /etc/php/php.ini ]
then
- sed -i 's/^.*date.timezone.*$/date.timezone='${timezone}'/' /etc/php/php.ini
+ sed -i 's|^.*date.timezone.*$|date.timezone='${timezone}'|' /etc/php/php.ini
fi
fi
echo 'Updating extension dir...'
diff --git a/abs/core-testing/runit/PKGBUILD b/abs/core-testing/runit/PKGBUILD
index 90bb57e2..bb3a4f5 100755
--- a/abs/core-testing/runit/PKGBUILD
+++ b/abs/core-testing/runit/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=runit
pkgver=1.8.0
-pkgrel=62
+pkgrel=64
pkgdesc="A replacement for sysvinit, and other init schemes, with service supervision"
url="http://smarden.org/runit/"
license="BSD"
@@ -64,3 +64,10 @@ build() {
}
+md5sums=('46549303a336bee8f627bfb399d44085'
+ '5828ac37537d60ded00252dc02d462c6'
+ '984dbe096b0db26ad9f3f5b51addd9c9'
+ 'e347ea8cf2981f2cd4105111ea1ce1d4'
+ '263198ec006b87891ea0f3ab1d103086'
+ '3ec5f3013dcbd60b6b957d17ba220585'
+ 'febe6821f4bea3bfa93f4b6d3df4d801')
diff --git a/abs/core-testing/runit/shutdown.script b/abs/core-testing/runit/shutdown.script
index 3bcc5d3..229996b 100755
--- a/abs/core-testing/runit/shutdown.script
+++ b/abs/core-testing/runit/shutdown.script
@@ -23,9 +23,8 @@ then
done
if [ x$delay = x ]
then
- echo "-t is mandatory"
- exit 4
- fi
+ delay=0
+ fi
if [ x$reboot = x1 ]
then
diff --git a/abs/core-testing/unclutter/PKGBUILD b/abs/core-testing/unclutter/PKGBUILD
index 5622394..64e808d 100755
--- a/abs/core-testing/unclutter/PKGBUILD
+++ b/abs/core-testing/unclutter/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=unclutter
pkgver=8
-pkgrel=1
+pkgrel=5
pkgdesc="Hides mouse cursor when not in use"
url="http://www.x.org/contrib/utilities/unclutter-8.README"
license="GPL"
@@ -8,10 +8,10 @@ depends=(x-server)
makedepends=()
conflicts=()
replaces=()
-backup=()
+backup=(etc/unclutter.cfg)
install=
arch='i686'
-source=(ftp://ftp.x.org/contrib/utilities/$pkgname-$pkgver.tar.Z)
+source=(ftp://ftp.x.org/contrib/utilities/$pkgname-$pkgver.tar.Z unclutter.cfg)
build() {
@@ -19,4 +19,10 @@ build() {
make LDLIBS=-L/usr/X11R6/lib || return 1
mkdir -p $startdir/pkg/usr/X11R6/bin
make DESTDIR=$startdir/pkg BINDIR=$startdir/pkg/usr/X11R6/bin install
+ mkdir -p $startdir/pkg/etc
+ cp -f $startdir/src/unclutter.cfg $startdir/pkg/etc/unclutter.cfg
}
+md5sums=('83d7a6498b69078f869378f801b6a84b'
+ '7277205ebd875a0175a5fdb184c6373c')
+md5sums=('83d7a6498b69078f869378f801b6a84b'
+ '07815312d084a31595cd90ab45c68727')
diff --git a/abs/core-testing/unclutter/unclutter.cfg b/abs/core-testing/unclutter/unclutter.cfg
new file mode 100644
index 0000000..e097b95
--- /dev/null
+++ b/abs/core-testing/unclutter/unclutter.cfg
@@ -0,0 +1,2 @@
+idle=1
+jitter=200