summaryrefslogtreecommitdiffstats
path: root/abs/core-testing
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing')
-rwxr-xr-xabs/core-testing/LinHES-config/PKGBUILD2
-rwxr-xr-xabs/core-testing/LinHES-config/xconfig.sh27
-rw-r--r--abs/core-testing/etcnet/10-defaults3
-rwxr-xr-xabs/core-testing/etcnet/PKGBUILD2
4 files changed, 20 insertions, 14 deletions
diff --git a/abs/core-testing/LinHES-config/PKGBUILD b/abs/core-testing/LinHES-config/PKGBUILD
index 11b1a55..cea9c1c 100755
--- a/abs/core-testing/LinHES-config/PKGBUILD
+++ b/abs/core-testing/LinHES-config/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=LinHES-config
pkgver=1.0
-pkgrel=286
+pkgrel=290
conflicts=(MythVantage-config MythVantage-config-dev LinHES-config-dev )
pkgdesc="Install and configure your system"
depends=(bc libstatgrab mysql-python expect curl dnsutils parted sg3_utils nmbscan )
diff --git a/abs/core-testing/LinHES-config/xconfig.sh b/abs/core-testing/LinHES-config/xconfig.sh
index eaa84b6..e2a48ed 100755
--- a/abs/core-testing/LinHES-config/xconfig.sh
+++ b/abs/core-testing/LinHES-config/xconfig.sh
@@ -5,6 +5,7 @@ BASE=""
. /etc/profile
NVIDIA_96XX="$TEMPLATES/xorg/96xx_supported.txt"
#TEMPLATES="/usr/share/templates"
+MYTHHOME=$BASE/home/mythtv
function Xvalues {
CMDLINE=$(cat /proc/cmdline)
@@ -23,29 +24,31 @@ function Xvalues {
}
function presetupX {
- if [ "$XUseAdvanced" = 1 ]
+ if [ -f /etc/sysconfig/IGNORE_X ]
then
+ echo "Will not run xconfig.sh due to presence of /etc/sysconfig/IGNORE_X"
+ return 1
+ else
if [ "$XIgnoreConfig" = 1 ]
then
echo "Using User supplied X"
- if [ -f "$BASE/data/home/mythtv/templates/xorg.user" ]
+ if [ -f "$MYTHHOME/templates/xorg.user" ]
then
- cp -f "$BASE/data/home/mythtv/templates/xorg.user" "$XORG_CONF"
+ cp -f "$MYTHHOME/templates/xorg.user" "$XORG_CONF"
else
echo "Didn't find the file"
- echo "Copy your config file to $BASE/data/home/mythtv/templates/xorg.use" >> "$XORG_CONF"
+ echo "Copy your config file to $MYTHHOME/templates/xorg.user" > "$XORG_CONF"
fi
else
- setupAdvancedX
- fi
- else
- if [ -f /etc/sysconfig/IGNORE_X ]
- then
- echo "Will not run xconfig.sh due to presence of /etc/sysconfig/IGNORE_X"
- else
- setupX
+ if [ "$XUseAdvanced" = 1 ]
+ then
+ setupAdvancedX
+ else
+ setupX
+ fi
fi
fi
+
}
function setupAdvancedX {
diff --git a/abs/core-testing/etcnet/10-defaults b/abs/core-testing/etcnet/10-defaults
index 3eb9024..5897a89 100644
--- a/abs/core-testing/etcnet/10-defaults
+++ b/abs/core-testing/etcnet/10-defaults
@@ -1,6 +1,9 @@
DHCP_CLIENT=/sbin/dhcpcd
+DHCP_ARGS=-L
IP=/usr/sbin/ip
TC=/usr/sbin/tc
LSMOD=/bin/lsmod
IFGROUP[1]='eth wlan plip usb dvb bnep tuntap'
IFRENAME=/usr/sbin/ifrename
+IPTABLES=/usr/sbin/iptables
+IP6TABLES=/usr/sbin/ip6tables
diff --git a/abs/core-testing/etcnet/PKGBUILD b/abs/core-testing/etcnet/PKGBUILD
index bc69c83..39e1378 100755
--- a/abs/core-testing/etcnet/PKGBUILD
+++ b/abs/core-testing/etcnet/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=etcnet
pkgver=0.9.7
-pkgrel=9
+pkgrel=10
pkgdesc="/etc/net network configuration subsystem"
url="http://etcnet.org/"
depends=('bash' 'grep' 'sed' 'iproute' 'wireless_tools' 'iptables' 'dhcpcd')