summaryrefslogtreecommitdiffstats
path: root/abs/core-testing
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing')
-rw-r--r--abs/core-testing/LinHES-system/LinHES-run4
-rwxr-xr-xabs/core-testing/mythtv/stable/mythdb-initial/PKGBUILD2
-rw-r--r--abs/core-testing/mythtv/stable/mythdb-initial/mc.sql2
-rwxr-xr-xabs/core-testing/mythtv/stable/mythdb-initial/mythdb.install39
-rwxr-xr-xabs/core-testing/tweaker/bin/create-linhes-sql.sh2
5 files changed, 19 insertions, 30 deletions
diff --git a/abs/core-testing/LinHES-system/LinHES-run b/abs/core-testing/LinHES-system/LinHES-run
index ae6651f..259ffc7 100644
--- a/abs/core-testing/LinHES-system/LinHES-run
+++ b/abs/core-testing/LinHES-system/LinHES-run
@@ -24,7 +24,9 @@ if [ ! $SystemType = "Frontend_only" ]
then
if [ -f ~/.configure ]
then
- autocard.py -g &
+ sudo -E tweaker.pl
+ /bin/rm /tmp/fps # ??? clean up a temp file that will eventually be obsolete anyway
+ #autocard.py -g &
MythVantage -b
#0 yes
diff --git a/abs/core-testing/mythtv/stable/mythdb-initial/PKGBUILD b/abs/core-testing/mythtv/stable/mythdb-initial/PKGBUILD
index e965530..e7090bd 100755
--- a/abs/core-testing/mythtv/stable/mythdb-initial/PKGBUILD
+++ b/abs/core-testing/mythtv/stable/mythdb-initial/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=mythdb-initial
pkgver=1
-pkgrel=21
+pkgrel=24
pkgdesc="setup the initial mythtv database for linhes"
url=""
license=""
diff --git a/abs/core-testing/mythtv/stable/mythdb-initial/mc.sql b/abs/core-testing/mythtv/stable/mythdb-initial/mc.sql
index 58a5919..67b6726 100644
--- a/abs/core-testing/mythtv/stable/mythdb-initial/mc.sql
+++ b/abs/core-testing/mythtv/stable/mythdb-initial/mc.sql
@@ -2784,5 +2784,5 @@ INSERT INTO settings VALUES ('SecurityPin','0000','MythTVhost');
INSERT INTO settings VALUES ('BackendServerIP','127.0.0.1','MythTVhost');
INSERT INTO settings VALUES ('MasterServerIP','127.0.0.1','MythTVhost');
INSERT INTO settings VALUES ('MasterServerPort','6543','MythTVhost');
-INSERT INTO settings VALUES ('Theme', 'Iulius','MythTVhost');
+INSERT INTO settings VALUES ('Theme', 'LinHES','MythTVhost');
INSERT INTO storagegroup VALUES ('\N', 'Default','MythTVhost','/');
diff --git a/abs/core-testing/mythtv/stable/mythdb-initial/mythdb.install b/abs/core-testing/mythtv/stable/mythdb-initial/mythdb.install
index e15231e..7833aa4 100755
--- a/abs/core-testing/mythtv/stable/mythdb-initial/mythdb.install
+++ b/abs/core-testing/mythtv/stable/mythdb-initial/mythdb.install
@@ -1,36 +1,23 @@
mydate=`date +%m-%d-%y`
HOST=`hostname`
post_install() {
-#echo backup the old database
- mysqldump mythconverg >/data/database/mythconverg.${mydate}.sql
-# echo dropping the old database
- mysql -u root -e 'drop database mythconverg;'
- mysql -u root -e 'create database mythconverg;'
- echo installing the default database
- if [ $HOST = 'larch5' ]
- then
- cp /data/database/mc.sql.initial /data/database/mc.sql.fixed
- cp /data/database/permissions.sql /data/database/permissions.sql.fixed
- else
- sed -e "s/larch5/$HOST/g" /data/database/mc.sql.initial > /data/database/mc.sql.fixed
- sed -e "s/larch5/$HOST/g" /data/database/permissions.sql > /data/database/permissions.sql.fixed
+ echo archiving the old database
+ mysqldump mythconverg > /data/database/mythconverg.${mydate}.sql
- fi
-
- mysql mythconverg < /data/database/mc.sql.fixed 2>/dev/null
- mysql < /data/database/permissions.sql.fixed 2>/dev/null
-
- rm /data/database/mc.sql.initial
-
- # Run Tweaker to apply settings on top of baseline SQL.
- tweaker.pl
- /bin/rm /tmp/fps # ??? clean up a temp file that will eventually be obsolete anyway
+ echo installing the baseline database
+ sed -e "s/MythTVhost/$HOST/g" /data/database/mc.sql.initial > /data/database/mc.sql.fixed
+ sed -e "s/MythTVhost/$HOST/g" /data/database/permissions.sql > /data/database/permissions.sql.fixed
+ mysql < /data/database/mc.sql.fixed 2>/dev/null
+ mysql < /data/database/permissions.sql.fixed 2>/dev/null
+ # Keep the baseline SQL file around because it's useful to learn what changes users made
+ # to their Tweaker-customized defaults.
+ #rm /data/database/mc.sql.initial
}
post_upgrade() {
- echo "nothing to do"
+ echo "nothing to do"
}
-op=$1
-shift
+op=$1
+shift
$op $*
diff --git a/abs/core-testing/tweaker/bin/create-linhes-sql.sh b/abs/core-testing/tweaker/bin/create-linhes-sql.sh
index c4a7848..1f3a379 100755
--- a/abs/core-testing/tweaker/bin/create-linhes-sql.sh
+++ b/abs/core-testing/tweaker/bin/create-linhes-sql.sh
@@ -130,7 +130,7 @@ echo "INSERT INTO settings VALUES ('SecurityPin','0000','MythTVhost');" >> $LINH
echo "INSERT INTO settings VALUES ('BackendServerIP','127.0.0.1','MythTVhost');" >> $LINHES_SQL_PROTOTYPE
echo "INSERT INTO settings VALUES ('MasterServerIP','127.0.0.1','MythTVhost');" >> $LINHES_SQL_PROTOTYPE
echo "INSERT INTO settings VALUES ('MasterServerPort','6543','MythTVhost');" >> $LINHES_SQL_PROTOTYPE
-echo "INSERT INTO settings VALUES ('Theme', 'Iulius','MythTVhost');" >> $LINHES_SQL_PROTOTYPE
+echo "INSERT INTO settings VALUES ('Theme', 'LinHES','MythTVhost');" >> $LINHES_SQL_PROTOTYPE
echo "INSERT INTO storagegroup VALUES ('\N', 'Default','MythTVhost','/');" >> $LINHES_SQL_PROTOTYPE
rm $TMPFILE