summaryrefslogtreecommitdiffstats
path: root/abs/core-testing
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core-testing')
-rw-r--r--abs/core-testing/mythtv/stable/mythweb/PKGBUILD5
-rw-r--r--abs/core-testing/mythtv/stable/mythweb/patch/mythweb.pl.diff23
-rw-r--r--abs/core-testing/tweaker/PKGBUILD2
-rwxr-xr-xabs/core-testing/tweaker/bin/twk_audio.pl3
-rwxr-xr-xabs/core-testing/tweaker/bin/twk_cpu.pl4
-rwxr-xr-xabs/core-testing/tweaker/bin/twk_keymap.sh2
6 files changed, 31 insertions, 8 deletions
diff --git a/abs/core-testing/mythtv/stable/mythweb/PKGBUILD b/abs/core-testing/mythtv/stable/mythweb/PKGBUILD
index 768eba0..7496d9a 100644
--- a/abs/core-testing/mythtv/stable/mythweb/PKGBUILD
+++ b/abs/core-testing/mythtv/stable/mythweb/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=mythweb
pkgver=0.21
-pkgrel=13
+pkgrel=14
pkgdesc="Web interface for MythTV's backend"
arch=('i686' 'x86_64')
url="http://www.mythtv.org"
@@ -29,7 +29,8 @@ build() {
chown -R http:users $startdir/pkg/$DOCROOT
chmod g+rw $startdir/pkg/$DOCROOT/{image_cache,php_sessions,data}
-
+# Workaround for LIGHTTPD bug in mythweb.pl (affects DB queries)
+ patch -p0 < $startdir/patch/mythweb.pl.diff
}
diff --git a/abs/core-testing/mythtv/stable/mythweb/patch/mythweb.pl.diff b/abs/core-testing/mythtv/stable/mythweb/patch/mythweb.pl.diff
new file mode 100644
index 0000000..6dcbf99
--- /dev/null
+++ b/abs/core-testing/mythtv/stable/mythweb/patch/mythweb.pl.diff
@@ -0,0 +1,23 @@
+*** mythweb-unpatched.pl 2009-06-02 14:55:24.011861459 -0400
+--- mythweb.pl 2009-06-02 14:56:24.386441304 -0400
+***************
+*** 49,57 ****
+
+ # Connect to the database
+ END { $dbh->disconnect() if ($dbh); }
+! our $dbh = DBI->connect("dbi:mysql:database=$ENV{'db_name'}:host=$ENV{'db_server'}",
+! $ENV{'db_login'},
+! $ENV{'db_password'});
+ unless ($dbh) {
+ print header(),
+ "Cannot connect to database: $!\n\n";
+--- 49,57 ----
+
+ # Connect to the database
+ END { $dbh->disconnect() if ($dbh); }
+! our $dbh = DBI->connect("dbi:mysql:database=$ENV{'DB_NAME'}:host=$ENV{'DB_SERVER'}",
+! $ENV{'DB_LOGIN'},
+! $ENV{'DB_PASSWORD'});
+ unless ($dbh) {
+ print header(),
+ "Cannot connect to database: $!\n\n";
diff --git a/abs/core-testing/tweaker/PKGBUILD b/abs/core-testing/tweaker/PKGBUILD
index f546293..78052f8 100644
--- a/abs/core-testing/tweaker/PKGBUILD
+++ b/abs/core-testing/tweaker/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=tweaker
pkgver=1
-pkgrel=29
+pkgrel=30
pkgdesc=""
arch=('i686' 'x86_64')
diff --git a/abs/core-testing/tweaker/bin/twk_audio.pl b/abs/core-testing/tweaker/bin/twk_audio.pl
index eec7992..42a90d1 100755
--- a/abs/core-testing/tweaker/bin/twk_audio.pl
+++ b/abs/core-testing/tweaker/bin/twk_audio.pl
@@ -243,7 +243,8 @@ sub implement_option {
# Now, do what works for all sound devices.
- my $command = "su - mythtv -c \"aumix -v 70 -m 0 -l 0 -l R -w 70\""; # ok for analog and digital
+ #my $command = "su - mythtv -c \"aumix -v 70 -m 0 -l 0 -l R -w 70\""; # ok for analog and digital
+ my $command = "su - mythtv -c \"amixer -c 1 -- sset Master playback -20dB\""; # ok for analog and digital
if (my $error = execute_shell_command($command)) {
$logger->error("ERROR: $error");
diff --git a/abs/core-testing/tweaker/bin/twk_cpu.pl b/abs/core-testing/tweaker/bin/twk_cpu.pl
index fb256cb..118bac1 100755
--- a/abs/core-testing/tweaker/bin/twk_cpu.pl
+++ b/abs/core-testing/tweaker/bin/twk_cpu.pl
@@ -84,7 +84,7 @@ sub implement_option {
# }
}
case "medium" {
- change_or_make_setting('AutoCommflagWhileRecording', '0') || exit -1;
+ change_or_make_setting('AutoCommflagWhileRecording', '1') || exit -1;
change_or_make_setting('Theme', 'LinHES') || exit -1; # Moderate eye candy, moderate performance
#change_or_make_setting('PreferredMPEG2Decoder', 'libmpeg2') || exit -1; # Least CPU usage, lowest quality
#change_or_make_entry("displayprofiles", [["pref_decoder", "libmpeg2"]], [["profilegroupid", "1"], ["profileid", "1"]]) || exit -1; # Least CPU usage, lowest quality
@@ -94,7 +94,7 @@ sub implement_option {
case "high" {
change_or_make_setting('AutoCommflagWhileRecording', '1') || exit -1;
# ??? Interacts with screen aspect ratio
- change_or_make_setting('Theme', 'LinHES') || exit -1; # High eye candy, potentially low performance
+ change_or_make_setting('Theme', 'LinHES') || exit -1; # Moderate eye candy, moderate performance
#change_or_make_entry("displayprofiles", [["pref_decoder", "ffmpeg"]], [["profilegroupid", "1"], ["profileid", "1"]]) || exit -1; # Most CPU usage, best quality
#change_or_make_setting('PreferredMPEG2Decoder', 'ffmpeg') || exit -1; # Most CPU usage, best quality
change_or_make_setting('DefaultVideoPlaybackProfile', 'CPU++') || exit -1; # best playback defaults for powerful hardware
diff --git a/abs/core-testing/tweaker/bin/twk_keymap.sh b/abs/core-testing/tweaker/bin/twk_keymap.sh
index 7e4ef8b..2aa38ee 100755
--- a/abs/core-testing/tweaker/bin/twk_keymap.sh
+++ b/abs/core-testing/tweaker/bin/twk_keymap.sh
@@ -69,5 +69,3 @@ else
echo "ERROR: /etc/mplayer/input.conf is missing, which is unexpected."
exit -1
fi
-
-echo "Tweaked keymap" \ No newline at end of file