summaryrefslogtreecommitdiffstats
path: root/abs/core/LinHES-config/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/LinHES-config/PKGBUILD')
-rwxr-xr-x[-rw-r--r--]abs/core/LinHES-config/PKGBUILD100
1 files changed, 64 insertions, 36 deletions
diff --git a/abs/core/LinHES-config/PKGBUILD b/abs/core/LinHES-config/PKGBUILD
index 7cebf11..e1879b9 100644..100755
--- a/abs/core/LinHES-config/PKGBUILD
+++ b/abs/core/LinHES-config/PKGBUILD
@@ -1,15 +1,16 @@
pkgname=LinHES-config
pkgver=2.3
-pkgrel=80
+pkgrel=140
conflicts=(MythVantage-config MythVantage-config-dev LinHES-config-dev LinHes-config )
pkgdesc="Install and configure your system"
depends=('bc' 'libstatgrab' 'mysql-python' 'expect' 'curl' 'dnsutils' 'parted'
'sg3_utils' 'nmbscan' 'system-templates' 'rsync' 'python-parted'
- 'ddcxinfo' 'python-pexpect' 'python-netifaces' 'LinHES-timezone'
- 'python-iplib' 'mythinstall>=2-10')
-arch=('i686')
+ 'python-pexpect' 'python-netifaces'
+ 'python-iplib' 'mythinstall>=2-10' 'sudo' 'setserial')
+#LinHES-timezone
+arch=('i686' 'x86_64')
-source=(mv_install.py
+source=(mv_install.py 09_mythvantge_runit_grub
mv_config.py
myth_user_call
file_time_offset.py
@@ -23,7 +24,6 @@ source=(mv_install.py
timezip.py
soundconfig.sh
LinHES-release
- issue
MythVantage.sh
create_master.sh
build_diskless.sh
@@ -43,16 +43,23 @@ source=(mv_install.py
mv_webuser.py
mv_hostype.py
mv_supplemental.py
+ mv_vnc.py
+ mv_fileshare.py
systemconfig.py
myth_user_call.py
- mythvantage.cfg)
+ mythvantage.cfg
+ config-sudo.rules
+ hdhr.conf blacklist_nouveau.conf blacklist_pcspkr.conf
+ print_xorg_res.py backend_control.sh )
backup=(etc/mythvantage.cfg)
-install=LinHES.install
+install=config.install
build() {
mkdir -p $startdir/pkg/etc
mkdir -p $startdir/pkg/usr/share/mythtv/themes/default
+ install -D -m0755 09_mythvantge_runit_grub $startdir/pkg/etc/grub.d/09_mythvantge_runit_grub
+
MVDIR=$startdir/pkg/usr/MythVantage
mkdir $startdir/pkg/etc/profile.d
@@ -61,8 +68,7 @@ build() {
mkdir -p $MVDIR/etc
#copy in all the installer specific stuff
-# install -m0700 myth_user_call $MVDIR/bin/myth_user_call
- install -m0700 myth_user_call.py $MVDIR/bin/myth_user_call
+ install -m 0700 myth_user_call.py $MVDIR/bin/myth_user_call
install -m 0755 install_proxy.sh $MVDIR/bin/install_proxy.sh
install -m 0755 install_functions.sh $MVDIR/bin/install_functions.sh
install -m 0755 systemconfig.sh $MVDIR/bin/systemconfig.sh
@@ -91,7 +97,11 @@ build() {
install -m 0755 mv_webuser.py $MVDIR/bin/
install -m 0755 mv_hostype.py $MVDIR/bin/
install -m 0755 mv_supplemental.py $MVDIR/bin/
+ install -m 0755 mv_vnc.py $MVDIR/bin/
+ install -m 0755 mv_fileshare.py $MVDIR/bin/
install -m 0755 systemconfig.py $MVDIR/bin/
+ install -m 0755 print_xorg_res.py $MVDIR/bin/
+ install -m 0755 backend_control.sh $MVDIR/bin/
install -m 0755 mythvantage.cfg $startdir/pkg/etc/
#README file displayed on install
@@ -99,46 +109,64 @@ build() {
mkdir -p $startdir/pkg/usr/bin
install -m 0755 file_time_offset.py $startdir/pkg/usr/bin/file_time_offset.py
-
#Copy in the branding stuff
install -m 0755 LinHES-release $startdir/pkg/etc/LinHES-release
- install -m 0755 issue $startdir/pkg/etc/issue
+ #sudo rules
+ mkdir -p $startdir/pkg/etc/sudoers.d/
+ chmod 750 $startdir/pkg/etc/sudoers.d/
+ chown -R root:root $startdir/pkg/etc/sudoers.d
+ install -o root -g root -m 0750 config-sudo.rules $startdir/pkg/etc/sudoers.d/config_sudo
+
+ #sysctrl conf
+ install -o root -g root -D -m 0755 hdhr.conf $startdir/pkg/etc/sysctl.d/hdhr.conf
+
+ #modules blacklist files
+ install -o root -g root -D -m 0755 blacklist_pcspkr.conf $startdir/pkg/etc/modprobe.d/blacklist_pcspkr.conf
+ install -o root -g root -D -m 0755 blacklist_nouveau.conf $startdir/pkg/etc/modprobe.d/blacklist_nouveau.conf
}
-md5sums=('18af4fe481e1fc2ae02050026eb5cd27'
- '16b98fcb3753ef6cfc35075c326d30e4'
- 'e36da536dd651ef182e7642337889e77'
+md5sums=('d27979591231e647f59c23ae18a3d37b'
+ 'f33e1a6f7985091b8d47cbaf7433f90f'
+ '1afacd0337d95f140b2a1777c27f041a'
+ '2596460462cf6c889cf8f95485537b20'
'985891a43f7c4c983eb2a362162f1a0f'
- '13172731c8b08d669336da31cece5775'
- '5a31addfbdc1154b05997f972a32fa33'
- 'c20f73d4da5d7e15e1f3eb85c7dcb49a'
+ 'fda01259a4bc74d83c9092d338bd247a'
+ '768504ef10ecd11a22875ccea9fcf62b'
+ 'f73d6d6f98839e900cb6685bf5dc4eae'
'68199e861c2933ccbb84735b9b440157'
- '9ae8d79f620c6d19973c55c32a921874'
- '79579277e0545aeeb50fba403434194c'
- '960017a34d9cc78af6298f45aad6eb8e'
+ '2a7f3b34e522acfd08283b86c8926aba'
+ '4a538bdfbb2833c48bcffb4f82729de6'
+ '689b01f7636e09b2f9657c6ce6006ee7'
'ecf9e5df20683a769c4a8a8f2d65de85'
- '6d32a88e76b0a97b0ce67d37ef6394aa'
- 'eaafce1499980eded37b9ad4e8dce28b'
- '6aff504ed5e860adc1b7317cd0780900'
- '55fccb1da0417a896b724f7cfc32dd5a'
+ 'a6faa20d905e2fd92ce79acab044b759'
+ '8ba06c2ce6129371548cc360ccca27f8'
+ '5f890ea9bda6aef652d2560ca19dac07'
'ab2aa42c2947148c2b1cac0ade6d1d55'
'd429b59d3cfb37b0624c6a4a71a7c2c0'
- 'a225143e3df6f56d451c2875e54ddbae'
+ 'f6a935c35123fdc7c259c01cbc794a64'
'9151c74fcaf18ec4cf5e757cfdbc7017'
'3d1e4a119f38cff0498bf8a67e94e4b3'
'71fd2d0d448fc2fcd15415a1beed7109'
- '61ccbf573ee196e3edf53a512820b431'
- 'e1715bbbabd42e7419755b09f60734aa'
+ 'af6b3c5ec0d974b3e19ff1ed50662ee5'
+ '65c2dad8748210c3c0098efab377c330'
'b845de3e05c1734cce4b9ac5e8f1baaf'
- '6801f87992b44118a12b6dfe6ea68127'
- '5e69839659d65ddda35b8a9982dc29e9'
- '3afd18517bb765d1680f4fcc8d08c9cc'
- 'ec6a9961e4d1b53ec1240c5979efff11'
+ 'e869e2c72212881db1e4fa40b116efe5'
+ '8b7dce4a3a0a281fa6656aa8781a648e'
+ '2934fd80277e4598856f3171ccef9bfd'
+ '824e49d9b01fed295c704ab68908b464'
'fe5e31b833cc6707209e9d656b6eb53c'
'ecb52b9b7a9ac0c8988093c1dfdda635'
'23d0e12b7ca1cc6ea6b993c1d7ff20b9'
- '0b5b9e5385c7ae77e561812e96ce8161'
- '755c05b833aca6c5be130972af052e8b'
- 'd8f80e5686d02555f044363f1ac17d97'
+ 'cc5ee06e2182bb825ca3712a1c1afb64'
+ '919909f4d23b9ee3caf71193c042cc40'
+ '85101b79d1ee30bff8244c810828033f'
+ '923197a517cb83d77263e8cea8b8c16a'
+ '60611c3f90dbaafde9c41421b2bf759d'
'2596460462cf6c889cf8f95485537b20'
- 'a63ff9ef5250965aeabc74bfa8e43981')
+ '4cba2bb55c6b8e27c57a6171f42d0455'
+ '4804aa93aaad3dfcfff08cd9ffd68836'
+ '0fa6fffd87f350380d45f1f8a5b7babe'
+ '6ec39b010c0ed8901ea896c7e153d330'
+ '3866086e6af5e3528a66eff492f2f4dd'
+ 'c9279fa095af624ee3d9bc75d3328360'
+ '66a5e2dd3e51d11a93a17f7c01a8708f')