summaryrefslogtreecommitdiffstats
path: root/abs/core/LinHES-config
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/LinHES-config')
-rw-r--r--abs/core/LinHES-config/09_mythvantge_runit_grub2
-rw-r--r--abs/core/LinHES-config/LinHES-release2
-rwxr-xr-xabs/core/LinHES-config/PKGBUILD19
-rw-r--r--abs/core/LinHES-config/config.install7
-rwxr-xr-xabs/core/LinHES-config/mv_fileshare.py1
-rw-r--r--abs/core/LinHES-config/mv_install.py23
6 files changed, 32 insertions, 22 deletions
diff --git a/abs/core/LinHES-config/09_mythvantge_runit_grub b/abs/core/LinHES-config/09_mythvantge_runit_grub
index aef11a1..137d8f6 100644
--- a/abs/core/LinHES-config/09_mythvantge_runit_grub
+++ b/abs/core/LinHES-config/09_mythvantge_runit_grub
@@ -30,7 +30,7 @@ menuentry 'LinHES' --class arch --class gnu-linux --class gnu --class os $menuen
search --no-floppy --fs-uuid --set=root $boot_device_id
fi
echo 'Loading Linux core repo kernel ...'
- linux /boot/vmlinuz-linux root=UUID=$boot_device_id ro quiet splash udev.log-priority=3 init=/sbin/runit $install_modules
+ linux /boot/vmlinuz-linux root=UUID=$boot_device_id ro quiet splash udev.log-priority=3 loglevel=3 init=/sbin/runit $install_modules
echo 'Loading initial ramdisk ...'
initrd /boot/initramfs-linux.img
}
diff --git a/abs/core/LinHES-config/LinHES-release b/abs/core/LinHES-config/LinHES-release
index b3360a3..5afb5ff 100644
--- a/abs/core/LinHES-config/LinHES-release
+++ b/abs/core/LinHES-config/LinHES-release
@@ -1 +1 @@
-LinHES R8.5.1 (Gareth)
+LinHES R8.5.2 (Gareth)
diff --git a/abs/core/LinHES-config/PKGBUILD b/abs/core/LinHES-config/PKGBUILD
index 9d8cbc9..424d709 100755
--- a/abs/core/LinHES-config/PKGBUILD
+++ b/abs/core/LinHES-config/PKGBUILD
@@ -1,12 +1,13 @@
pkgname=LinHES-config
-pkgver=8.5.1
-pkgrel=2
+pkgver=8.5.2
+pkgrel=3
conflicts=(MythVantage-config MythVantage-config-dev LinHES-config-dev LinHes-config )
pkgdesc="Install and configure your system"
depends=('bc' 'libstatgrab' 'mysql-python' 'expect' 'curl' 'dnsutils' 'parted'
- 'sg3_utils' 'nmbscan' 'system-templates' 'rsync' 'python-parted'
- 'python2-pexpect' 'python-netifaces' 'xcursor-vanilla-dmz-aa'
- 'python-iplib' 'sudo' 'setserial' 'udevil' 'balance' 'runit-scripts>=8.3-4' )
+ 'sg3_utils' 'nmbscan' 'system-templates' 'rsync' 'python2-pyparted'
+ 'python2-pexpect' 'python-netifaces' 'xcursor-vanilla-dmz-aa'
+ 'python-iplib' 'sudo' 'setserial' 'udevil' 'balance'
+ 'mythinstall' 'runit-scripts>=8.3-4' )
arch=('i686' 'x86_64')
source=(mv_install.py 09_mythvantge_runit_grub
@@ -144,8 +145,8 @@ package() {
install -o root -g root -D -m 0755 blacklist_nouveau.conf $pkgdir/etc/modprobe.d/blacklist_nouveau.conf
}
-md5sums=('518c868141fe443e9258144c029ed3f9'
- '51525188ac6f6034422c5d71d0c84408'
+md5sums=('49952a2375b8ee53d8673473f22f8d12'
+ 'bee51ac2c232ab134eec127f5c8846ad'
'f6e9dd7bc6cf0aaa3bd203dab4cb79b9'
'2596460462cf6c889cf8f95485537b20'
'985891a43f7c4c983eb2a362162f1a0f'
@@ -159,7 +160,7 @@ md5sums=('518c868141fe443e9258144c029ed3f9'
'f0376c98a7986897406d393186c0365e'
'157e73d0f90d7b306aba8f5921aeedd3'
'1f58c0393a131f4a8f9a84b3fe08a7e4'
- '55ac9212faa4efa7f9cb67a35640817e'
+ '03ab4c6af061da01584b450ec83f26ed'
'5f890ea9bda6aef652d2560ca19dac07'
'ab2aa42c2947148c2b1cac0ade6d1d55'
'd429b59d3cfb37b0624c6a4a71a7c2c0'
@@ -182,7 +183,7 @@ md5sums=('518c868141fe443e9258144c029ed3f9'
'8be8ce5f1d8522b1cde12d34840865c2'
'80685e047993b00161be29e3580f3a40'
'0e1c98392887b6efcb3f8b04ead7c4f9'
- '3cb673adb83b6afa52cffaa621b9d96b'
+ '3d84d2b508a73733e8d593e551b21081'
'781f161a79c3188a31c8615b8258b241'
'44e32e7015612cbf5d9f6539f4b6799b'
'6cb0aac63623a44463c4209862d2baa0'
diff --git a/abs/core/LinHES-config/config.install b/abs/core/LinHES-config/config.install
index 50c66c7..332f033 100644
--- a/abs/core/LinHES-config/config.install
+++ b/abs/core/LinHES-config/config.install
@@ -40,7 +40,12 @@ post_upgrade() {
/usr/MythVantage/bin/systemconfig.py -m hostype
fi
- /usr/MythVantage/bin/systemconfig.py -m locale,vnc,ir
+ if [ $(vercmp $2 8.5.1-4) -lt 0 ]; then
+ #reconfig to include grub
+ /usr/MythVantage/bin/systemconfig.py -m locale,vnc,ir,advanced
+ else
+ /usr/MythVantage/bin/systemconfig.py -m locale,vnc,ir
+ fi
echo " Removing pts and shm from fstab..."
cp -a /etc/fstab /etc/fstab.backup.pre_pts_shm
diff --git a/abs/core/LinHES-config/mv_fileshare.py b/abs/core/LinHES-config/mv_fileshare.py
index 5844a2f..3311bb8 100755
--- a/abs/core/LinHES-config/mv_fileshare.py
+++ b/abs/core/LinHES-config/mv_fileshare.py
@@ -441,6 +441,7 @@ def setup_NFSshares(UseNFS,templatefile,data_config,servername,nfslist):
else:
logging.info(" Removing NFS server")
mv_common.remove_service("nfsd")
+ mv_common.remove_service("nfs-common")
return
def setup_dyndns(DDnsEnable):
diff --git a/abs/core/LinHES-config/mv_install.py b/abs/core/LinHES-config/mv_install.py
index f414942..bf53476 100644
--- a/abs/core/LinHES-config/mv_install.py
+++ b/abs/core/LinHES-config/mv_install.py
@@ -82,10 +82,13 @@ def kill_dhcp_chroot():
pass
#force kill
try:
- cmd = "lsof -t /new_boot|xargs kill -9"
+ #cmd = "lsof -t /new_boot|xargs kill -9"
+ #newer versions of lsof show /dev/pts bind mounts
+ #even after they are umounted
+ cmd = "fuser -mk /new_boot"
runcmd(cmd)
except:
- print " !!!Problem killing all /new_boot pids"
+ logging.debug("!!!Problem killing all /new_boot pids")
@@ -218,7 +221,7 @@ def mysqldb(cmd, inchroot):
if cmd == "start":
cmd = "chroot /new_boot /etc/rc.d/mysqld start"
elif cmd == "stop":
- cmd = " chroot /new_boot /etc/rc.d/mysqld stop"
+ cmd = "chroot /new_boot /etc/rc.d/mysqld stop"
else:
if cmd == "start":
cmd = "systemctl start mysqld.service"
@@ -748,10 +751,10 @@ def mount_for_copy_it():
#Versions of util-linux mount after 2.28.2 do not allow 1 image to be
# mounted to multiple loop devices.
#Our ISO mounts airootfs.img to both / and /image_mount
- cmd = 'tar -xvf /tmp/mount2.28.2.tar.xz -C /tmp/'
+ cmd = 'tar -xvf /root/linhes_install/mount2.28.2.tar.xz -C /root/linhes_install/'
rc = runcmd(cmd)[0]
if rc != 0 :
- error_out("Failed to extract static mount from /tmp/mount2.28.2.tar.xz")
+ error_out("Failed to extract static mount from /root/linhes_install/mount2.28.2.tar.xz")
mounts = {}
mounts['/image_mount'] = 'airootfs'
@@ -760,7 +763,7 @@ def mount_for_copy_it():
os.makedirs(image_mount)
except:
pass
- cmd = '/tmp/mount /run/archiso/sfs/%s/%s.img %s' %(fsimage,fsimage,image_mount)
+ cmd = '/root/linhes_install/mount /run/archiso/sfs/%s/%s.img %s' %(fsimage,fsimage,image_mount)
rc = runcmd(cmd)[0]
if rc != 0 :
error_out("Mount image %s" %fsimage)
@@ -770,7 +773,7 @@ def umount_for_copy_it():
mounts = {}
mounts['/image_mount'] = 'airootfs'
for image_mount, fsimage in mounts.iteritems():
- cmd='/tmp/umount %s' %(image_mount)
+ cmd='/root/linhes_install/umount %s' %(image_mount)
rc = runcmd(cmd)[0]
if rc != 0 :
error_out("unMount image %s" %image_mount)
@@ -784,7 +787,7 @@ def copy_it(install_type):
if ( install_type == "install"):
logging.info("Transferring system")
- cmdlist = ['rsync -arp --exclude var-lib-pacman --exclude boot-orig --exclude tmp/mount2.28.2.tar.xz /image_mount/* /new_boot']
+ cmdlist = ['rsync -arp --exclude var-lib-pacman --exclude boot-orig /image_mount/* /new_boot']
for cmd in cmdlist:
rc = runcmd(cmd)[0]
@@ -796,7 +799,7 @@ def copy_it(install_type):
if ( install_type == "upgrade"):
logging.info("Upgrading system")
- cmdlist = ['rsync -arp --exclude var-lib-pacman --exclude boot-orig --exclude tmp/mount2.28.2.tar.xz --exclude /home --exclude /data/srv/mysql /image_mount/* /new_boot']
+ cmdlist = ['rsync -arp --exclude var-lib-pacman --exclude boot-orig --exclude /home --exclude /data/srv/mysql /image_mount/* /new_boot']
for cmd in cmdlist:
rc = runcmd(cmd)[0]
@@ -1653,7 +1656,7 @@ def full_install(hostoptions):
else:
double_mount(fe_only=True)
#move_myth_home("restore")
-# Need to check for to touch /tmp/.dbsysfailed
+ #Need to check for to touch /tmp/.dbsysfailed
#cmd = " chroot %s %s/bin/myth_settings_wrapper.sh -c restore -t syssettings " %(data_config.MOUNTPOINT, MVROOT)
#runcmd(cmd)
if ( 'x' == '1' ):