summaryrefslogtreecommitdiffstats
path: root/abs/core/LinHES-system/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/LinHES-system/PKGBUILD')
-rwxr-xr-xabs/core/LinHES-system/PKGBUILD32
1 files changed, 23 insertions, 9 deletions
diff --git a/abs/core/LinHES-system/PKGBUILD b/abs/core/LinHES-system/PKGBUILD
index d0012c1..ef5b2e8 100755
--- a/abs/core/LinHES-system/PKGBUILD
+++ b/abs/core/LinHES-system/PKGBUILD
@@ -1,16 +1,26 @@
pkgname=LinHES-system
pkgver=2
-pkgrel=13
+pkgrel=22
arch=('i686')
MVDIR=$startdir/pkg/usr/LH
BINDIR=$startdir/pkg/usr/bin
install=LinHES.install
pkgdesc="scripts and things related to having an automated system"
-depends=(linhes-sounds xdotool fluxbox tilda keylaunch python_aosd)
+depends=(linhes-sounds xdotool fluxbox tilda keylaunch python_aosd 'linhes-scripts>=7-24' 'runit-scripts>=2.1.1-43')
backup=(etc/modprobe.d/alsa-base)
-binfiles="LinHES-start optimize_mythdb.py myth_mtc.py myth_mtc.sh LinHES-run firstboot.sh load-modules-mythvantage.sh unclutter-toggle.sh tvterm.sh myth_mtc.lr smolt.cron mythfrontend-start set_windowmanager.sh myth_status.py myth_status.sh xmsg.py install_supplemental_service.sh"
+binfiles="LinHES-start optimize_mythdb.py
+ myth_mtc.py myth_mtc.sh LinHES-run
+ firstboot.sh load-modules-mythvantage.sh
+ unclutter-toggle.sh tvterm.sh smolt.cron
+ mythfrontend-start set_windowmanager.sh
+ myth_status.py myth_status.sh
+ xmsg.py install_supplemental_service.sh
+ lh_system_backup_job
+ lh_system_restore_job
+ lh_system_host_update
+ lh_system_all_host_update"
-source=(LinHES-session LinHES-profile.sh $binfiles alsa-base)
+source=(LinHES-session LinHES-profile.sh $binfiles alsa-base myth_mtc.lr)
build() {
cd $startdir/src
@@ -37,23 +47,27 @@ build() {
mkdir $startdir/pkg/etc/logrotate.d
cp $startdir/myth_mtc.lr $startdir/pkg/etc/logrotate.d
}
-md5sums=('989c22c2eae00501f5b46f215dbf5e59'
+md5sums=('71a1fc9b01476b0b2c30596107eeff75'
'5881bdb43d578ec3a79d1f77ea58a3db'
'a875ee97f86e46f34a741c2bc455f894'
'76b2637cac0452b3acdbeeb4e8a5474b'
- '6a42d3799fad2ebffac2fbf2411511ed'
+ 'd1f27cb422010077c841376526fe46ea'
'2ef9f945e034119f77d9b6beb17e4fa5'
'f7ecc552a2823cae63d75f58dc7435c4'
'18a884a73344ff6eb74f63b49745e0f5'
'dc3eef2a624754e16805d72bbe488b67'
'dc0be354ce77ba2b89868fc29b942c43'
'542e670e78d117657f93141e9689f54d'
- 'f1870a9522c79e6b248fcbf81dec3280'
'abe887472a170bd1a8e6da6a7b7e93e4'
'752488eb8bfb672ce0e4c924f7faf3d1'
- 'dae4dfb638b11c8c79fb1424a60b762a'
+ 'ba351b92e69bcaf26a9bf80417b09c3c'
'361bf81a6a117d61c3bc32dda91c4cb9'
'ce72aad1fc66c575f863d4bfbf65ce16'
'd03aedeeeda0f5e9c1eb437411c88477'
'94ce8f1d5085c0db7b267db8c2e9a3ff'
- 'eb879fee9603a05d5420d4ce8ed9e450')
+ '3db82bd7b9234fc941e4a53b464e0d46'
+ '9c2294ccfd5359583497a6b03d918a27'
+ '859a80ddb4c234506379c605114c1343'
+ '47e093e8cfe4b5b96602358e1f540832'
+ 'eb879fee9603a05d5420d4ce8ed9e450'
+ 'f1870a9522c79e6b248fcbf81dec3280')