summaryrefslogtreecommitdiffstats
path: root/abs/core/LinHES-system/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/LinHES-system/PKGBUILD')
-rwxr-xr-x[-rw-r--r--]abs/core/LinHES-system/PKGBUILD60
1 files changed, 36 insertions, 24 deletions
diff --git a/abs/core/LinHES-system/PKGBUILD b/abs/core/LinHES-system/PKGBUILD
index 686d3bc..94c982e 100644..100755
--- a/abs/core/LinHES-system/PKGBUILD
+++ b/abs/core/LinHES-system/PKGBUILD
@@ -1,35 +1,38 @@
pkgname=LinHES-system
pkgver=2
-pkgrel=60
-arch=('i686')
+pkgrel=95
+arch=('i686' 'x86_64')
MVDIR=$startdir/pkg/usr/LH
BINDIR=$startdir/pkg/usr/bin
-install=LinHES.install
+#install=LinHES-system.install
pkgdesc="scripts and things related to having an automated system"
-depends=(linhes-sounds xdotool fluxbox tilda keylaunch python_aosd 'linhes-scripts>=7-24' 'runit-scripts>=2.1.1-43' 'udisks' 'LinHES-config>=2.3-59')
+depends=(linhes-sounds xdotool tilda keylaunch python_aosd 'linhes-scripts>=7-24' 'udisks' 'LinHES-config>=2.3-59' 'sudo' 'python2-dbus' 'unclutter' 'wmctrl' 'archlinux-xdg-menu')
backup=(etc/modprobe.d/alsa-base)
binfiles="LinHES-start optimize_mythdb.py
myth_mtc.py myth_mtc.sh LinHES-run
- firstboot.sh load-modules-mythvantage.sh
+ load-modules-mythvantage.sh
unclutter-toggle.sh tvterm.sh
mythfrontend-start set_windowmanager.sh
myth_status.py myth_status.sh
- xmsg.py install_supplemental_service.sh
+ msg_osd.py install_supplemental_service.sh
lh_system_backup_job
lh_system_restore_job
lh_system_host_update
lh_system_all_host_update
add_storage.py
diskspace.sh
- cacheclean lh_message.sh switch_web.sh
+ cacheclean lh_message.sh lh_backend_control.sh switch_web.sh
+ create_media_dirs.sh
+ msg_client.py msg_daemon.py gen_is_xml.py gen_lib_xml.py
misc_recent_recordings.pl
misc_status_config.py
misc_status_info.sh
misc_upcoming_recordings.pl
misc_which_recorder.pl"
-source=(LinHES-session LinHES-profile.sh $binfiles alsa-base myth_mtc.lr
- diskspace smolt.cron cacheclean.cron)
+source=(LinHES-session LinHES-profile.sh $binfiles alsa-base myth_mtc.lr
+ diskspace cacheclean.cron readme_is_xml add_storage.readme)
+
build() {
cd $startdir/src
install -m755 -D LinHES-session $startdir/pkg/etc/X11/Sessions/LinHES
@@ -48,48 +51,57 @@ build() {
item=$i
install -m755 -D $item $MVDIR/bin/$item
echo $item
- done
+ done
install -m644 -D $startdir/src/alsa-base $startdir/pkg/etc/modprobe.d/alsa-base.conf
- install -m755 -D $startdir/src/smolt.cron $startdir/pkg/etc/cron.weekly/smolt.cron
+ install -m644 -D $startdir/src/readme_is_xml $startdir/pkg/etc/gen_is_xml.d/readme_is_xml
+ install -m644 -D $startdir/src/readme_is_xml $startdir/pkg/etc/gen_lib_xml.d/readme_gen_xml
+ install -m644 -D $startdir/src/add_storage.readme $startdir/pkg/etc/storage.d/readme
+ # install -m755 -D $startdir/src/smolt.cron $startdir/pkg/etc/cron.weekly/smolt.cron
install -m755 -D $startdir/src/cacheclean.cron $startdir/pkg/etc/cron.weekly/cacheclean.cron
install -m755 -D $startdir/src/diskspace $startdir/pkg/etc/cron.tenminutes/diskspace
mkdir $startdir/pkg/etc/logrotate.d
cp $startdir/myth_mtc.lr $startdir/pkg/etc/logrotate.d
}
-md5sums=('d1a5963c5a440a608031c6d750232633'
+md5sums=('a941af97fe534731a507b1d57c0c2aed'
'5881bdb43d578ec3a79d1f77ea58a3db'
'a875ee97f86e46f34a741c2bc455f894'
'76b2637cac0452b3acdbeeb4e8a5474b'
- 'd1f27cb422010077c841376526fe46ea'
+ '781c977f8872543f033dad2caaf0458e'
'2ef9f945e034119f77d9b6beb17e4fa5'
'4b4585ccba30595cf958d202997c57f7'
- 'cbe4cba14fa9d01a62e2196edc1bd98b'
'dc3eef2a624754e16805d72bbe488b67'
'dc0be354ce77ba2b89868fc29b942c43'
'542e670e78d117657f93141e9689f54d'
'41951459ea9d2b0567be521b67e6285a'
- 'ba351b92e69bcaf26a9bf80417b09c3c'
+ 'ee6b9d277843e7047f46bdd83e1377ec'
'4545eb39213d40b5a2bdeda5e066cdc4'
'962a3e9eaba2d1466251b7ab0956705d'
'd03aedeeeda0f5e9c1eb437411c88477'
'94ce8f1d5085c0db7b267db8c2e9a3ff'
- '16a2a3347961517fe7d95a2956a091a6'
- '9c2294ccfd5359583497a6b03d918a27'
+ '6a56efa9abcf914ebe380178749cf7ce'
+ '0e7b910fe26e9096e5531cd38f331292'
'859a80ddb4c234506379c605114c1343'
'47e093e8cfe4b5b96602358e1f540832'
- '6faeba0aeb38e772121f751cabda8683'
- '68e3e87571f3b0fa4a48a10df50dc220'
- '9603b0ca6e090eff31e76482a3c335e7'
- 'b798ee0796d1b760a2998f90eb8ce9cc'
+ '9f08fb2e821297841f1849c6221b87cb'
+ 'b8f0414427c5d9afdc32ceb3ae56f82a'
+ '6519d209e151cdc39ae7e1091d189c3e'
+ 'd1cdf28fcb1c88f0e504905771dd6040'
+ '88c669b8eeb988106bd26c9cf8277df2'
'4a3cd8f9b33b2b86fdba47a8f1fa2859'
+ '4d5a2441fe681c85986c5626c2944a3d'
+ 'a182af47a7d373b2a63a27e1bb7485b2'
+ '5148fe4c6ac27fff8152c819c4d2b47a'
+ 'ea315f41dcd6c978e546c95fc05546cf'
+ 'ac61cc460d9e97ba1f5ef69e92cdfbe5'
'06a628469051237943b7c874f2e29b8a'
'54ebcc024db2e0ebe8121305d8926767'
'45f46d1f9193c8dde18e56369ec29a1e'
'a8edbe7bc37e9932e8749d9f5f89c16f'
- '116b0f62ed4e8dd6e437930deeb6e49e'
+ 'afd621cd8a8cf5fcff5d00b9f340a9a9'
'eb879fee9603a05d5420d4ce8ed9e450'
'f1870a9522c79e6b248fcbf81dec3280'
'84492954db16740f949d795b74383189'
- 'abe887472a170bd1a8e6da6a7b7e93e4'
- '02c810c2f47b7c4495fdacaf54189473')
+ '02c810c2f47b7c4495fdacaf54189473'
+ '1e2ca4dd872a50df6b70528e06df558a'
+ 'da432d68962e109e09beb2b71c8c8571')