summaryrefslogtreecommitdiffstats
path: root/abs/core/LinHES-system
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/LinHES-system')
-rwxr-xr-xabs/core/LinHES-system/LinHES-session2
-rwxr-xr-xabs/core/LinHES-system/PKGBUILD8
-rwxr-xr-xabs/core/LinHES-system/add_storage.py5
3 files changed, 11 insertions, 4 deletions
diff --git a/abs/core/LinHES-system/LinHES-session b/abs/core/LinHES-system/LinHES-session
index c2b9b03..7960bf5 100755
--- a/abs/core/LinHES-system/LinHES-session
+++ b/abs/core/LinHES-system/LinHES-session
@@ -340,6 +340,8 @@ function run_wmctrl(){
function run_myth(){
if [ -f /tmp/nomfe ]
then
+ msg "MythFrontend will not start because /tmp/nomfe exists."
+ wait $pid
exit 0
else
if [ -f /tmp/debug ]
diff --git a/abs/core/LinHES-system/PKGBUILD b/abs/core/LinHES-system/PKGBUILD
index 4af9bea..2479cab 100755
--- a/abs/core/LinHES-system/PKGBUILD
+++ b/abs/core/LinHES-system/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=LinHES-system
pkgver=8.4
-pkgrel=10
+pkgrel=12
arch=('i686' 'x86_64')
install=system.install
pkgdesc="Everything that makes LinHES an automated system"
@@ -9,7 +9,7 @@ depends=('linhes-sounds' 'xdotool' 'tilda' 'keylaunch'
'python_aosd' 'udisks' 'LinHES-config>=2.3-59' 'sudo'
'python2-dbus' 'unclutter' 'wmctrl' 'archlinux-xdg-menu'
'ethtool' 'gnu-netcat' 'normalize' 'ttf-overlock'
- 'handbrake-cli' 'mkvtoolnix' 'mplayer' 'runit-scripts>=8.1-12')
+ 'handbrake-cli' 'mkvtoolnix-cli' 'mplayer' 'runit-scripts>=8.1-12')
backup=('etc/modprobe.d/alsa-base.conf' 'etc/X11/autostart/autostart.run')
binfiles="LinHES-start optimize_mythdb.py myth_mtc.py
load-modules-mythvantage.sh unclutter-toggle.sh tvterm.sh
@@ -79,7 +79,7 @@ package() {
}
-md5sums=('c03d5e54f00e404c561c7dc69fff9168'
+md5sums=('c6e6b83a1f4c35ef4501e277657ab2ac'
'ad5e144999b6f37931dea799c2761c7e'
'de32a1c50101265dd7f6ca5037f7a26a'
'2d7b8414ddce5f401331342ac1529c22'
@@ -100,7 +100,7 @@ md5sums=('c03d5e54f00e404c561c7dc69fff9168'
'bc69a520add58ede9b060c73e67ace13'
'74e17d6f7453c52d56fecaed5c3f6ad5'
'47e093e8cfe4b5b96602358e1f540832'
- 'e270f46a1737a52e8f6b915830ef65f7'
+ '9d1ad3c698296a1f8790c5cdc85483e3'
'0c81e5cad656f6260e39cd7585b1421a'
'e5bb027c54a2727d0bcf8d6fb357ba32'
'2c005d95312018bef80092136f80f254'
diff --git a/abs/core/LinHES-system/add_storage.py b/abs/core/LinHES-system/add_storage.py
index 260421f..853c39e 100755
--- a/abs/core/LinHES-system/add_storage.py
+++ b/abs/core/LinHES-system/add_storage.py
@@ -57,6 +57,7 @@ class disk_device:
self.model = self.get_model(device_props)
self.mmount = False
+ self.dir_sg = False
self.f = self.get_mounts(device_props)
self.is_mounted = self.get_is_mounted(device_props)
@@ -80,6 +81,9 @@ class disk_device:
def set_mmount(self,flag):
self.mmount = flag
+ def set_dir_sg(self,flag):
+ self.dir_sg = flag
+
def set_disk_num(self,num):
self.disk_num=num
@@ -730,6 +734,7 @@ def myth_main(no_mount,install_call,dir_sg):
print " Disk: %s" %(i.get_name())
i.set_mmount(True)
+ i.set_dir_sg(dir_sg)
i.set_partition("7")
i.set_disk_num(0)
i.lookup_format()