summaryrefslogtreecommitdiffstats
path: root/abs/core/aspell
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/aspell')
-rw-r--r--abs/core/aspell/PKGBUILD13
-rw-r--r--abs/core/aspell/__changelog1
-rw-r--r--abs/core/aspell/aspell.install24
-rw-r--r--abs/core/aspell/gcc7fixes.patch37
4 files changed, 45 insertions, 30 deletions
diff --git a/abs/core/aspell/PKGBUILD b/abs/core/aspell/PKGBUILD
index 50c9264..2cdaf6d 100644
--- a/abs/core/aspell/PKGBUILD
+++ b/abs/core/aspell/PKGBUILD
@@ -8,20 +8,21 @@
pkgname=aspell
pkgver=0.60.6.1
_pkgmajorver=0.60
-pkgrel=2
+pkgrel=5
pkgdesc="A spell checker designed to eventually replace Ispell"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="http://aspell.net/"
license=('LGPL')
depends=('gcc-libs' 'ncurses')
optdepends=('perl: to import old dictionaries')
-install=aspell.install
-source=(ftp://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.gz)
-md5sums=('e66a9c9af6a60dc46134fdacf6ce97d7')
-sha1sums=('ff1190db8de279f950c242c6f4c5d5cdc2cbdc49')
+source=(ftp://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.gz
+ gcc7fixes.patch)
+sha1sums=('ff1190db8de279f950c242c6f4c5d5cdc2cbdc49'
+ 'df5364a8472154452f4e1fe9db0891df457949e0')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -p1 < $srcdir/gcc7fixes.patch
./configure --prefix=/usr --sysconfdir=/etc
make
}
diff --git a/abs/core/aspell/__changelog b/abs/core/aspell/__changelog
new file mode 100644
index 0000000..beb9215
--- /dev/null
+++ b/abs/core/aspell/__changelog
@@ -0,0 +1 @@
+add gcc7fixes.patch
diff --git a/abs/core/aspell/aspell.install b/abs/core/aspell/aspell.install
deleted file mode 100644
index 4bb848e..0000000
--- a/abs/core/aspell/aspell.install
+++ /dev/null
@@ -1,24 +0,0 @@
-infodir=usr/share/info
-filelist=(aspell.info aspell-dev.info)
-
-post_install() {
- echo "==> aspell comes with no default dictionary"
- [ -x usr/bin/install-info ] || return 0
- for file in ${filelist[@]}; do
- install-info $infodir/$file $infodir/dir 2> /dev/null
- done
-}
-
-post_upgrade() {
- [ -x usr/bin/install-info ] || return 0
- for file in ${filelist[@]}; do
- install-info $infodir/$file $infodir/dir 2> /dev/null
- done
-}
-
-pre_remove() {
- [ -x usr/bin/install-info ] || return 0
- for file in ${filelist[@]}; do
- install-info --delete $infodir/$file $infodir/dir 2> /dev/null
- done
-}
diff --git a/abs/core/aspell/gcc7fixes.patch b/abs/core/aspell/gcc7fixes.patch
new file mode 100644
index 0000000..61ffabb
--- /dev/null
+++ b/abs/core/aspell/gcc7fixes.patch
@@ -0,0 +1,37 @@
+From 8089fa02122fed0a6394eba14bbedcb1d18e2384 Mon Sep 17 00:00:00 2001
+From: Kevin Atkinson <kevina@gnu.org>
+Date: Thu, 29 Dec 2016 00:50:31 -0500
+Subject: [PATCH] Compile Fixes for GCC 7.
+
+Closes #519.
+---
+ modules/filter/tex.cpp | 2 +-
+ prog/check_funs.cpp | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/modules/filter/tex.cpp b/modules/filter/tex.cpp
+index a979539..19ab63c 100644
+--- a/modules/filter/tex.cpp
++++ b/modules/filter/tex.cpp
+@@ -174,7 +174,7 @@ namespace {
+
+ if (c == '{') {
+
+- if (top.in_what == Parm || top.in_what == Opt || top.do_check == '\0')
++ if (top.in_what == Parm || top.in_what == Opt || *top.do_check == '\0')
+ push_command(Parm);
+
+ top.in_what = Parm;
+diff --git a/prog/check_funs.cpp b/prog/check_funs.cpp
+index db54f3d..89ee09d 100644
+--- a/prog/check_funs.cpp
++++ b/prog/check_funs.cpp
+@@ -647,7 +647,7 @@ static void print_truncate(FILE * out, const char * word, int width) {
+ }
+ }
+ if (i == width-1) {
+- if (word == '\0')
++ if (*word == '\0')
+ put(out,' ');
+ else if (word[len] == '\0')
+ put(out, word, len);