summaryrefslogtreecommitdiffstats
path: root/abs/core/aumix/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/aumix/PKGBUILD')
-rw-r--r--abs/core/aumix/PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/abs/core/aumix/PKGBUILD b/abs/core/aumix/PKGBUILD
new file mode 100644
index 0000000..09b525a
--- /dev/null
+++ b/abs/core/aumix/PKGBUILD
@@ -0,0 +1,24 @@
+# Contributor: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=aumix
+pkgver=2.8
+pkgrel=4
+pkgdesc="A color text mode sound mixer with GPM support"
+arch=('i686' 'x86_64')
+license=('GPL')
+url="http://www.jpj.net/~trevor/aumix.html"
+depends=('gpm')
+conflicts=('aumix-gtk')
+provides=('aumix-gtk')
+source=(http://jpj.net/~trevor/aumix/aumix-$pkgver.tar.bz2 aumix.patch)
+md5sums=('dc3fc7209752207c23e7c94ab886b340' 'a4dae53812a41b7576228c37856c701b')
+
+build() {
+ cd $startdir/src/$pkgname-$pkgver
+ patch -Np1 <../aumix.patch || return 1
+ # we build without X/GTK support so we can avoid the dependencies.
+ # if you want GTK support, you can rebuild aumix from your ABS tree.
+ ./configure --prefix=/usr --without-alsa --without-gtk --without-gtk1 || return 1
+ make || return 1
+ make DESTDIR=$startdir/pkg install || return 1
+}