summaryrefslogtreecommitdiffstats
path: root/abs/core/aumix/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/aumix/PKGBUILD')
-rw-r--r--abs/core/aumix/PKGBUILD44
1 files changed, 30 insertions, 14 deletions
diff --git a/abs/core/aumix/PKGBUILD b/abs/core/aumix/PKGBUILD
index 09b525a..aa9b072 100644
--- a/abs/core/aumix/PKGBUILD
+++ b/abs/core/aumix/PKGBUILD
@@ -1,24 +1,40 @@
-# Contributor: Stefan Husmann <stefan-husmann@t-online.de>
+# $Id: PKGBUILD 70215 2012-05-02 12:56:49Z spupykin $
+# Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
pkgname=aumix
-pkgver=2.8
+pkgver=2.9.1
pkgrel=4
pkgdesc="A color text mode sound mixer with GPM support"
arch=('i686' 'x86_64')
license=('GPL')
-url="http://www.jpj.net/~trevor/aumix.html"
-depends=('gpm')
-conflicts=('aumix-gtk')
+depends=()
+makedepends=('gtk2' 'gpm' 'ncurses')
+optdepends=('gtk2: aumix'
+ 'ncurses: aumix-nox'
+ 'gpm: aumix-nox')
+replaces=('aumix-gtk')
provides=('aumix-gtk')
-source=(http://jpj.net/~trevor/aumix/aumix-$pkgver.tar.bz2 aumix.patch)
-md5sums=('dc3fc7209752207c23e7c94ab886b340' 'a4dae53812a41b7576228c37856c701b')
+install=aumix.install
+url=(http://www.jpj.net/~trevor/aumix.html)
+source=(http://www.jpj.net/~trevor/aumix/releases/aumix-$pkgver.tar.bz2
+ aumix.desktop)
build() {
- cd $startdir/src/$pkgname-$pkgver
- patch -Np1 <../aumix.patch || return 1
- # we build without X/GTK support so we can avoid the dependencies.
- # if you want GTK support, you can rebuild aumix from your ABS tree.
- ./configure --prefix=/usr --without-alsa --without-gtk --without-gtk1 || return 1
- make || return 1
- make DESTDIR=$startdir/pkg install || return 1
+ cd $srcdir/aumix-$pkgver
+
+ msg "No X11 build"
+ ./configure --prefix=/usr --mandir=/usr/share/man --without-gtk --without-gtk1 \
+ --without-alsa --without-x
+ make
+ install -D -m0755 src/aumix $pkgdir/usr/bin/aumix-nox
+ make distclean
+
+ msg "X11+GTK2 build"
+ ./configure --prefix=/usr --mandir=/usr/share/man --without-gtk1 --without-alsa \
+ --without-gpm
+ make
+ make DESTDIR=$pkgdir install
+ install -D -m0644 $srcdir/aumix.desktop $pkgdir/usr/share/applications/aumix.desktop
}
+md5sums=('34f28ae1c94fc5298e8bb2688c4b3a20'
+ 'afba8b39b8dd95d8a9d74356023de14a')