summaryrefslogtreecommitdiffstats
path: root/abs/core/bash/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/bash/PKGBUILD')
-rw-r--r--abs/core/bash/PKGBUILD19
1 files changed, 15 insertions, 4 deletions
diff --git a/abs/core/bash/PKGBUILD b/abs/core/bash/PKGBUILD
index ceb5e17..cb6847e 100644
--- a/abs/core/bash/PKGBUILD
+++ b/abs/core/bash/PKGBUILD
@@ -5,16 +5,16 @@
pkgname=bash
_basever=4.3
-_patchlevel=039
+_patchlevel=042
pkgver=$_basever.$_patchlevel
-pkgrel=1
+pkgrel=4
pkgdesc='The GNU Bourne Again shell'
arch=('i686' 'x86_64')
license=('GPL')
url='http://www.gnu.org/software/bash/bash.html'
groups=('base')
backup=(etc/bash.bash{rc,_logout} etc/skel/.bash{rc,_profile,_logout})
-depends=('readline>=6.3' 'glibc')
+depends=('readline>=6.3' 'glibc' 'ncurses' 'libncursesw.so')
optdepends=('bash-completion: for tab completion')
provides=('sh')
install=bash.install
@@ -24,7 +24,8 @@ source=(http://ftp.gnu.org/gnu/bash/bash-$_basever.tar.gz{,.sig}
dot.bash_logout
system.bashrc
system.bash_logout
- privmode-setuid-fail.patch)
+ privmode-setuid-fail.patch
+ bash-4.3-old-memleak.patch)
validpgpkeys=('7C0135FB088AAF6C66C650B9BB5869F064EA74AB') # Chet Ramey
if [[ $((10#${_patchlevel})) -gt 0 ]]; then
@@ -43,6 +44,9 @@ prepare() {
# http://hmarco.org/bugs/bash_4.3-setuid-bug.html (FS#40663)
patch -p0 -i ../privmode-setuid-fail.patch
+
+ # https://bugs.archlinux.org/task/45891
+ patch -p1 -i ../bash-4.3-old-memleak.patch
}
build() {
@@ -86,6 +90,7 @@ md5sums=('81348932d5da294953e15d4814c74dd1'
'561949793177116b7be29a07c385ba8b'
'472f536d7c9e8250dc4568ec4cfaf294'
'a577d42e38249d298d6a8d4bf2823883'
+ '5bb46160bba51ff904922c6ccfd9c49e'
'1ab682b4e36afa4cf1b426aa7ac81c0d'
'SKIP'
'8fc22cf50ec85da00f6af3d66f7ddc1b'
@@ -163,4 +168,10 @@ md5sums=('81348932d5da294953e15d4814c74dd1'
'61e0522830b24fbe8c0d1b010f132470'
'SKIP'
'a4775487abe958536751c8ce53cdf6f9'
+ 'SKIP'
+ '80d3587c58854e226055ef099ffeb535'
+ 'SKIP'
+ '20bf63eef7cb441c0b1cc49ef3191d03'
+ 'SKIP'
+ '70790646ae61e207c995e44931390e50'
'SKIP')