summaryrefslogtreecommitdiffstats
path: root/abs/core/certmaster
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/certmaster')
-rw-r--r--abs/core/certmaster/PKGBUILD9
-rw-r--r--abs/core/certmaster/logrotate-certmaster.conf3
2 files changed, 7 insertions, 5 deletions
diff --git a/abs/core/certmaster/PKGBUILD b/abs/core/certmaster/PKGBUILD
index e3b9df1..0c2bb91 100644
--- a/abs/core/certmaster/PKGBUILD
+++ b/abs/core/certmaster/PKGBUILD
@@ -8,12 +8,12 @@ depends=('pyopenssl' 'linhes-scripts>=7-24' )
makedepends=()
conflicts=()
replaces=()
-moddir="pkg/usr/lib/python2.6/site-packages/func/minion/modules/"
+moddir="pkg/usr/lib/python2.7/site-packages/func/minion/modules/"
backup=('etc/certmaster/certmaster.conf' 'etc/certmaster/minion.conf')
install=certmaster.install
source=($pkgname-$pkgver.tar.gz certmaster.conf minion.conf logrotate-certmaster.conf)
-arch=('i686')
+arch=('i686' 'x86_64')
build() {
cd $startdir/src/$pkgname-${pkgver}
@@ -22,12 +22,13 @@ build() {
cd $startdir/src
install -m755 -D minion.conf $startdir/pkg/etc/certmaster/minion.conf
install -m755 -D certmaster.conf $startdir/pkg/etc/certmaster/certmaster.conf
- install -m755 -D logrotate-certmaster.conf $startdir/pkg/etc/logrotate.d/certmaster.conf
+ install -m644 -D logrotate-certmaster.conf $startdir/pkg/etc/logrotate.d/certmaster
mkdir -p $startdir/pkg/var/log/certmaster
cd $startdir/pkg
+ find ./usr/bin/* -exec sed -i 's|#!/usr/bin/python|#!/usr/bin/python2|' {} \;
find ./ -name "*.pyc" -print | xargs rm -f
}
md5sums=('f5acc9ff1efa34971296e26d794c5b35'
'953ff601e5381b457383e7a3c4928192'
'be7bd532ae103ab3c0048980314b4fd9'
- '6bc28ccd331a6c4c05e0a9c9755a848f')
+ 'fa8fabe2381c7b891e014bf9e23e653b')
diff --git a/abs/core/certmaster/logrotate-certmaster.conf b/abs/core/certmaster/logrotate-certmaster.conf
index 39c3537..e4637a2 100644
--- a/abs/core/certmaster/logrotate-certmaster.conf
+++ b/abs/core/certmaster/logrotate-certmaster.conf
@@ -2,7 +2,8 @@
missingok
notifempty
rotate 4
- weekly
+ size 512k
+ compress
postrotate
if [ -f /service/certmaster ]; then
sv restart certmaster