summaryrefslogtreecommitdiffstats
path: root/abs/core/coreutils/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/coreutils/PKGBUILD')
-rw-r--r--abs/core/coreutils/PKGBUILD27
1 files changed, 16 insertions, 11 deletions
diff --git a/abs/core/coreutils/PKGBUILD b/abs/core/coreutils/PKGBUILD
index f10a12e..6762512 100644
--- a/abs/core/coreutils/PKGBUILD
+++ b/abs/core/coreutils/PKGBUILD
@@ -1,31 +1,36 @@
# $Id$
-# Maintainer: Sébastien "Seblu" Luttringer
-# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
+# Maintainer: Sébastien "Seblu" Luttringer
+# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
# Contributor: Allan McRae <allan@archlinux.org>
# Contributor: judd <jvinet@zeroflux.org>
pkgname=coreutils
-pkgver=8.23
+pkgver=8.24
pkgrel=1
pkgdesc='The basic file, shell and text manipulation utilities of the GNU operating system'
arch=('i686' 'x86_64')
license=('GPL3')
url='http://www.gnu.org/software/coreutils'
groups=('base')
-depends=('glibc' 'pam' 'acl' 'gmp' 'libcap' 'openssl')
+depends=('glibc' 'acl' 'attr' 'gmp' 'libcap' 'openssl')
install=$pkgname.install
source=("ftp://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.xz"{,.sig})
-md5sums=('abed135279f87ad6762ce57ff6d89c41'
+validpgpkeys=('6C37DC12121A5006BC1DB804DF6FD971306037D9') # Pádraig Brady
+md5sums=('40efdbce865d2458d8da0a9dcee7c16c'
'SKIP')
-#prepare() {
-# cd $pkgname-$pkgver
-#}
+prepare() {
+ local _p
+ for _p in *.patch; do
+ [[ -e $_p ]] || continue
+ msg2 "Applying $_p"
+ patch -p1 -d $pkgname-$pkgver < "$_p"
+ done
+}
build() {
cd $pkgname-$pkgver
- FORCE_UNSAFE_CONFIGURE=1
- export FORCE_UNSAFE_CONFIGURE
+ export FORCE_UNSAFE_CONFIGURE=1
./configure \
--prefix=/usr \
--libexecdir=/usr/lib \
@@ -36,7 +41,7 @@ build() {
check() {
cd $pkgname-$pkgver
- make RUN_EXPENSIVE_TESTS=yes check
+ make check
}
package() {