summaryrefslogtreecommitdiffstats
path: root/abs/core/directfb/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/directfb/PKGBUILD')
-rw-r--r--abs/core/directfb/PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/abs/core/directfb/PKGBUILD b/abs/core/directfb/PKGBUILD
new file mode 100644
index 0000000..89d322a
--- /dev/null
+++ b/abs/core/directfb/PKGBUILD
@@ -0,0 +1,26 @@
+# $Id: PKGBUILD,v 1.7 2008/08/02 19:48:28 Snowman Exp $
+# Maintainer: Eric Belanger <eric@archlinux.org>
+# Contributor: Eric Belanger <eric@archlinux.org>
+
+pkgname=directfb
+pkgver=1.2.0
+pkgrel=2
+pkgdesc="A thin library that provides hardware graphics acceleration, input device handling and abstraction, integrated windowing system on top of the Linux Framebuffer Device"
+arch=('i686' 'x86_64')
+url="http://www.directfb.org"
+license=('LGPL')
+depends=('libjpeg' 'libxext' 'sdl' 'sysfsutils' 'libpng' 'freetype2')
+options=('!libtool')
+source=(http://www.directfb.org/downloads/Old/DirectFB-${pkgver}.tar.gz dfb_serial.diff)
+md5sums=('231f2247c9d0a2b8a51f415571105ecb'
+ '5993ae20546b80d0e5fa4f7b367e2f82')
+
+build() {
+ cd ${srcdir}/DirectFB-${pkgver}
+# patch -p0 < ../dfb_serial.diff
+ ./configure --prefix=/usr --sysconfdir=/etc --enable-static --enable-zlib \
+ --enable-x11 --enable-sdl --disable-vnc --disable-osx \
+ --enable-video4linux2 --enable-voodoo || return 1
+ make || return 1
+ make DESTDIR=${pkgdir} install || return 1
+}