summaryrefslogtreecommitdiffstats
path: root/abs/core/dvdauthor
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/dvdauthor')
-rw-r--r--abs/core/dvdauthor/PKGBUILD25
1 files changed, 16 insertions, 9 deletions
diff --git a/abs/core/dvdauthor/PKGBUILD b/abs/core/dvdauthor/PKGBUILD
index 6066d7f..37b3a01 100644
--- a/abs/core/dvdauthor/PKGBUILD
+++ b/abs/core/dvdauthor/PKGBUILD
@@ -1,21 +1,28 @@
-# Maintainer: Travis Willard <travisw@wmpub.ca>
+# $Id: PKGBUILD 87461 2010-08-13 20:20:49Z giovanni $
+# Maintainer: Giovanni Scafora <giovanni@archlinux.org>
+# Contributor: Travis Willard <travisw@wmpub.ca>
# Contributor: Jaroslaw Swierczynski <swiergot@juvepoland.com>
# Contributor: Nicolai Lissner <nlissne@linux01.gwdg.de>
pkgname=dvdauthor
-pkgver=0.6.14
-pkgrel=2
+pkgver=0.6.18
+pkgrel=1
pkgdesc="DVD authoring tools"
arch=('i686' 'x86_64')
url="http://dvdauthor.sourceforge.net/"
license=('GPL')
-depends=('libdvdread' 'fribidi' 'imagemagick>=6.4.0.2')
-source=(http://dl.sourceforge.net/sourceforge/dvdauthor/${pkgname}-${pkgver}.tar.gz)
-md5sums=('bd646b47950c4091ffd781d43fd2c5e9')
+depends=('libdvdread' 'imagemagick' 'libxml2' 'libpng' 'fribidi')
+options=('!makeflags')
+source=(http://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.tar.gz)
+md5sums=('ded5373800ac6448ff044606f5047550')
build() {
- cd $startdir/src/$pkgname-$pkgver
- ./configure --prefix=/usr
+ cd "${srcdir}/${pkgname}"
+ ./configure --prefix=/usr || return 1
make || return 1
- make prefix=$startdir/pkg/usr install
}
+package() {
+ cd "${srcdir}/${pkgname}"
+ make DESTDIR="${pkgdir}" install || return 1
+}
+