summaryrefslogtreecommitdiffstats
path: root/abs/core/faac/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/faac/PKGBUILD')
-rw-r--r--abs/core/faac/PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/abs/core/faac/PKGBUILD b/abs/core/faac/PKGBUILD
new file mode 100644
index 0000000..3d7ce11
--- /dev/null
+++ b/abs/core/faac/PKGBUILD
@@ -0,0 +1,28 @@
+# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# Maintainer: Alexander Baldeck <alexander@archlinux.org>
+# Contributor: Sarah Hay <sarah@archlinux.org>
+# Contributor: dorphell <dorphell@archlinux.org>
+pkgname=faac
+pkgver=1.26
+pkgrel=1
+pkgdesc="FAAC is an AAC audio encoder."
+arch=(i686 x86_64)
+url="http://www.audiocoding.com/"
+license=('GPL' 'custom')
+depends=('libmp4v2' 'glibc')
+makedepends=('automake' 'autoconf' 'libtool')
+options=('!libtool')
+source=(http://downloads.sourceforge.net/sourceforge/${pkgname}/${pkgname}-${pkgver}.tar.gz)
+
+build() {
+ cd ${startdir}/src/${pkgname}
+ find . -type f -print0 | xargs -0 sed -i 's/\r//g'
+ ./bootstrap
+ ./configure --prefix=/usr --with-mp4v2
+ make || return 1
+ make DESTDIR=${startdir}/pkg install
+
+ install -D -m644 ${startdir}/src/${pkgname}/libfaac/kiss_fft/COPYING \
+ ${startdir}/pkg/usr/share/licenses/faac/COPYING.kiss_fft
+}
+md5sums=('1d7c019bd2dbb4f3101b8937ebc59cf6')