summaryrefslogtreecommitdiffstats
path: root/abs/core/filesystem
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/filesystem')
-rw-r--r--abs/core/filesystem/PKGBUILD184
-rw-r--r--abs/core/filesystem/__changelog3
-rw-r--r--abs/core/filesystem/archlinux.7.txt80
-rw-r--r--abs/core/filesystem/crypttab36
-rw-r--r--abs/core/filesystem/filesystem.install122
-rw-r--r--abs/core/filesystem/fstab5
-rw-r--r--abs/core/filesystem/group3
-rw-r--r--abs/core/filesystem/gshadow4
-rw-r--r--abs/core/filesystem/hosts3
-rw-r--r--abs/core/filesystem/issue3
-rw-r--r--abs/core/filesystem/locale.sh28
-rw-r--r--abs/core/filesystem/modprobe.d.usb-load-ehci-first4
-rw-r--r--abs/core/filesystem/nsswitch.conf2
-rw-r--r--abs/core/filesystem/os-release8
-rw-r--r--abs/core/filesystem/passwd1
-rw-r--r--abs/core/filesystem/profile41
-rw-r--r--abs/core/filesystem/securetty1
-rw-r--r--abs/core/filesystem/shadow1
-rw-r--r--abs/core/filesystem/shells1
19 files changed, 302 insertions, 228 deletions
diff --git a/abs/core/filesystem/PKGBUILD b/abs/core/filesystem/PKGBUILD
index 01b8a0d..1bce61a 100644
--- a/abs/core/filesystem/PKGBUILD
+++ b/abs/core/filesystem/PKGBUILD
@@ -1,111 +1,109 @@
-# $Id: PKGBUILD 96685 2010-10-24 09:56:25Z pierre $
-# Maintainer: Aaron Griffin <aaron@archlinux.org>
-# Contributor: judd <jvinet@zeroflux.org>
+# $Id: PKGBUILD 169662 2012-10-25 10:06:29Z tomegun $
+# Maintainer: Tom Gundersen <teg@jklm.no>
pkgname=filesystem
-pkgver=2010.10
-pkgrel=1
-pkgdesc="Base filesystem"
+pkgver=2012.10
+pkgrel=2
+pkgdesc='Base filesystem'
arch=('any')
license=('GPL')
-url="http://www.archlinux.org"
+url='http://www.archlinux.org'
groups=('base')
-install=filesystem.install
-# These dependencies are not needed for initial installation.
-# They are only required on upgrade to create missing groups.
-#depends=('sh' 'coreutils')
-depends=('iana-etc')
-backup=(etc/fstab etc/crypttab etc/group etc/hosts etc/ld.so.conf etc/passwd
- etc/shadow etc/gshadow etc/resolv.conf etc/motd etc/nsswitch.conf
- etc/shells etc/host.conf etc/securetty etc/profile )
-source=(group nsswitch.conf securetty host.conf ld.so.conf
- passwd shadow fstab crypttab hosts motd resolv.conf shells
- gshadow profile modprobe.d.usb-load-ehci-first)
-md5sums=('75c7e1770305e1f3b75c52785c137611'
- '1bdc5dba66947d74866a5df8ce9ef3b1'
- '13753e4e0964f3652b0cc60a28528bdf'
- '933dee67c58d452334d342c294342910'
- 'f28150d4c0b22a017be51b9f7f9977ed'
- '6e488ffecc8ba142c0cf7e2d7aeb832e'
- '8a9042a2cedf6b6b47eb8973f14289cb'
- 'b8355d9d2782f424f4cedcf682651be0'
- 'ef40305da5803ca69d22e428ffc2ab9b'
- 'e5d8323a4dbee7a6d0d2a19cbf4b819f'
- '81b3cb42a6ddabc2ed2310511ee9c859'
- 'd41d8cd98f00b204e9800998ecf8427e'
- '6f48288b6fcaf0065fcb7b0e525413e0'
- '40dac0de4c6b99c8ca97effbd7527c84'
- '5340b9287b71ffe9d4d99510bffe933f'
- 'ccc4e6292ae594f16b44c66c7769765c'
- '8098ffd9fbf890468d3198277596b85a')
+install='filesystem.install'
+makedepends=('asciidoc')
+depends=('iana-etc' 'bash' 'coreutils' 'nss-myhostname')
+backup=('etc/fstab' 'etc/crypttab' 'etc/group' 'etc/hosts' 'etc/ld.so.conf' 'etc/passwd'
+ 'etc/shadow' 'etc/gshadow' 'etc/resolv.conf' 'etc/motd' 'etc/nsswitch.conf'
+ 'etc/shells' 'etc/host.conf' 'etc/securetty' 'etc/profile' 'etc/issue')
+source=('group' 'nsswitch.conf' 'securetty' 'host.conf' 'ld.so.conf'
+ 'passwd' 'shadow' 'fstab' 'crypttab' 'hosts' 'motd' 'os-release' 'resolv.conf'
+ 'shells' 'gshadow' 'profile' 'modprobe.d.usb-load-ehci-first' 'archlinux.7.txt'
+ 'locale.sh')
-build()
-{
- cd ${pkgdir}
- mkdir -p bin boot dev etc home lib media mnt proc root sbin tmp usr var opt srv sys
- chmod 555 proc
- mkdir -p usr/{bin,include,lib,sbin,share/misc,src}
-
- mkdir -p usr/share/man/man{1,2,3,4,5,6,7,8}
-
- # fhs compliance
- mkdir -p usr/local/{bin,games,include,lib,man,sbin,share,src}
- ln -s ../man ${pkgdir}/usr/local/share/man
- mkdir -p var/{cache/man,local,lock,opt,run,spool/mail,tmp,games}
- chmod 1777 var/lock
- mkdir -p var/log/old
- mkdir -p etc/{ld.so.conf.d,skel,profile.d}
- mkdir -p lib/modules
- mkdir -p var/lib/misc
- (cd ${pkgdir}/var; ln -s spool/mail mail)
+build() {
+ cd ${srcdir}
+ a2x -d manpage -f manpage archlinux.7.txt
+}
- # vsftpd won't run with write perms on /srv/ftp
- mkdir -p srv/ftp
- chown root.ftp srv/ftp
- chmod 555 srv/ftp
+package() {
+ cd ${pkgdir}
- install -d -o root -g root -m 755 srv/http
+ #
+ # setup root filesystem
+ #
+ for d in boot dev etc home media mnt usr var opt srv/http run; do
+ install -d -m755 ${d}
+ done
+ install -d -m555 proc
+ install -d -m555 sys
+ install -d -m0750 root
+ install -d -m1777 tmp
+ # vsftpd won't run with write perms on /srv/ftp
+ install -d -m555 -g ftp srv/ftp
- chmod 1777 var/spool/mail tmp var/tmp
- chmod 0750 root
+ # setup /etc
+ install -d etc/{ld.so.conf.d,skel,profile.d}
+ for f in fstab group host.conf hosts ld.so.conf motd nsswitch.conf os-release passwd resolv.conf securetty shells profile; do
+ install -m644 ${srcdir}/${f} etc/
+ done
+ ln -s /proc/self/mounts etc/mtab
+ for f in gshadow shadow crypttab; do
+ install -m600 ${srcdir}/${f} etc/
+ done
+ touch etc/arch-release
+ install -D -m644 ${srcdir}/modprobe.d.usb-load-ehci-first usr/lib/modprobe.d/usb-load-ehci-first.conf
+ install -m755 ${srcdir}/locale.sh etc/profile.d/locale.sh
- #Allow setgid games to write scores:
- chmod 775 ${pkgdir}/var/games
- chown root:50 ${pkgdir}/var/games
+ # setup /var
+ for d in cache/man local opt log/old lib/misc empty; do
+ install -d -m755 var/${d}
+ done
+ install -d -m1777 var/{tmp,spool/mail}
+ # allow setgid games to write scores
+ install -d -m775 -g games var/games
+ ln -s spool/mail var/mail
+ ln -s ../run var/run
+ ln -s ../run/lock var/lock
- cd ${srcdir}
- cp fstab crypttab group host.conf hosts ld.so.conf motd nsswitch.conf \
- passwd resolv.conf securetty shadow shells profile \
- ${pkgdir}/etc/
- install -m 600 ${srcdir}/gshadow ${pkgdir}/etc/gshadow
- chmod 600 ${pkgdir}/etc/shadow
- chmod 600 ${pkgdir}/etc/crypttab
+ #
+ # setup /usr hierarchy
+ #
+ for d in bin include lib sbin share/misc src; do
+ install -d -m755 usr/${d}
+ done
+ for d in $(seq 8); do
+ install -d -m755 usr/share/man/man${d}
+ done
- # re-add /etc/arch-release, some software uses it
- # to check whether arch is running
- touch ${pkgdir}/etc/arch-release
-
- # Add /etc/modprobe.d/
- install -D -m644 ${srcdir}/modprobe.d.usb-load-ehci-first \
- ${pkgdir}/etc/modprobe.d/usb-load-ehci-first.conf
+ #
+ # install archlinux(7) manpage
+ #
+ install -D -m644 ${srcdir}/archlinux.7 usr/share/man/man7/archlinux.7
- # Prevent pacman from removing directory (FS#16886)
- mkdir ${pkgdir}/var/empty
- touch ${pkgdir}/var/empty/.keep
+ #
+ # setup /usr/local hierarchy
+ #
+ for d in bin etc games include lib man sbin share src; do
+ install -d -m755 usr/local/${d}
+ done
+ ln -s ../man usr/local/share/man
}
-md5sums=('75c7e1770305e1f3b75c52785c137611'
- '13753e4e0964f3652b0cc60a28528bdf'
- 'f97799ef3d8990f2eda9166122d8d5aa'
+md5sums=('004013ac940ef3d3cdd8c596e7accfe1'
+ '9e4533df61f0c82d6b2e2371f7376282'
+ 'f833071f3b4c1e1033770c0ef30da0a4'
'f28150d4c0b22a017be51b9f7f9977ed'
'6e488ffecc8ba142c0cf7e2d7aeb832e'
- '8a9042a2cedf6b6b47eb8973f14289cb'
- 'b8355d9d2782f424f4cedcf682651be0'
- 'ef40305da5803ca69d22e428ffc2ab9b'
- 'e5d8323a4dbee7a6d0d2a19cbf4b819f'
- '81b3cb42a6ddabc2ed2310511ee9c859'
+ '455b78cada80f40b6f6968f5cbd97a2e'
+ '01249bb0ba4468f95e2cc3a627f5e6e3'
+ 'ca716f853860199c1286e7939b2f2666'
+ '1745349eb24ed21b4cfaa6f423bddb76'
+ '7bc65f234dfb6abf24e7c3b03e86f4ff'
'd41d8cd98f00b204e9800998ecf8427e'
+ 'c1e795aa3bae70bf0fb76b8a720e4825'
'6f48288b6fcaf0065fcb7b0e525413e0'
- '40dac0de4c6b99c8ca97effbd7527c84'
- '5340b9287b71ffe9d4d99510bffe933f'
- 'ccc4e6292ae594f16b44c66c7769765c'
- '8098ffd9fbf890468d3198277596b85a')
+ '22518e922891f9359f971f4f5b4e793c'
+ '677523dbe94b79299aa91b35ed8203b6'
+ 'f3b6ae7db8adffaaa4bffc6099dcbd50'
+ 'a8a962370cd0128465d514e6a1f74130'
+ 'f339bbc45ff3ad4dd73039beab2f28e3'
+ '3807d07215d9116331fe1cf8feeaa0f8')
diff --git a/abs/core/filesystem/__changelog b/abs/core/filesystem/__changelog
index 87707ff..b68b199 100644
--- a/abs/core/filesystem/__changelog
+++ b/abs/core/filesystem/__changelog
@@ -1,2 +1,3 @@
-removed /etc/issue
added tty10 to securetty
+os-release
+remove issue
diff --git a/abs/core/filesystem/archlinux.7.txt b/abs/core/filesystem/archlinux.7.txt
new file mode 100644
index 0000000..74eee59
--- /dev/null
+++ b/abs/core/filesystem/archlinux.7.txt
@@ -0,0 +1,80 @@
+/////
+vim:set ts=4 sw=4 syntax=asciidoc noet:
+/////
+archlinux(7)
+============
+
+NAME
+----
+archlinux - basic configuration
+
+SYNOPSIS
+--------
+Overview of the basic configuration of Arch Linux.
+
+DESCRIPTION
+-----------
+Arch Linux exposes the user to the system without hiding any details. This manpage gives a
+brief overview of the configuration files that should be set up on a fresh install.
+
+SYSTEM SERVICES[[S]]
+--------------------
+System services to be started at boot can be enabled using 'systemctl enable <name>.service'. To view
+available services use 'systemctl list-unit-files'.
+
+HOSTNAME[[H]]
+-------------
+The hostname of the machine can be set using 'hostnamectl set-hostname <hostname>'. It will then be
+written to /etc/hostname.
+
+LOCALIZATION[[L]]
+-----------------
+Various locales may be enabled in /etc/locale.gen, and generated by locale-gen. The system-wide locale to be used
+can be configured in /etc/locale.conf. These settings can be overridden on a per-user basis by keeping a
+user-specific locale.conf in $HOME/.config/locale.conf. The user-specific file will take precedence if it exists.
+
+VIRTUAL CONSOLE[[V]]
+--------------------
+The virtual console is configured in /etc/vconsole.conf. It allows you to set a font and a keyboard layout, among
+other things. Note that these settings only apply to the console, and not if you use X.
+
+TIME[[T]]
+---------
+The local timezone is configured by calling 'timedatectl set-timezone <Region/City>'. A *symlink* is then created
+from /etc/localtime to the correct zoneinfo file under /usr/share/zoneinfo/. E.g.,
+
+ /etc/localtime -> ../usr/share/zoneinfo/Europe/Paris
+
+The real-time clock, which keeps track of time when the computer is off, can be configured to either
+be in UTC or in localtime by calling 'timedatectl set-local-rtc <false|true>'. The default is UTC.
+
+FILESYSTEMS[[F]]
+----------------
+Filesystems are configured in /etc/fstab, and encryption mappings are configured in /etc/crypttab.
+
+INITRAMFS[[R]]
+--------------
+The initramfs is generated by mkinitcpio, and can be configured in /etc/mkinitcpio.conf.
+
+PACKAGE MANAGER[[P]]
+--------------------
+The package manager, pacman, is configured in /etc/pacman.conf.
+
+BOOTLOADER[[B]]
+---------------
+GRUB's configuration is generated from /etc/default/grub by grub-mkconfig. Syslinux is configured in /boot/syslinux/syslinux.cfg
+
+MODULES[[M]]
+------------
+Most modules should be loaded on-demand. Modules to be unconditionally loaded at boot can be specified in /etc/modules-load.d/,
+and modules to be blacklisted from auto-loading can be configured in /etc/modprobe.d/.
+
+SEE ALSO
+--------
+
+systemctl(1), hostnamectl(1), hostname(5), locale.conf(5), vconsole.conf(5), timedatectl(1), timezone(3), hwclock(8), fstab(5),
+crypttab(5), mkinitcpio(8), pacman(8), pacman.conf(5), grub-mkconfig(8), syslinux(1), modules-load.d(5), modprobe.d(5)
+
+AUTHORS
+-------
+Written by Tom Gundersen.
diff --git a/abs/core/filesystem/crypttab b/abs/core/filesystem/crypttab
index dd6994b..195945a 100644
--- a/abs/core/filesystem/crypttab
+++ b/abs/core/filesystem/crypttab
@@ -1,33 +1,17 @@
-# crypttab: Mappings for encrypted partitions
+# crypttab: mappings for encrypted partitions
#
# Each mapped device will be created in /dev/mapper, so your /etc/fstab
-# should use the /dev/mapper/{NAME} paths for encrypted devices.
+# should use the /dev/mapper/<name> paths for encrypted devices.
#
-# Each PASSWORD field can be an absolute pathname to a key file (starting
-# with a slash, recommended) or a literal string that will be used as
-# a passphrase. To use special characters in the passphrase, surround it
-# by quotes, the usual bash quoting rules apply.
-# There are two special keywords that cannot be used as passphrases:
-# - ASK ask for a passphrase on boot
-# - SWAP use a random key and create a swapspace afterwards
-# WARNING: use the SWAP keyword carefully, as it overwrites the data
-# on the specified partition
-#
-# To create a key file:
-# hashalot -n 32 ripemd160 >/etc/crytfs.key
-# or
-# dd if=/dev/urandom of=/etc/cryptfs.key bs=256 count=1
-#
-# To pass additional options to cryptsetup for non-LUKS partitions, use the
-# fourth column.
+# The Arch specific syntax has been deprecated, see crypttab(5) for the
+# new supported syntax.
#
# NOTE: Do not list your root (/) partition here, it must be set up
# beforehand by the initramfs (/etc/mkinitcpio.conf).
-
-# NAME SOURCE DEVICE PASSWORD OPTIONS
-#home /dev/hda4 mypassword
-#data1 /dev/hda3 "my \"password\""
-#data2 /dev/hda5 /etc/cryptfs.key
-#swap /dev/hdx4 SWAP -c aes-cbc-essiv:sha256 -s 256
-#vol /dev/hdb7 ASK
+# <name> <device> <password> <options>
+# home /dev/hda4 /etc/mypassword1
+# data1 /dev/hda3 /etc/mypassword2
+# data2 /dev/hda5 /etc/cryptfs.key
+# swap /dev/hdx4 /dev/urandom swap,cipher=aes-cbc-essiv:sha256,size=256
+# vol /dev/hdb7 none
diff --git a/abs/core/filesystem/filesystem.install b/abs/core/filesystem/filesystem.install
index e0ce1e2..34fcc0d 100644
--- a/abs/core/filesystem/filesystem.install
+++ b/abs/core/filesystem/filesystem.install
@@ -1,74 +1,62 @@
-# arg 1: the new package version
post_install() {
- [ -f var/log/lastlog ] || : >var/log/lastlog
- [ -f var/log/wtmp ] || : >var/log/wtmp
- [ -f var/run/utmp ] || : >var/run/utmp
- [ -f var/log/btmp ] || (: >var/log/btmp && bin/chmod 600 var/log/btmp)
- # workaround for bug #7194
- # readded due to bug #9465
- # please do not remove!
- chmod 1777 var/spool/mail tmp var/tmp var/lock
+ [ -f var/log/lastlog ] || : >var/log/lastlog
+ [ -f var/log/wtmp ] || : >var/log/wtmp
+ [ -f var/log/btmp ] || { : >var/log/btmp && chmod 600 var/log/btmp; }
+ # workaround for bug #7194
+ # readded due to bug #9465
+ # please do not remove!
+ chmod 1777 var/spool/mail tmp var/tmp
+}
+
+# args: <group> [options]
+_addgroup() {
+ if ! getent group "$1" >/dev/null; then
+ groupadd "$@" >/dev/null
+ fi
+}
+
+# args: <group> [options]
+_adduser() {
+ if ! getent passwd "$1" >/dev/null; then
+ useradd "$@" >/dev/null
+ fi
}
-# arg 1: the new package version
-# arg 2: the old package version
post_upgrade() {
- post_install $1
- if [ ! "`grep ^optical: etc/group`" ]; then
- echo "adding new groups: audio optical"
- usr/sbin/groupadd -g 92 audio >/dev/null
- usr/sbin/groupadd -g 93 optical >/dev/null
- fi
- if [ ! "`grep ^video: etc/group`" ]; then
- echo "adding new groups: video floppy storage"
- usr/sbin/groupadd -g 91 video >/dev/null
- usr/sbin/groupadd -g 94 floppy >/dev/null
- usr/sbin/groupadd -g 95 storage >/dev/null
- fi
- if [ ! "`grep ^log: etc/group`" ]; then
- echo "adding new group: log"
- usr/sbin/groupadd -g 19 log >/dev/null
- fi
- if [ ! "`grep ^power: etc/group`" ]; then
- echo "adding new group: power"
- usr/sbin/groupadd -g 98 power >/dev/null
- fi
- if [ ! "`grep ^network: etc/group`" ]; then
- echo "adding new group: network"
- usr/sbin/groupadd -g 90 network >/dev/null
- fi
- if [ ! "`grep ^games: etc/group`" ]; then
- echo "adding new group: games"
- usr/sbin/groupadd -g 50 games >/dev/null
- fi
- if [ ! "`grep ^uucp: etc/group`" ]; then
- echo "adding new group: uucp"
- usr/sbin/groupadd -g 14 uucp >/dev/null
- fi
- if [ ! "`grep ^http: etc/group`" ]; then
- echo "adding new group: http"
- usr/sbin/groupadd -g 33 http >/dev/null
- fi
- if [ ! "`grep ^http: etc/passwd`" ]; then
- echo "adding new user http"
- usr/sbin/useradd -u 33 -d /srv/http -g http -s /bin/false http >/dev/null
- fi
- if [ ! "`grep ^scanner: etc/group`" ]; then
- echo "adding new group: scanner"
- usr/sbin/groupadd -g 96 scanner >/dev/null
- fi
- if [ ! "`grep ^rfkill: etc/group`" ]; then
- echo "adding new group: rfkill"
- usr/sbin/groupadd -g 24 rfkill >/dev/null
- fi
+ post_install
+
+ _addgroup optical -g 93
+ _addgroup audio -g 92
+ _addgroup video -g 91
+ _addgroup floppy -g 94
+ _addgroup storage -g 95
+ _addgroup log -g 19
+ _addgroup utmp -g 20
+ _addgroup power -g 98
+ _addgroup network -g 90
+ _addgroup games -g 50
+ _addgroup uucp -g 14
+ _addgroup http -g 33
+ _adduser http -u 33 -d /srv/http -g http -s /bin/false
+ _addgroup scanner -g 96
+ _addgroup rfkill -g 24
+ _addgroup lock -g 54
+ _addgroup uuidd -g 68
+ _adduser uuidd -u 68 -d / -g uuidd -s /sbin/nologin
+
+ # sync gshadow to group (fixes FS#19869)
+ if ! grep -q '^lock:' etc/gshadow; then
+ grpconv >/dev/null
+ fi
- grep -q '^include /etc/ld.so.conf.d/\*.conf$' etc/ld.so.conf \
- || echo 'include /etc/ld.so.conf.d/*.conf' >> etc/ld.so.conf
+ if ! grep -q '^include /etc/ld.so.conf.d/\*.conf$' etc/ld.so.conf; then
+ echo 'include /etc/ld.so.conf.d/*.conf' >> etc/ld.so.conf
+ fi
- # set "Last password change" > 0; otherwise su $user wont work
- for user in bin daemon mail ftp http nobody; do
- if LANG=C chage -l ${user} | grep -q 'password must be changed'; then
- chage -d 14871 ${user}
- fi
- done
+ # set "Last password change" > 0; otherwise su $user wont work
+ for user in bin daemon mail ftp http nobody; do
+ if LANG=C chage -l ${user} | grep -q 'password must be changed'; then
+ chage -d 14871 ${user}
+ fi
+ done
}
diff --git a/abs/core/filesystem/fstab b/abs/core/filesystem/fstab
index a23e795..f7f9298 100644
--- a/abs/core/filesystem/fstab
+++ b/abs/core/filesystem/fstab
@@ -1,6 +1,5 @@
#
# /etc/fstab: static file system information
#
-# <file system> <dir> <type> <options> <dump> <pass>
-devpts /dev/pts devpts defaults 0 0
-shm /dev/shm tmpfs nodev,nosuid 0 0
+# <file system> <dir> <type> <options> <dump> <pass>
+tmpfs /tmp tmpfs nodev,nosuid 0 0
diff --git a/abs/core/filesystem/group b/abs/core/filesystem/group
index 4bd635c..cfee1f2 100644
--- a/abs/core/filesystem/group
+++ b/abs/core/filesystem/group
@@ -13,11 +13,14 @@ ftp:x:11:
mail:x:12:
uucp:x:14:
log:x:19:root
+utmp:x:20:
locate:x:21:
rfkill:x:24:
smmsp:x:25:
http:x:33:
games:x:50:
+lock:x:54:
+uuidd:x:68:
network:x:90:
video:x:91:
audio:x:92:
diff --git a/abs/core/filesystem/gshadow b/abs/core/filesystem/gshadow
index a6d78a3..c5ac185 100644
--- a/abs/core/filesystem/gshadow
+++ b/abs/core/filesystem/gshadow
@@ -13,10 +13,14 @@ ftp:::
mail:::
uucp:::
log:::root
+utmp:x::
locate:::
+rfkill:x::
smmsp:::
http:::
games:::
+lock:::
+uuidd:!::
network:x::
video:x::
audio:::
diff --git a/abs/core/filesystem/hosts b/abs/core/filesystem/hosts
index ec12849..1747f91 100644
--- a/abs/core/filesystem/hosts
+++ b/abs/core/filesystem/hosts
@@ -3,6 +3,7 @@
#
#<ip-address> <hostname.domain.org> <hostname>
-127.0.0.1 localhost.localdomain localhost
+127.0.0.1 localhost.localdomain localhost
+::1 localhost.localdomain localhost
# End of file
diff --git a/abs/core/filesystem/issue b/abs/core/filesystem/issue
index 3db753d..dd702dc 100644
--- a/abs/core/filesystem/issue
+++ b/abs/core/filesystem/issue
@@ -1,3 +1,2 @@
-
-Arch Linux \r (\n) (\l)
+Arch Linux \r (\l)
diff --git a/abs/core/filesystem/locale.sh b/abs/core/filesystem/locale.sh
new file mode 100644
index 0000000..5fd4174
--- /dev/null
+++ b/abs/core/filesystem/locale.sh
@@ -0,0 +1,28 @@
+#!/bin/sh
+
+unset LANG LC_CTYPE LC_NUMERIC LC_TIME LC_COLLATE LC_MONETARY LC_MESSAGES \
+ LC_PAPER LC_NAME LC_ADDRESS LC_TELEPHONE LC_MEASUREMENT LC_IDENTIFICATION
+
+if [ -n "$XDG_CONFIG_HOME" ] && [ -r "$XDG_CONFIG_HOME/locale.conf" ]; then
+ . "$XDG_CONFIG_HOME/locale.conf"
+elif [ -n $HOME ] && [ -r $HOME/.config/locale.conf ]; then
+ . "$HOME/.config/locale.conf"
+elif [ -r /etc/locale.conf ]; then
+ . /etc/locale.conf
+elif [ -r /etc/rc.conf ]; then
+ LANG=$(. /etc/rc.conf 2>/dev/null; echo "$LOCALE")
+fi
+
+export LANG="${LANG:-C}"
+[ -n "$LC_CTYPE" ] && export LC_CTYPE
+[ -n "$LC_NUMERIC" ] && export LC_NUMERIC
+[ -n "$LC_TIME" ] && export LC_TIME
+[ -n "$LC_COLLATE" ] && export LC_COLLATE
+[ -n "$LC_MONETARY" ] && export LC_MONETARY
+[ -n "$LC_MESSAGES" ] && export LC_MESSAGES
+[ -n "$LC_PAPER" ] && export LC_PAPER
+[ -n "$LC_NAME" ] && export LC_NAME
+[ -n "$LC_ADDRESS" ] && export LC_ADDRESS
+[ -n "$LC_TELEPHONE" ] && export LC_TELEPHONE
+[ -n "$LC_MEASUREMENT" ] && export LC_MEASUREMENT
+[ -n "$LC_IDENTIFICATION" ] && export LC_IDENTIFICATION
diff --git a/abs/core/filesystem/modprobe.d.usb-load-ehci-first b/abs/core/filesystem/modprobe.d.usb-load-ehci-first
index 3b5db0e..9473794 100644
--- a/abs/core/filesystem/modprobe.d.usb-load-ehci-first
+++ b/abs/core/filesystem/modprobe.d.usb-load-ehci-first
@@ -1,2 +1,2 @@
-install ohci_hcd /sbin/modprobe ehci_hcd ; /sbin/modprobe --ignore-install ohci_hcd $CMDLINE_OPTS
-install uhci_hcd /sbin/modprobe ehci_hcd ; /sbin/modprobe --ignore-install uhci_hcd $CMDLINE_OPTS
+softdep ohci_hcd pre: ehci_hcd
+softdep uhci_hcd pre: ehci_hcd
diff --git a/abs/core/filesystem/nsswitch.conf b/abs/core/filesystem/nsswitch.conf
index 6e459ad..4a4f577 100644
--- a/abs/core/filesystem/nsswitch.conf
+++ b/abs/core/filesystem/nsswitch.conf
@@ -6,7 +6,7 @@ shadow: files
publickey: files
-hosts: files dns
+hosts: files dns myhostname
networks: files
protocols: files
diff --git a/abs/core/filesystem/os-release b/abs/core/filesystem/os-release
new file mode 100644
index 0000000..c36b91c
--- /dev/null
+++ b/abs/core/filesystem/os-release
@@ -0,0 +1,8 @@
+NAME="LinHES"
+ID=linhes
+PRETTY_NAME="LinHES The Home Entertainment System"
+ANSI_COLOR="0;36"
+HOME_URL="http://www.linhes.org/"
+SUPPORT_URL="http://forum.archlinux.org/"
+BUG_REPORT_URL="http://bugs.linhes.org/"
+
diff --git a/abs/core/filesystem/passwd b/abs/core/filesystem/passwd
index a4a24e3..cb9fec7 100644
--- a/abs/core/filesystem/passwd
+++ b/abs/core/filesystem/passwd
@@ -4,4 +4,5 @@ daemon:x:2:2:daemon:/sbin:/bin/false
mail:x:8:12:mail:/var/spool/mail:/bin/false
ftp:x:14:11:ftp:/srv/ftp:/bin/false
http:x:33:33:http:/srv/http:/bin/false
+uuidd:x:68:68:uuidd:/:/sbin/nologin
nobody:x:99:99:nobody:/:/bin/false
diff --git a/abs/core/filesystem/profile b/abs/core/filesystem/profile
index e7a958a..3bc22db 100644
--- a/abs/core/filesystem/profile
+++ b/abs/core/filesystem/profile
@@ -1,44 +1,23 @@
-#
# /etc/profile
-#
-# This file is intended to be used for ALL common
-# Bourne-compatible shells. Shell specifics should be
-# handled in /etc/profile.$SHELL where $SHELL is the name
-# of the binary being run (discounting symlinks)
-#
-# Sections taken from SuSe's /etc/profile
-# Note the explicit use of 'test' to cover all bases
-# and potentially incompatible shells
-
-#Determine our shell without using $SHELL, which may lie
-shell="sh"
-if test -f /proc/mounts; then
- case $(/bin/ls -l /proc/$$/exe) in
- *bash) shell=bash ;;
- *dash) shell=dash ;;
- *ash) shell=ash ;;
- *ksh) shell=ksh ;;
- *zsh) shell=zsh ;;
- esac
-fi
-
-# Load shell specific profile settings
-test -f "/etc/profile.$shell" && . "/etc/profile.$shell"
-unset shell
#Set our umask
umask 022
# Set our default path
-PATH="/bin:/usr/bin:/sbin:/usr/sbin"
+PATH="/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin"
export PATH
# Load profiles from /etc/profile.d
if test -d /etc/profile.d/; then
- for profile in /etc/profile.d/*.sh; do
- test -x $profile && . $profile
- done
- unset profile
+ for profile in /etc/profile.d/*.sh; do
+ test -r "$profile" && . "$profile"
+ done
+ unset profile
+fi
+
+# Source global bash config
+if test "$PS1" && test "$BASH" && test -r /etc/bash.bashrc; then
+ . /etc/bash.bashrc
fi
# Termcap is outdated, old, and crusty, kill it.
diff --git a/abs/core/filesystem/securetty b/abs/core/filesystem/securetty
index 7fcd451..5cc27d8 100644
--- a/abs/core/filesystem/securetty
+++ b/abs/core/filesystem/securetty
@@ -9,6 +9,7 @@ tty3
tty4
tty5
tty6
+ttyS0
hvc0
tty10
# End of file
diff --git a/abs/core/filesystem/shadow b/abs/core/filesystem/shadow
index ccab68d..5eff493 100644
--- a/abs/core/filesystem/shadow
+++ b/abs/core/filesystem/shadow
@@ -4,4 +4,5 @@ daemon:x:14871::::::
mail:x:14871::::::
ftp:x:14871::::::
http:x:14871::::::
+uuidd:x:14871::::::
nobody:x:14871::::::
diff --git a/abs/core/filesystem/shells b/abs/core/filesystem/shells
index ff9e383..18c1aef 100644
--- a/abs/core/filesystem/shells
+++ b/abs/core/filesystem/shells
@@ -4,6 +4,5 @@
/bin/sh
/bin/bash
-/bin/dash
# End of file