summaryrefslogtreecommitdiffstats
path: root/abs/core/gdb/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/gdb/PKGBUILD')
-rw-r--r--abs/core/gdb/PKGBUILD13
1 files changed, 6 insertions, 7 deletions
diff --git a/abs/core/gdb/PKGBUILD b/abs/core/gdb/PKGBUILD
index 3c5769c..6e0648b 100644
--- a/abs/core/gdb/PKGBUILD
+++ b/abs/core/gdb/PKGBUILD
@@ -1,9 +1,9 @@
-# $Id: PKGBUILD 157331 2012-04-27 05:07:31Z allan $
+# $Id: PKGBUILD 172148 2012-11-30 04:20:34Z allan $
# Maintainer: Allan McRae <allan@archlinux.org>
# Contributor: Jan de Groot <jgc@archlinux.org>
pkgname=gdb
-pkgver=7.4.1
+pkgver=7.5.1
pkgrel=1
pkgdesc="The GNU Debugger"
arch=('i686' 'x86_64')
@@ -14,11 +14,13 @@ makedepends=('texinfo')
backup=('etc/gdb/gdbinit')
options=('!libtool')
install=gdb.install
-source=(http://ftp.gnu.org/gnu/gdb/${pkgname}-${pkgver}.tar.bz2{,.sig} siginfo_t.patch)
+source=(http://ftp.gnu.org/gnu/gdb/${pkgname}-${pkgver}.tar.bz2{,.sig})
+md5sums=('3f48f468b24447cf24820054ff6e85b1'
+ '31ab569c78a01d3f946c6fe0336175fe')
build() {
cd ${srcdir}/${pkgname}-${pkgver}
- patch -Np1 <$srcdir/siginfo_t.patch || exit 1
+
./configure --prefix=/usr --disable-nls \
--with-system-readline \
--with-python=/usr/bin/python2 \
@@ -39,6 +41,3 @@ package() {
rm ${pkgdir}/usr/lib/{libbfd,libiberty,libopcodes}.a
rm ${pkgdir}/usr/share/info/{bfd,configure,standards}.info
}
-md5sums=('8854d34691087ec127d934692639855f'
- 'a3d48626efc9e7d802f0734ca39a7878'
- 'd3d6566382696c7d5a1b6aea5df0bbc2')