summaryrefslogtreecommitdiffstats
path: root/abs/core/gettext/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/gettext/PKGBUILD')
-rw-r--r--abs/core/gettext/PKGBUILD47
1 files changed, 29 insertions, 18 deletions
diff --git a/abs/core/gettext/PKGBUILD b/abs/core/gettext/PKGBUILD
index c8dbf03..0980598 100644
--- a/abs/core/gettext/PKGBUILD
+++ b/abs/core/gettext/PKGBUILD
@@ -1,34 +1,45 @@
-# $Id$
# Maintainer:
pkgname=gettext
-pkgver=0.19.8.1
-pkgrel=2
+pkgver=0.21
+pkgrel=1
pkgdesc="GNU internationalization library"
-arch=('x86_64')
-url="http://www.gnu.org/software/gettext/"
-license=('GPL')
-groups=('base' 'base-devel')
-depends=('gcc-libs' 'acl' 'sh' 'glib2' 'libunistring')
+url="https://www.gnu.org/software/gettext/"
+arch=(x86_64)
+license=(GPL)
+groups=(base-devel)
+depends=(gcc-libs acl sh glib2 libunistring libcroco)
+makedepends=(gettext emacs git)
optdepends=('git: for autopoint infrastructure updates')
options=(!docs)
-source=(ftp://ftp.gnu.org/pub/gnu/gettext/${pkgname}-${pkgver}.tar.gz{,.sig})
-validpgpkeys=('462225C3B46F34879FC8496CD605848ED7E69871') # Daiki Ueno
+source=(https://ftp.gnu.org/pub/gnu/gettext/$pkgname-$pkgver.tar.gz{,.sig})
+sha256sums=('c77d0da3102aec9c07f43671e60611ebff89a996ef159497ce8e59d075786b12'
+ 'SKIP')
+validpgpkeys=('462225C3B46F34879FC8496CD605848ED7E69871' # Daiki Ueno
+ '68D94D8AAEEAD48AE7DC5B904F494A942E4616C2'
+ '9001B85AF9E1B83DF1BDA942F5BE8B267C6A406D') # Bruno Haible (Open Source Development)
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- ./configure --prefix=/usr
+ cd $pkgname-$pkgver
+ ./configure \
+ --prefix=/usr \
+ --enable-csharp \
+ --enable-nls \
+ --with-xz \
+ --without-included-gettext
+
+ sed -e 's/ -shared / -Wl,-O1,--as-needed\0/g' \
+ -i gettext-{tools,runtime,runtime/libasprintf}/libtool
+
make
}
check() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- make -j1 -k check
+ cd $pkgname-$pkgver
+ make check
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- make DESTDIR="${pkgdir}" install
+ cd $pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
}
-md5sums=('97e034cf8ce5ba73a28ff6c3c0638092'
- 'SKIP')