summaryrefslogtreecommitdiffstats
path: root/abs/core/gzip/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/gzip/PKGBUILD')
-rw-r--r--abs/core/gzip/PKGBUILD47
1 files changed, 31 insertions, 16 deletions
diff --git a/abs/core/gzip/PKGBUILD b/abs/core/gzip/PKGBUILD
index df04137..7b85e26 100644
--- a/abs/core/gzip/PKGBUILD
+++ b/abs/core/gzip/PKGBUILD
@@ -1,33 +1,48 @@
-# $Id: PKGBUILD 162088 2012-06-19 15:43:54Z allan $
-# Maintainer: Allan McRae <allan@archlinux.org>
+# $Id$
+# Mainainer: Sébastien "Seblu" Luttringer <seblu@archlinux.org>
+# Contributor: Allan McRae <allan@archlinux.org>
# Contributor: judd <jvinet@zeroflux.org>
pkgname=gzip
-pkgver=1.5
+pkgver=1.9
pkgrel=1
-pkgdesc="GNU compression utility"
-arch=('i686' 'x86_64')
-url="http://www.gnu.org/software/gzip/"
+pkgdesc='GNU compression utility'
+arch=('x86_64')
+url='https://www.gnu.org/software/gzip/'
license=('GPL3')
-groups=('base')
-depends=('glibc' 'bash')
-install=gzip.install
-source=(ftp://ftp.gnu.org/pub/gnu/gzip/gzip-$pkgver.tar.xz{,.sig})
-md5sums=('2a431e169b6f62f7332ef6d47cc53bae'
- '2de95937a3f65137acf9c55d4ad0447a')
+groups=('base' 'base-devel')
+depends=('glibc' 'bash' 'less')
+validpgpkeys=('155D3FC500C834486D1EEA677FD9FCCB000BEEEE') # Jim Meyering
+source=("https://ftp.gnu.org/pub/gnu/gzip/gzip-$pkgver.tar.xz"{,.sig})
+md5sums=('9492c6ccb2239ff679a5475a7bb543ed'
+ 'SKIP')
+prepare() {
+ cd $pkgname-$pkgver
+ # apply patch from the source array (should be a pacman feature)
+ local filename
+ for filename in "${source[@]}"; do
+ if [[ "$filename" =~ \.patch$ ]]; then
+ msg2 "Applying patch ${filename##*/}"
+ patch -p1 -N -i "$srcdir/${filename##*/}"
+ fi
+ done
+ :
+}
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd $pkgname-$pkgver
./configure --prefix=/usr
make
}
check() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd $pkgname-$pkgver
make check
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- make prefix=${pkgdir}/usr install
+ cd $pkgname-$pkgver
+ make prefix="$pkgdir/usr" install
}
+
+# vim:set ts=2 sw=2 et: