summaryrefslogtreecommitdiffstats
path: root/abs/core/iproute2/iproute2-fhs.patch
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/iproute2/iproute2-fhs.patch')
-rw-r--r--abs/core/iproute2/iproute2-fhs.patch97
1 files changed, 44 insertions, 53 deletions
diff --git a/abs/core/iproute2/iproute2-fhs.patch b/abs/core/iproute2/iproute2-fhs.patch
index 2608414..add3635 100644
--- a/abs/core/iproute2/iproute2-fhs.patch
+++ b/abs/core/iproute2/iproute2-fhs.patch
@@ -1,48 +1,19 @@
-diff -Naur iproute2.old/Makefile iproute2-2.6.29/Makefile
---- iproute2.old/Makefile 2009-11-11 22:05:21.251407668 +0100
-+++ iproute2-2.6.29/Makefile 2009-11-11 22:07:09.891833516 +0100
-@@ -1,11 +1,12 @@
- DESTDIR=/usr/
+diff -Naur iproute2-3.4.0/Makefile iproute2-3.4.0.new/Makefile
+--- iproute2-3.4.0/Makefile 2012-05-21 23:12:19.000000000 +0200
++++ iproute2-3.4.0.new/Makefile 2012-06-18 10:23:53.896760158 +0200
+@@ -1,7 +1,8 @@
ROOTDIR=$(DESTDIR)
- LIBDIR=/usr/lib/
+ PREFIX=/usr
+ LIBDIR=$(PREFIX)/lib
-SBINDIR=/sbin
+SBINDIR=/usr/sbin
- CONFDIR=/etc/iproute2
--DOCDIR=/share/doc/iproute2
--MANDIR=/share/man
-+DOCDIR=/usr/share/doc/iproute2
-+MANDIR=/usr/share/man
- ARPDDIR=/var/lib/arpd
+SHAREDIR=/usr/share
-
- # Path to db_185.h include
- DBM_INCLUDE:=$(ROOTDIR)/usr/include
-diff -Naur iproute2.old/tc/tc_util.c iproute2-2.6.29/tc/tc_util.c
---- iproute2.old/tc/tc_util.c 2009-11-11 22:05:21.298076943 +0100
-+++ iproute2-2.6.29/tc/tc_util.c 2009-11-11 22:09:32.865152646 +0100
-@@ -24,8 +24,8 @@
- #include "utils.h"
- #include "tc_util.h"
-
--#ifndef LIBDIR
--#define LIBDIR "/usr/lib/"
-+#ifndef SHAREDIR
-+#define SHAREDIR "/usr/share"
- #endif
-
- const char *get_tc_lib(void)
-@@ -34,7 +34,7 @@
-
- lib_dir = getenv("TC_LIB_DIR");
- if (!lib_dir)
-- lib_dir = LIBDIR "/tc/";
-+ lib_dir = SHAREDIR "/tc/";
-
- return lib_dir;
- }
-diff -Naur iproute2.old/netem/Makefile iproute2-2.6.35/netem/Makefile
---- iproute2.old/netem/Makefile 2010-08-06 11:30:48.640940183 +0200
-+++ iproute2-2.6.35/netem/Makefile 2010-08-06 11:32:34.210908892 +0200
+ CONFDIR=/etc/iproute2
+ DATADIR=$(PREFIX)/share
+ DOCDIR=$(DATADIR)/doc/iproute2
+diff -Naur iproute2-3.4.0/netem/Makefile iproute2-3.4.0.new/netem/Makefile
+--- iproute2-3.4.0/netem/Makefile 2012-05-21 23:12:19.000000000 +0200
++++ iproute2-3.4.0.new/netem/Makefile 2012-06-18 10:23:53.896760158 +0200
@@ -20,9 +20,9 @@
$(HOSTCC) $(CCOPTS) -I../include -o $@ $@.c -lm
@@ -55,18 +26,20 @@ diff -Naur iproute2.old/netem/Makefile iproute2-2.6.35/netem/Makefile
done
clean:
-diff -Naur iproute2.old/tc/Makefile iproute2-2.6.35/tc/Makefile
---- iproute2.old/tc/Makefile 2010-08-06 11:48:35.607472252 +0200
-+++ iproute2-2.6.35/tc/Makefile 2010-08-06 11:49:36.977473380 +0200
-@@ -99,18 +99,11 @@
+diff -Naur iproute2-3.4.0/tc/Makefile iproute2-3.4.0.new/tc/Makefile
+--- iproute2-3.4.0/tc/Makefile 2012-05-21 23:12:19.000000000 +0200
++++ iproute2-3.4.0.new/tc/Makefile 2012-06-18 10:23:53.893426840 +0200
+@@ -105,18 +105,11 @@
$(AR) rcs $@ $(TCLIB)
install: all
- mkdir -p $(MODDESTDIR)
-- install -m 0755 tc $(DESTDIR)$(SBINDIR)
-- for i in $(TCSO); \
++ mkdir -p $(DESTDIR)$(LIBDIR)/tc
+ install -m 0755 tc $(DESTDIR)$(SBINDIR)
+ for i in $(TCSO); \
- do install -m 755 $$i $(MODDESTDIR); \
-- done
++ do install -m 755 $$i $(DESTDIR)$(LIBDIR)/tc; \
+ done
- if [ ! -f $(MODDESTDIR)/m_ipt.so ]; then \
- if [ -f $(MODDESTDIR)/m_xt.so ]; \
- then ln -s m_xt.so $(MODDESTDIR)/m_ipt.so ; \
@@ -74,11 +47,29 @@ diff -Naur iproute2.old/tc/Makefile iproute2-2.6.35/tc/Makefile
- then ln -s m_xt_old.so $(MODDESTDIR)/m_ipt.so ; \
- fi; \
- fi
-+ mkdir -p $(DESTDIR)$(LIBDIR)/tc
-+ install -m 0755 tc $(DESTDIR)$(SBINDIR)
-+ for i in $(TCSO); \
-+ do install -m 755 $$i $(DESTDIR)$(LIBDIR)/tc; \
-+ done
clean:
rm -f $(TCOBJ) $(TCLIB) libtc.a tc *.so emp_ematch.yacc.h; \
+diff -Naur iproute2-3.4.0/tc/tc_util.c iproute2-3.4.0.new/tc/tc_util.c
+--- iproute2-3.4.0/tc/tc_util.c 2012-05-21 23:12:19.000000000 +0200
++++ iproute2-3.4.0.new/tc/tc_util.c 2012-06-18 10:23:53.893426840 +0200
+@@ -24,8 +24,8 @@
+ #include "utils.h"
+ #include "tc_util.h"
+
+-#ifndef LIBDIR
+-#define LIBDIR "/usr/lib"
++#ifndef SHAREDIR
++#define SHAREDIR "/usr/share"
+ #endif
+
+ const char *get_tc_lib(void)
+@@ -34,7 +34,7 @@
+
+ lib_dir = getenv("TC_LIB_DIR");
+ if (!lib_dir)
+- lib_dir = LIBDIR "/tc/";
++ lib_dir = SHAREDIR "/tc/";
+
+ return lib_dir;
+ }