summaryrefslogtreecommitdiffstats
path: root/abs/core/libidn2/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/libidn2/PKGBUILD')
-rw-r--r--abs/core/libidn2/PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/abs/core/libidn2/PKGBUILD b/abs/core/libidn2/PKGBUILD
index c0a1a25..f20827a 100644
--- a/abs/core/libidn2/PKGBUILD
+++ b/abs/core/libidn2/PKGBUILD
@@ -1,30 +1,31 @@
-# $Id$
# Maintainer: Evangelos Foutras <evangelos@foutrelis.com>
# Contributor: Daurnimator <quae@daurnimator.com>
pkgname=libidn2
-pkgver=2.0.4
+pkgver=2.1.1
pkgrel=2
pkgdesc="Free software implementation of IDNA2008, Punycode and TR46"
arch=('x86_64')
url="https://www.gnu.org/software/libidn/#libidn2"
license=('GPL2' 'LGPL3')
depends=('libunistring')
-makedepends=('gtk-doc' 'ruby-ronn')
+makedepends=('ruby-ronn')
+provides=('libidn2.so')
source=(https://ftp.gnu.org/gnu/libidn/$pkgname-$pkgver.tar.gz{,.sig})
-sha256sums=('644b6b03b285fb0ace02d241d59483d98bc462729d8bb3608d5cad5532f3d2f0'
+sha256sums=('95416080329298a13269e13175041b530cec3d98b54cafae9424b8dfd22078b1'
'SKIP')
validpgpkeys=('1CB27DBC98614B2D5841646D08302DB6A2670428')
prepare() {
cd $pkgname-$pkgver
- # https://gitlab.com/libidn/libidn2/issues/39
- autoreconf -fvi
}
build() {
cd $pkgname-$pkgver
- ./configure --prefix=/usr
+
+ ./configure \
+ --prefix=/usr \
+ --disable-static
make
}