summaryrefslogtreecommitdiffstats
path: root/abs/core/libvdpau/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/libvdpau/PKGBUILD')
-rw-r--r--abs/core/libvdpau/PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/abs/core/libvdpau/PKGBUILD b/abs/core/libvdpau/PKGBUILD
new file mode 100644
index 0000000..3c44363
--- /dev/null
+++ b/abs/core/libvdpau/PKGBUILD
@@ -0,0 +1,27 @@
+# $Id: $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+
+pkgname=libvdpau
+pkgver=0.4
+pkgrel=1
+pkgdesc="NVIDIA VDPAU library"
+arch=(i686 x86_64)
+url=http://cgit.freedesktop.org/~aplattner/libvdpau
+depends=('gcc-libs>=4.3.3')
+conflicts=('nvidia-utils<190.42-2')
+options=('!libtool' 'force')
+license=('custom')
+source=(http://people.freedesktop.org/~aplattner/vdpau/${pkgname}-${pkgver}.tar.gz)
+makedepends=('libx11')
+sha256sums=('530c630e0784cc65bc31e5b487bd11fccd4049bc861d16844702048821262faa')
+
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr || return 1
+ make || return 1
+ make DESTDIR="${pkgdir}" install || return 1
+
+ install -d -m755 "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/" || return 1
+}