summaryrefslogtreecommitdiffstats
path: root/abs/core/libwmf/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/libwmf/PKGBUILD')
-rw-r--r--abs/core/libwmf/PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/abs/core/libwmf/PKGBUILD b/abs/core/libwmf/PKGBUILD
new file mode 100644
index 0000000..f1c3d17
--- /dev/null
+++ b/abs/core/libwmf/PKGBUILD
@@ -0,0 +1,31 @@
+# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+# Contributor: FJ <joostef@gmail.com>
+pkgname=libwmf
+pkgver=0.2.8.4
+pkgrel=4
+pkgdesc="A library for reading vector images in Microsoft's native Windows Metafile Format (WMF)."
+arch=(i686 x86_64)
+url="http://wvware.sourceforge.net/libwmf.html"
+license=("LGPL")
+depends=('libpng' 'libx11' 'freetype2' 'libjpeg' 'gsfonts' 'expat>=2.0')
+makedepends=('gtk2>=2.10.0' 'pkgconfig')
+options=(!libtool)
+install=libwmf.install
+source=(http://heanet.dl.sf.net/sourceforge/wvware/${pkgname}-${pkgver}.tar.gz)
+md5sums=(d1177739bf1ceb07f57421f0cee191e0)
+
+build() {
+ cd ${startdir}/src/${pkgname}-${pkgver}
+ sed -i -e 's/src include fonts doc/src include fonts/g' Makefile.in
+ ./configure --prefix=/usr \
+ --with-gsfontdir=/usr/share/fonts/Type1 \
+ --with-fontdir=/usr/share/fonts/Type1 \
+ --with-gsfontmap=/usr/share/ghostscript/8.15/lib/Fontmap.GS
+ make || return 1
+ make DESTDIR=${startdir}/pkg install
+ #Remove fonts, these are in gsfonts
+ rm -rf ${startdir}/pkg/usr/share/fonts
+ #Remove static GTK loader, can't use it anyways
+ rm -f ${startdir}/pkg/usr/lib/gtk-2.0/*/loaders/*.a
+}