summaryrefslogtreecommitdiffstats
path: root/abs/core/libxcb/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/libxcb/PKGBUILD')
-rw-r--r--abs/core/libxcb/PKGBUILD34
1 files changed, 22 insertions, 12 deletions
diff --git a/abs/core/libxcb/PKGBUILD b/abs/core/libxcb/PKGBUILD
index c656433..990dbe8 100644
--- a/abs/core/libxcb/PKGBUILD
+++ b/abs/core/libxcb/PKGBUILD
@@ -1,34 +1,44 @@
-# $Id: PKGBUILD 168376 2012-10-09 16:18:34Z andyrtr $
+# $Id$
+# Maintainer: Andreas Radke <andyrtr@archlinux.org>
# Maintainer: Jan de Groot <jgc@archlinux.org>
# Contributor: Alexander Baldeck <alexander@archlinux.org>
pkgname=libxcb
-pkgver=1.9
+pkgver=1.10
pkgrel=1
pkgdesc="X11 client-side library"
-arch=(i686 x86_64)
+arch=('i686' 'x86_64')
url="http://xcb.freedesktop.org/"
-depends=('xcb-proto>=1.7' 'libxdmcp' 'libxau')
+depends=('xcb-proto>=1.10' 'libxdmcp' 'libxau')
makedepends=('pkgconfig' 'libxslt' 'python2')
-options=('!libtool')
license=('custom')
source=($url/dist/$pkgname-$pkgver.tar.bz2
libxcb-1.1-no-pthread-stubs.patch)
-sha1sums=('ad2fb95eeec41ba3d39502a4f7460c3b64fdf061'
- 'd2df03ddf3e949c10c2c185256b0eb7fa02837ab')
+sha256sums=('98d9ab05b636dd088603b64229dd1ab2d2cc02ab807892e107d674f9c3f2d5b5'
+ '748ed83af60468a0eb6785222e4a5ca589d28f20b9bfc60d5936ec93b8eef356')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ patch -Np1 -i ../libxcb-1.1-no-pthread-stubs.patch
+ autoreconf -vfi
+}
build() {
- cd "$srcdir/$pkgname-$pkgver"
- patch -Np1 -i "$srcdir/libxcb-1.1-no-pthread-stubs.patch"
- PYTHON=/usr/bin/python2
- ./autogen.sh --prefix=/usr \
+ cd "$pkgname-$pkgver"
+ ./configure --prefix=/usr \
--enable-xinput \
+ --enable-xkb \
--disable-static
make
}
+check() {
+ cd $pkgname-$pkgver
+ make -k check
+}
+
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$pkgname-$pkgver"
make DESTDIR="$pkgdir" install
install -m755 -d "$pkgdir/usr/share/licenses/$pkgname"
install -m644 COPYING "$pkgdir/usr/share/licenses/$pkgname"