summaryrefslogtreecommitdiffstats
path: root/abs/core/lighttpd
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/lighttpd')
-rw-r--r--abs/core/lighttpd/PKGBUILD4
-rw-r--r--abs/core/lighttpd/__changelog9
-rw-r--r--abs/core/lighttpd/lighttpd.conf10
3 files changed, 17 insertions, 6 deletions
diff --git a/abs/core/lighttpd/PKGBUILD b/abs/core/lighttpd/PKGBUILD
index ba553a2..1758f85 100644
--- a/abs/core/lighttpd/PKGBUILD
+++ b/abs/core/lighttpd/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=lighttpd
pkgver=1.4.28
-pkgrel=3
+pkgrel=4
pkgdesc='A secure, fast, compliant and very flexible web-server'
license=('custom')
arch=('i686' 'x86_64')
@@ -78,5 +78,5 @@ package() {
md5sums=('586eb535d31ac299652495b058dd87c4'
'bd690eee0d9e51857448770a151023b0'
'857e174643fd7761a2f0d8431a679f6c'
- '11fbec7ff7ca1b0d5575445681e8f60e'
+ 'e10f1f82029772115095d45fba3e966a'
'c6e361131000ceec085f40b310ef4a2c')
diff --git a/abs/core/lighttpd/__changelog b/abs/core/lighttpd/__changelog
index 4658cd1..375590d 100644
--- a/abs/core/lighttpd/__changelog
+++ b/abs/core/lighttpd/__changelog
@@ -16,3 +16,12 @@ Added etc/lighttpd/conf.include and etc/lighttpd/html.include to backup array
upgrade to 1.4.28
php-cgi is a depends.
+
+---
+
+added bash and python to cgi list
+ cgi.assign = ( ".pl" => "/usr/bin/perl",
+ ".cgi" => "/usr/bin/perl"
+ ".sh" => "/bin/bash",
+ ".py" => "/usr/bin/python")
+
diff --git a/abs/core/lighttpd/lighttpd.conf b/abs/core/lighttpd/lighttpd.conf
index f437484..79d4f66 100644
--- a/abs/core/lighttpd/lighttpd.conf
+++ b/abs/core/lighttpd/lighttpd.conf
@@ -14,15 +14,15 @@
server.modules = (
"mod_rewrite",
# "mod_redirect",
-# "mod_alias",
+ "mod_alias",
"mod_access",
# "mod_cml",
# "mod_trigger_b4_dl",
"mod_auth",
-# "mod_status",
+ "mod_status",
"mod_setenv",
"mod_fastcgi",
-# "mod_proxy",
+ "mod_proxy",
# "mod_simple_vhost",
# "mod_evhost",
# "mod_userdir",
@@ -235,7 +235,9 @@ server.groupname = "http"
)
#### CGI module
cgi.assign = ( ".pl" => "/usr/bin/perl",
- ".cgi" => "/usr/bin/perl" )
+ ".cgi" => "/usr/bin/perl",
+ ".sh" => "/bin/bash",
+ ".py" => "/usr/bin/python")
url.rewrite-once = (
"^/mythweb/(css|data|images|js|themes|skins|[a-z_]+\.(php|pl)).*" => "$0",