summaryrefslogtreecommitdiffstats
path: root/abs/core/man-pages/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/man-pages/PKGBUILD')
-rw-r--r--abs/core/man-pages/PKGBUILD52
1 files changed, 21 insertions, 31 deletions
diff --git a/abs/core/man-pages/PKGBUILD b/abs/core/man-pages/PKGBUILD
index baa2eba..67b3013 100644
--- a/abs/core/man-pages/PKGBUILD
+++ b/abs/core/man-pages/PKGBUILD
@@ -1,30 +1,27 @@
-# $Id$
# Maintainer: Andreas Radke <andyrtr@archlinux.org>
pkgname=man-pages
-pkgver=4.08
+pkgver=5.08
_posixver=2013-a
pkgrel=1
pkgdesc="Linux man pages"
arch=('any')
license=('GPL' 'custom')
-url="http://man7.org/linux/man-pages/index.html"
-groups=('base')
-depends=()
-source=(http://www.kernel.org/pub/linux/docs/man-pages/$pkgname-$pkgver.tar.{xz,sign}
- http://www.kernel.org/pub/linux/docs/man-pages/man-pages-posix/$pkgname-posix-${_posixver}.tar.{xz,sign})
+url="https://www.kernel.org/doc/man-pages/"
+source=(https://www.kernel.org/pub/linux/docs/man-pages/$pkgname-$pkgver.tar.{xz,sign}
+ https://www.kernel.org/pub/linux/docs/man-pages/man-pages-posix/$pkgname-posix-${_posixver}.tar.{xz,sign})
# https://www.kernel.org/pub/linux/docs/man-pages/sha256sums.asc
-sha256sums=('2c6e7db4d76014dc21b1068df372f325e863318c32056369eca2f169519c62b4'
+sha256sums=('cea7cd31f8080ed8ec6725419e58bbe04ab0dd4fa0071526bd7cf0cd8d1bf7f7'
'SKIP'
'19633a5c75ff7deab35b1d2c3d5b7748e7bd4ef4ab598b647bb7e7f60b90a808'
'SKIP')
-validpgpkeys=('E522595B52EDA4E6BFCCCB5E856199113A35CE5E') #Michael Kerrisk (Linux man-pages maintainer) <mtk.manpages@gmail.com>
+validpgpkeys=('E522595B52EDA4E6BFCCCB5E856199113A35CE5E') # Michael Kerrisk (Linux man-pages maintainer) <mtk.manpages@gmail.com>
build() {
- cd ${srcdir}/$pkgname-$pkgver
+ cd "${srcdir}"/$pkgname-$pkgver
# move the posix pages
- mkdir -p ${srcdir}/$pkgname-$pkgver/man0
+ mkdir -p "${srcdir}"/$pkgname-$pkgver/man0
for sect in 0 1 3; do
sed -i "/^\.so /s/man${sect}p/man$sect/" "${srcdir}/$pkgname-posix-${_posixver}/man${sect}p"/*
mv -iv "${srcdir}/$pkgname-posix-${_posixver}/man${sect}p"/* "${srcdir}/$pkgname-$pkgver/man$sect/"
@@ -32,29 +29,22 @@ build() {
}
package() {
- cd ${srcdir}/$pkgname-$pkgver
+ cd "${srcdir}"/$pkgname-$pkgver
- make prefix=${pkgdir}/usr install
+ make prefix="${pkgdir}"/usr install
# posix pages have a custom license
install -m755 -d "${pkgdir}/usr/share/licenses/${pkgname}"
- install -m644 ${srcdir}/$pkgname-posix-${_posixver}/POSIX-COPYRIGHT "${pkgdir}/usr/share/licenses/${pkgname}/POSIX-COPYRIGHT"
+ install -m644 "${srcdir}"/$pkgname-posix-${_posixver}/POSIX-COPYRIGHT "${pkgdir}/usr/share/licenses/${pkgname}/POSIX-COPYRIGHT"
- cd ${pkgdir}/usr/share/man
- # these are included in coreutils
- rm -f man1/{chgrp,chmod,chown,cp,dir,dd}.1
- rm -f man1/{df,dircolors,du,install,ln,ls}.1
- rm -f man1/{mkdir,mkfifo,mknod,mv,rm,rmdir}.1
- rm -f man1/{touch,vdir}.1
- # this is included in shadow
- rm -f man5/passwd.5
- rm -f man3/getspnam.3
- # this is included in diffutils
- rm -f man1/diff.1
- # this is included in xf86-input-mouse
- rm -f man4/mouse.4
- # this is included in attr
- rm -f man5/attr.5
- # this is included in lirc
- rm -f man4/lirc.4
+ cd "${pkgdir}"/usr/share/man
+ # included in shadow
+ rm man5/passwd.5
+ rm man3/getspnam.3
+ # included in tzdata
+ rm man5/tzfile.5 man8/{tzselect,zdump,zic}.8
+ # included in bpf
+ rm man7/bpf-helpers.7
+ # included in libxcrypt
+ rm man3/crypt*.3
}