summaryrefslogtreecommitdiffstats
path: root/abs/core/mdadm/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/mdadm/PKGBUILD')
-rw-r--r--abs/core/mdadm/PKGBUILD16
1 files changed, 7 insertions, 9 deletions
diff --git a/abs/core/mdadm/PKGBUILD b/abs/core/mdadm/PKGBUILD
index 0af45bf..22ecc25 100644
--- a/abs/core/mdadm/PKGBUILD
+++ b/abs/core/mdadm/PKGBUILD
@@ -1,8 +1,8 @@
# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
# Maintainer: Judd Vinet <jvinet@zeroflux.org>
pkgname=mdadm
-pkgver=3.0
-pkgrel=12
+pkgver=3.1.2
+pkgrel=2
pkgdesc="A tool for managing/monitoring Linux md device arrays, also known as Software RAID"
arch=(i686 x86_64)
license=('GPL')
@@ -12,20 +12,14 @@ depends=('glibc')
backup=('etc/mdadm.conf')
conflicts=('udev<135-4')
source=(ftp://ftp.kernel.org/pub/linux/utils/raid/mdadm/$pkgname-$pkgver.tar.bz2 \
- mdadm mdadm.conf raid-partitions_install raid-partitions_hook)
+ mdadm.conf raid-partitions_install raid-partitions_hook)
replaces=('raidtools')
-md5sums=('bcd27a1359b18e25e61593221d098f6a'
- '6df172c8f77b280018cf87eb3d313f29'
- '0ce4c0f9770bf582a71228053566359d'
- '9de7e423ec9c6766b5f5d39915929003'
- '09d72c714b40b6fa1e8eab04c1dabd42')
build() {
cd $startdir/src/$pkgname-$pkgver
make || return 1
make INSTALL=/bin/install DESTDIR=$startdir/pkg install
install -D -m644 ../mdadm.conf $startdir/pkg/etc/mdadm.conf
- install -D -m755 ../mdadm $startdir/pkg/etc/rc.d/mdadm
install -D -m644 ../raid-partitions_install $startdir/pkg/lib/initcpio/install/raid-partitions
install -D -m644 ../raid-partitions_hook $startdir/pkg/lib/initcpio/hooks/raid-partitions
# a static binary is required for Arch's initrd
@@ -33,3 +27,7 @@ build() {
make LDFLAGS+=-static || return 1
install -D -m755 mdadm $startdir/pkg/sbin/mdadm.static
}
+md5sums=('c5a39f38c465229767a5af2a4eb81bef'
+ '0ce4c0f9770bf582a71228053566359d'
+ '9de7e423ec9c6766b5f5d39915929003'
+ '09d72c714b40b6fa1e8eab04c1dabd42')