summaryrefslogtreecommitdiffstats
path: root/abs/core/mjpegtools
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/mjpegtools')
-rw-r--r--abs/core/mjpegtools/PKGBUILD29
-rw-r--r--abs/core/mjpegtools/__changelog4
-rw-r--r--abs/core/mjpegtools/gcc_3.7.patch11
-rw-r--r--abs/core/mjpegtools/mjpegtools-1.9.0-glibc-2.10.patch11
-rw-r--r--abs/core/mjpegtools/mjpegtools-1.9.0-jpeg-7.patch24
-rw-r--r--abs/core/mjpegtools/mjpegtools-v4l-2.6.38.patch100
-rw-r--r--abs/core/mjpegtools/mjpegtools.install6
-rw-r--r--abs/core/mjpegtools/png2yuv-fix-memleak.patch10
8 files changed, 128 insertions, 67 deletions
diff --git a/abs/core/mjpegtools/PKGBUILD b/abs/core/mjpegtools/PKGBUILD
index bf31ebf..3615c32 100644
--- a/abs/core/mjpegtools/PKGBUILD
+++ b/abs/core/mjpegtools/PKGBUILD
@@ -1,35 +1,27 @@
-# $Id: PKGBUILD 84755 2010-07-04 03:32:01Z eric $
+# $Id: PKGBUILD 148854 2012-02-05 11:52:58Z ibiru $
# Contributor: Damir Perisa <damir.perisa@bluewin.ch>
-# Mantainer: Roberto Carvajal <roberto@archlinux.org>
+# Maintainer: Roberto Carvajal <roberto@archlinux.org>
pkgname=mjpegtools
-pkgver=1.9.0
-pkgrel=12
+pkgver=2.0.0
+pkgrel=1
pkgdesc="Set of tools that can do recording of videos and playback, simple cut-and-paste editing and the MPEG compression of audio and video"
arch=(i686 x86_64)
license=('GPL')
url="http://mjpeg.sourceforge.net/"
-depends=('libjpeg>=8' 'libpng>=1.4.0' 'sdl' 'gcc-libs' 'libdv' 'libjpeg6')
-makedepends=('gtk2>=2.18.6')
+depends=('libjpeg' 'libpng' 'sdl' 'gcc-libs' 'libdv')
+makedepends=('gtk2' 'v4l-utils')
optdepends=('gtk2: glav GUI')
options=('!makeflags' '!libtool')
install=mjpegtools.install
source=(http://downloads.sourceforge.net/sourceforge/mjpeg/${pkgname}-${pkgver}.tar.gz
- mjpegtools-1.9.0-glibc-2.10.patch
- png2yuv-fix-memleak.patch
- mjpegtools-1.9.0-jpeg-7.patch)
-md5sums=('309a6fcf0900a010d6a9c1e91afc2f5c' 'b8ae66237d83be533db8eea166fd3357'\
- '39e1def8fb0f7c58a217b22dc251a86a' 'ccc7562a3933877d3362da7cf4695ea0')
-sha1sums=('1701233354c7ea86b5b7808c4dd5d03a71118e48' '3029f0e835e693b144298ed9f8143c9566be26f3'\
- '8af5c3747756353bef56d03bafbdd086ff15c02c' '2bdb1b3b8591cede11d4a133a758e8ead35db4dd')
+ mjpegtools-v4l-2.6.38.patch gcc_3.7.patch)
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -Np0 -i "${srcdir}/mjpegtools-v4l-2.6.38.patch"
+ patch -Np1 -i "${srcdir}/gcc_3.7.patch"
sed -i -e '/ARCHFLAGS=/s:=.*:=:' configure
- patch -Np1 -i "$srcdir/mjpegtools-1.9.0-glibc-2.10.patch"
- patch -Np1 -i "${srcdir}/png2yuv-fix-memleak.patch"
- patch -Np0 -i "${srcdir}/mjpegtools-1.9.0-jpeg-7.patch"
- env CPPFLAGS="-I/opt/libjpeg6/include" LDFLAGS="-L/opt/libjpeg6/lib"
./configure --prefix=/usr --enable-largefile
make
}
@@ -39,3 +31,6 @@ package() {
make DESTDIR="${pkgdir}" install
install -m644 mpeg2enc/mpeg2syntaxcodes.h "${pkgdir}/usr/include/mjpegtools/mpeg2enc/"
}
+md5sums=('903e1e3b967eebcc5fe5626d7517dc46'
+ '44006d6f844017fe57aa123aa43f4508'
+ '7c9b3d4a1f3a10e3263a6a110b0f55cc')
diff --git a/abs/core/mjpegtools/__changelog b/abs/core/mjpegtools/__changelog
index aa74d17..8244652 100644
--- a/abs/core/mjpegtools/__changelog
+++ b/abs/core/mjpegtools/__changelog
@@ -1,2 +1,2 @@
-change to build against libjpeg6
- env CPPFLAGS="-I/opt/libjpeg6/include" LDFLAGS="-L/opt/libjpeg6/lib" ./configure -
+added gcc 3.7.patch
+https://bugs.gentoo.org/show_bug.cgi?id=409197
diff --git a/abs/core/mjpegtools/gcc_3.7.patch b/abs/core/mjpegtools/gcc_3.7.patch
new file mode 100644
index 0000000..050b33f
--- /dev/null
+++ b/abs/core/mjpegtools/gcc_3.7.patch
@@ -0,0 +1,11 @@
+--- a/y4mdenoise/MotionSearcher.hh
++++ b/y4mdenoise/MotionSearcher.hh
+@@ -2196,7 +2196,7 @@
+ {
+ // This region is too small to be bothered with.
+ // Just get rid of it.
+- DeleteRegion (a_pRegion);
++ this->DeleteRegion (a_pRegion);
+ }
+ else
+ {
diff --git a/abs/core/mjpegtools/mjpegtools-1.9.0-glibc-2.10.patch b/abs/core/mjpegtools/mjpegtools-1.9.0-glibc-2.10.patch
deleted file mode 100644
index e161560..0000000
--- a/abs/core/mjpegtools/mjpegtools-1.9.0-glibc-2.10.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- mjpegtools-1.9.0/mplex/lpcmstrm_in.cpp.orig 2009-05-27 01:31:46.000000000 -0700
-+++ mjpegtools-1.9.0/mplex/lpcmstrm_in.cpp 2009-05-27 01:33:09.000000000 -0700
-@@ -53,7 +53,7 @@
-
- bool LPCMStream::Probe(IBitStream &bs )
- {
-- char *last_dot = strrchr( bs.StreamName(), '.' );
-+ const char *last_dot = strrchr( bs.StreamName(), '.' );
- return
- last_dot != NULL
- && strcmp( last_dot+1, "lpcm") == 0;
diff --git a/abs/core/mjpegtools/mjpegtools-1.9.0-jpeg-7.patch b/abs/core/mjpegtools/mjpegtools-1.9.0-jpeg-7.patch
deleted file mode 100644
index ec36731..0000000
--- a/abs/core/mjpegtools/mjpegtools-1.9.0-jpeg-7.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-Fix segmentation fault with jpeg-7 and above where dinfo.do_fancy_upsampling isn't set by default to FALSE anymore.
-
-Patch by: Salah Coronya
-
-http://bugs.gentoo.org/show_bug.cgi?id=293919
-
---- lavtools/jpegutils.c
-+++ lavtools/jpegutils.c
-@@ -502,6 +502,7 @@
-
- jpeg_read_header (&dinfo, TRUE);
- dinfo.raw_data_out = TRUE;
-+ dinfo.do_fancy_upsampling = FALSE;
- dinfo.out_color_space = JCS_YCbCr;
- dinfo.dct_method = JDCT_IFAST;
- guarantee_huff_tables(&dinfo);
-@@ -599,6 +600,7 @@
- if (field > 0) {
- jpeg_read_header (&dinfo, TRUE);
- dinfo.raw_data_out = TRUE;
-+ dinfo.do_fancy_upsampling = FALSE;
- dinfo.out_color_space = JCS_YCbCr;
- dinfo.dct_method = JDCT_IFAST;
- jpeg_start_decompress (&dinfo);
diff --git a/abs/core/mjpegtools/mjpegtools-v4l-2.6.38.patch b/abs/core/mjpegtools/mjpegtools-v4l-2.6.38.patch
new file mode 100644
index 0000000..6adeb92
--- /dev/null
+++ b/abs/core/mjpegtools/mjpegtools-v4l-2.6.38.patch
@@ -0,0 +1,100 @@
+Index: lavtools/lavvideo.c
+===================================================================
+--- lavtools/lavvideo.c.orig
++++ lavtools/lavvideo.c
+@@ -63,7 +63,7 @@ Copyright by Gernot Ziegler.
+ * errors here, check your linux/time.h && sys/time.h header setup.
+ */
+ #define _LINUX_TIME_H
+-#include <linux/videodev.h>
++#include <libv4l1-videodev.h>
+
+ #include <videodev_mjpeg.h>
+ #include <frequencies.h>
+Index: lavtools/liblavplay.c
+===================================================================
+--- lavtools/liblavplay.c.orig
++++ lavtools/liblavplay.c
+@@ -68,7 +68,8 @@
+ * errors here, check your linux/time.h && sys/time.h header setup.
+ */
+ #define _LINUX_TIME_H
+-#include <linux/videodev.h>
++#include <libv4l1-videodev.h>
++#define BASE_VIDIOCPRIVATE 192 /* 192-255 are private */
+ #else
+ #define VIDEO_MODE_PAL 0
+ #define VIDEO_MODE_NTSC 1
+Index: lavtools/liblavrec.c
+===================================================================
+--- lavtools/liblavrec.c.orig
++++ lavtools/liblavrec.c
+@@ -63,7 +63,8 @@
+ * errors here, check your linux/time.h && sys/time.h header setup.
+ */
+ #define _LINUX_TIME_H
+-#include <linux/videodev.h>
++#include <libv4l1-videodev.h>
++#define BASE_VIDIOCPRIVATE 192 /* 192-255 are private */
+ #ifdef HAVE_SYS_SOUNDCARD_H
+ #include <sys/soundcard.h>
+ #endif
+Index: lavtools/testrec.c
+===================================================================
+--- lavtools/testrec.c.orig
++++ lavtools/testrec.c
+@@ -89,7 +89,7 @@
+ * errors here, check your linux/time.h && sys/time.h header setup.
+ */
+ #define _LINUX_TIME_H
+-#include <linux/videodev.h>
++#include <libv4l1-videodev.h>
+ #include <linux/soundcard.h>
+
+ /* These are explicit prototypes for the compiler, to prepare separation of audiolib.c */
+Index: configure.ac
+===================================================================
+--- configure.ac.orig
++++ configure.ac
+@@ -164,7 +164,7 @@ AC_ARG_WITH([v4l], AC_HELP_STRING([--wit
+ AS_IF([test "x$with_v4l" != "xno"], [
+ case $host in
+ *-*-linux*)
+- AC_CHECK_HEADER(linux/videodev.h,
++ AC_CHECK_HEADER(libv4l1-videodev.h,
+ [have_video4linux=true
+ AC_DEFINE(HAVE_V4L, 1,
+ [Building for Linux - using the video4linux API])], [])
+@@ -173,7 +173,7 @@ esac])
+
+ AS_IF([test "x$have_video4linux" != "xtrue" && test "x$with_v4l" != "xno"],
+ [have_video4linux=false
+- AC_MSG_WARN([videodev.h not found - please install the linux kernel headers programms needing v4l disabled])])
++ AC_MSG_WARN([libv4l1-videodev.h not found - please install the linux kernel headers programms needing v4l disabled])])
+ AM_CONDITIONAL(HAVE_V4L, test x$have_video4linux = xtrue)
+
+ dnl *********************************************************************
+Index: configure
+===================================================================
+--- configure.orig
++++ configure
+@@ -16392,7 +16392,7 @@ if test "x$with_v4l" != "xno"; then :
+
+ case $host in
+ *-*-linux*)
+- ac_fn_c_check_header_mongrel "$LINENO" "linux/videodev.h" "ac_cv_header_linux_videodev_h" "$ac_includes_default"
++ ac_fn_c_check_header_mongrel "$LINENO" "libv4l1-videodev.h" "ac_cv_header_linux_videodev_h" "$ac_includes_default"
+ if test "x$ac_cv_header_linux_videodev_h" = xyes; then :
+ have_video4linux=true
+
+@@ -16407,8 +16407,8 @@ fi
+
+ if test "x$have_video4linux" != "xtrue" && test "x$with_v4l" != "xno"; then :
+ have_video4linux=false
+- { $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: videodev.h not found - please install the linux kernel headers programms needing v4l disabled" >&5
+-$as_echo "$as_me: WARNING: videodev.h not found - please install the linux kernel headers programms needing v4l disabled" >&2;}
++ { $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: libv4l1-videodev.h not found - please install the linux kernel headers programms needing v4l disabled" >&5
++$as_echo "$as_me: WARNING: libv4l1-videodev.h not found - please install the linux kernel headers programms needing v4l disabled" >&2;}
+ fi
+ if test x$have_video4linux = xtrue; then
+ HAVE_V4L_TRUE=
diff --git a/abs/core/mjpegtools/mjpegtools.install b/abs/core/mjpegtools/mjpegtools.install
index 1ef7d6f..4d12316 100644
--- a/abs/core/mjpegtools/mjpegtools.install
+++ b/abs/core/mjpegtools/mjpegtools.install
@@ -1,8 +1,8 @@
-infodir=/usr/share/info
+infodir=usr/share/info
file=mjpeg-howto.info
post_install() {
- [ -x usr/bin/install-info ] || return 0
+ [[ -x usr/bin/install-info ]] || return 0
install-info $infodir/$file.gz $infodir/dir 2> /dev/null
}
@@ -11,6 +11,6 @@ post_upgrade() {
}
pre_remove() {
- [ -x usr/bin/install-info ] || return 0
+ [[ -x usr/bin/install-info ]] || return 0
install-info --delete $infodir/$file.gz $infodir/dir 2> /dev/null
}
diff --git a/abs/core/mjpegtools/png2yuv-fix-memleak.patch b/abs/core/mjpegtools/png2yuv-fix-memleak.patch
deleted file mode 100644
index a6f03a4..0000000
--- a/abs/core/mjpegtools/png2yuv-fix-memleak.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- mjpegtools-1.9.0/lavtools/png2yuv.c.orig 2010-01-17 14:26:24.000000000 +0100
-+++ mjpegtools-1.9.0/lavtools/png2yuv.c 2010-01-17 14:27:53.000000000 +0100
-@@ -407,6 +407,7 @@
- return 2;
- }
-
-+ png_destroy_read_struct(&png_ptr, &info_ptr, &end_info);
- fclose(pngfile);
-
- return 1;