summaryrefslogtreecommitdiffstats
path: root/abs/core/mkinitcpio
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/mkinitcpio')
-rw-r--r--abs/core/mkinitcpio/0001-Update-module-filter-to-be-aware-of-hyphens-in-the-M.patch29
-rw-r--r--abs/core/mkinitcpio/0002-shutdown-don-t-alert-udev-on-disable-VGs.patch28
-rw-r--r--abs/core/mkinitcpio/PKGBUILD47
-rw-r--r--abs/core/mkinitcpio/__changelog8
-rw-r--r--abs/core/mkinitcpio/mkinitcpio.conf.patch20
-rw-r--r--abs/core/mkinitcpio/mkinitcpio.install8
-rw-r--r--abs/core/mkinitcpio/mkinitcpio.patch20
7 files changed, 118 insertions, 42 deletions
diff --git a/abs/core/mkinitcpio/0001-Update-module-filter-to-be-aware-of-hyphens-in-the-M.patch b/abs/core/mkinitcpio/0001-Update-module-filter-to-be-aware-of-hyphens-in-the-M.patch
new file mode 100644
index 0000000..042a0b9
--- /dev/null
+++ b/abs/core/mkinitcpio/0001-Update-module-filter-to-be-aware-of-hyphens-in-the-M.patch
@@ -0,0 +1,29 @@
+From 7cf7ac4eb2c29a2b1aa748dae7658da5fbbc3a18 Mon Sep 17 00:00:00 2001
+From: Brian Parsons <brian@pmex.com>
+Date: Mon, 11 Jun 2012 17:30:10 -0400
+Subject: [PATCH 1/2] Update module filter to be aware of hyphens in the
+ MODULES array
+
+[dave: fix whitespace and re-add needed quoting]
+
+Signed-off-by: Dave Reisner <dreisner@archlinux.org>
+---
+ functions | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/functions b/functions
+index 4a62d8e..e9fb81a 100644
+--- a/functions
++++ b/functions
+@@ -590,7 +590,7 @@ write_image_config() {
+ . "$CONFIG"
+
+ # sanitize of any extra whitespace
+- read -ra modules <<< "$MODULES"
++ read -ra modules <<<"${MODULES//-/_}"
+ for mod in "${modules[@]}"; do
+ in_array "${mod%\?}" "${ADDED_MODULES[@]}" || continue
+ add+=("${mod%\?}")
+--
+1.7.10.4
+
diff --git a/abs/core/mkinitcpio/0002-shutdown-don-t-alert-udev-on-disable-VGs.patch b/abs/core/mkinitcpio/0002-shutdown-don-t-alert-udev-on-disable-VGs.patch
new file mode 100644
index 0000000..7a1aba9
--- /dev/null
+++ b/abs/core/mkinitcpio/0002-shutdown-don-t-alert-udev-on-disable-VGs.patch
@@ -0,0 +1,28 @@
+From c257b0d7b4dd1c3f9b63c6a27b68a27bc246acea Mon Sep 17 00:00:00 2001
+From: Dave Reisner <dreisner@archlinux.org>
+Date: Tue, 12 Jun 2012 19:18:18 -0400
+Subject: [PATCH 2/2] shutdown: don't alert udev on disable VGs
+
+Fixes FS#30271.
+
+Signed-off-by: Dave Reisner <dreisner@archlinux.org>
+---
+ shutdown | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/shutdown b/shutdown
+index ce7de23..fd88105 100644
+--- a/shutdown
++++ b/shutdown
+@@ -25,7 +25,7 @@ stop_device() {
+ read devname <"$1/dm/name"
+ lvm lvdisplay -c "/dev/mapper/$devname" | {
+ IFS=: read _ vgname _
+- lvm vgchange -an "$vgname"
++ lvm vgchange --noudevsync -an "$vgname"
+ }
+ ;;
+ raid*)
+--
+1.7.10.4
+
diff --git a/abs/core/mkinitcpio/PKGBUILD b/abs/core/mkinitcpio/PKGBUILD
index 0631650..32b9fdb 100644
--- a/abs/core/mkinitcpio/PKGBUILD
+++ b/abs/core/mkinitcpio/PKGBUILD
@@ -1,29 +1,44 @@
+# $Id: PKGBUILD 161860 2012-06-15 22:35:26Z dreisner $
+# Maintainer: Dave Reisner <dreisner@archlinux.org>
# Maintainer: Thomas Bächler <thomas@archlinux.org>
-
pkgname=mkinitcpio
-pkgver=0.7.2
-pkgrel=11
+pkgver=0.9.2
+pkgrel=3
pkgdesc="Modular initramfs image creation utility"
-arch=(any)
+arch=('any')
url="http://www.archlinux.org/"
license=('GPL')
-depends=('mkinitcpio-busybox>=1.16.1-2' 'mkinitcpio-nfs-utils=>0.2' 'module-init-tools' 'util-linux>=2.19' 'libarchive' 'coreutils'
- 'bash' 'findutils' 'sed' 'grep' 'filesystem>=2009.01-2' 'udev>=171-2' 'file' 'gzip'
- 'which')
+depends=('awk' 'mkinitcpio-busybox>=1.19.4-2' 'kmod>=3' 'util-linux>=2.21' 'libarchive' 'coreutils'
+ 'bash' 'findutils' 'grep' 'filesystem>=2011.10-1' 'file' 'gzip' 'systemd-tools')
optdepends=('xz: Use lzma or xz compression for the initramfs image'
'bzip2: Use bzip2 compression for the initramfs image'
'lzop: Use lzo compression for the initramfs image'
'mkinitcpio-nfs-utils: Support for root filesystem on NFS')
-replaces=('mkinitrd' 'mkinitramfs' 'klibc' 'klibc-extras' 'klibc-kbd'
- 'klibc-module-init-tools' 'klibc-udev')
-source=(ftp://ftp.archlinux.org/other/${pkgname}/${pkgname}-${pkgver}.tar.gz mkinitcpio.conf.patch)
-backup=(etc/mkinitcpio.conf)
+backup=('etc/mkinitcpio.conf')
+source=("ftp://ftp.archlinux.org/other/$pkgname/$pkgname-$pkgver.tar.gz"
+ 0001-Update-module-filter-to-be-aware-of-hyphens-in-the-M.patch
+ 0002-shutdown-don-t-alert-udev-on-disable-VGs.patch
+ mkinitcpio.patch)
+install=mkinitcpio.install
package() {
- cd $srcdir/${pkgname}-${pkgver}
- patch -p0 < $srcdir/mkinitcpio.conf.patch
- make DESTDIR="${pkgdir}" install
+ cd "$pkgname-$pkgver"
+
+ patch -Np1 <"$srcdir"/0001-Update-module-filter-to-be-aware-of-hyphens-in-the-M.patch
+ patch -Np1 <"$srcdir"/0002-shutdown-don-t-alert-udev-on-disable-VGs.patch
+
+ make DESTDIR="$pkgdir" install
+
+ # compat symlink
+ install -dm755 "$pkgdir/sbin"
+ ln -s /usr/bin/mkinitcpio "$pkgdir/sbin/mkinitcpio"
+
+ cd $pkgdir/etc
+ patch -Np0 < $srcdir/mkinitcpio.patch || exit 1
}
-md5sums=('e11670a7d4802b2ef20cab4b3815168a'
- '36da3320c907bf3b41b74fc824cbd1d8')
+
+md5sums=('6894147b09012054e025bfbe03445cda'
+ 'e6e2aafa24f6c9d58b483e8df4dafdec'
+ 'ffd144b1c8b3950671dacdc1c4a5e80d'
+ 'e317ad4c65eae59eb75bd8adba8b0b4c')
diff --git a/abs/core/mkinitcpio/__changelog b/abs/core/mkinitcpio/__changelog
index c8dbb63..a2eacb9 100644
--- a/abs/core/mkinitcpio/__changelog
+++ b/abs/core/mkinitcpio/__changelog
@@ -1,6 +1,2 @@
-added "usb" and net to the modules line in mkinitcpio.conf
-+HOOKS="base udev usb net autodetect pata scsi sata filesystems usbinput"
-
-MODULES="nfs"
-
-added depends: mkinitcpio-nfs-utils
+modified mkinitcpio.patch to move fsck earlier in the hook
+this is needed so that drives other then / can mount during boot
diff --git a/abs/core/mkinitcpio/mkinitcpio.conf.patch b/abs/core/mkinitcpio/mkinitcpio.conf.patch
deleted file mode 100644
index 800b347..0000000
--- a/abs/core/mkinitcpio/mkinitcpio.conf.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- mkinitcpio.conf.orig 2011-08-06 00:04:15.991131194 +0000
-+++ mkinitcpio.conf 2011-08-06 00:04:02.791130644 +0000
-@@ -4,7 +4,7 @@
- # run. Advanced users may wish to specify all system modules
- # in this array. For instance:
- # MODULES="piix ide_disk reiserfs"
--MODULES=""
-+MODULES="nfs"
-
- # BINARIES
- # This setting includes any additional binaries a given user may
-@@ -54,7 +54,7 @@
- #
- ## This setup loads an lvm2 volume group on a usb device.
- # HOOKS="base udev usb lvm2 filesystems"
--HOOKS="base udev autodetect pata scsi sata filesystems usbinput"
-+HOOKS="base udev usb net autodetect pata scsi sata filesystems usbinput fbsplash"
-
- # COMPRESSION
- # Use this to compress the initramfs image. With kernels earlier than
diff --git a/abs/core/mkinitcpio/mkinitcpio.install b/abs/core/mkinitcpio/mkinitcpio.install
new file mode 100644
index 0000000..d8bbfdb
--- /dev/null
+++ b/abs/core/mkinitcpio/mkinitcpio.install
@@ -0,0 +1,8 @@
+#!/bin/sh
+
+post_upgrade() {
+ if [ "$(vercmp 0.9.0 "$2")" -eq 1 ]; then
+ printf '==> If your /usr is on a separate partition, you must add the "usr" hook\n'
+ printf ' to /etc/mkinitcpio.conf and regenerate your images before rebooting\n'
+ fi
+}
diff --git a/abs/core/mkinitcpio/mkinitcpio.patch b/abs/core/mkinitcpio/mkinitcpio.patch
new file mode 100644
index 0000000..2b35f81
--- /dev/null
+++ b/abs/core/mkinitcpio/mkinitcpio.patch
@@ -0,0 +1,20 @@
+--- mkinitcpio.conf.orig 2012-08-22 23:26:28.952203845 +0000
++++ mkinitcpio.conf 2012-08-22 23:25:44.408871852 +0000
+@@ -4,7 +4,7 @@
+ # run. Advanced users may wish to specify all system modules
+ # in this array. For instance:
+ # MODULES="piix ide_disk reiserfs"
+-MODULES=""
++MODULES="nfs reiserfs xfs jfs ext4"
+
+ # BINARIES
+ # This setting includes any additional binaries a given user may
+@@ -56,7 +56,7 @@
+ #
+ ## NOTE: If you have /usr on a separate partition, you MUST include the
+ # usr, fsck and shutdown hooks.
+-HOOKS="base udev autodetect pata scsi sata filesystems usbinput fsck"
++HOOKS="base udev fsck autodetect pata scsi sata filesystems usb usbinput resume fbsplash"
+
+ # COMPRESSION
+ # Use this to compress the initramfs image. By default, gzip compression