summaryrefslogtreecommitdiffstats
path: root/abs/core/mpfr/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/mpfr/PKGBUILD')
-rw-r--r--abs/core/mpfr/PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/abs/core/mpfr/PKGBUILD b/abs/core/mpfr/PKGBUILD
new file mode 100644
index 0000000..ac2ab77
--- /dev/null
+++ b/abs/core/mpfr/PKGBUILD
@@ -0,0 +1,26 @@
+# $Id: PKGBUILD 12992 2008-09-25 17:47:29Z jgc $
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+# Contributor: damir <damir@archlinux.org>
+
+pkgname=mpfr
+pkgver=2.3.2
+pkgrel=2
+pkgdesc="multiple-precision floating-point library"
+arch=(i686 x86_64)
+license=('GPL' 'LGPL')
+url="http://www.mpfr.org/"
+depends=('gmp>=4.2.3' 'texinfo')
+options=('!libtool')
+install=mpfr.install
+#source=(http://www.mpfr.org/mpfr-current/mpfr-${pkgver}.tar.gz)
+
+source=(http://modular.math.washington.edu/home/novocin/tars/mpfr-2.3.2.tar.gz)
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr --enable-thread-safe --enable-shared || return 1
+ make || return 1
+ make DESTDIR="${pkgdir}" install || return 1
+ cd "${pkgdir}/usr/share/info" || return 1
+ rm -f dir
+ gzip * || return 1
+}