summaryrefslogtreecommitdiffstats
path: root/abs/core/mythinstall
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/mythinstall')
-rwxr-xr-xabs/core/mythinstall/MythVantage-app/mythinstall/installdialog.cpp3
-rwxr-xr-xabs/core/mythinstall/MythVantage-app/mythinstall/installsettings.cpp32
-rwxr-xr-xabs/core/mythinstall/MythVantage-app/mythinstall/installsettings.h1
-rwxr-xr-xabs/core/mythinstall/MythVantage-app/mythinstall/main.cpp6
-rw-r--r--abs/core/mythinstall/PKGBUILD6
5 files changed, 33 insertions, 15 deletions
diff --git a/abs/core/mythinstall/MythVantage-app/mythinstall/installdialog.cpp b/abs/core/mythinstall/MythVantage-app/mythinstall/installdialog.cpp
index ac72a0b..e18da49 100755
--- a/abs/core/mythinstall/MythVantage-app/mythinstall/installdialog.cpp
+++ b/abs/core/mythinstall/MythVantage-app/mythinstall/installdialog.cpp
@@ -116,7 +116,8 @@ void WelcomeDialog::runLIVECD(void)
if ( runsettings(true) == 1 )
{
QString PAINTER = gCoreContext->GetSetting("ThemePainter");
- QString startFECmd = ("MYTHCONFDIR=/tmp mythfrontend -O ThemePainter=" + PAINTER );
+ QString SERVERIP = gCoreContext->GetSetting("HostMysqlServer");
+ QString startFECmd = ("MYTHCONFDIR=/tmp mythfrontend -O ThemePainter=" + PAINTER + " -O AudioOutputDevice=ALSA:default -O MasterServerIP=" + SERVERIP );
myth_system(startFECmd.ascii());
}
else
diff --git a/abs/core/mythinstall/MythVantage-app/mythinstall/installsettings.cpp b/abs/core/mythinstall/MythVantage-app/mythinstall/installsettings.cpp
index 3592f09..05acc5e 100755
--- a/abs/core/mythinstall/MythVantage-app/mythinstall/installsettings.cpp
+++ b/abs/core/mythinstall/MythVantage-app/mythinstall/installsettings.cpp
@@ -56,7 +56,7 @@ static HostComboBox *ThemePainter()
gc->setLabel(QObject::tr("Paint Engine"));
gc->addSelection(QObject::tr("Qt"), "qt");
gc->addSelection(QObject::tr("OpenGL"), "opengl");
- gc->setHelpText(QObject::tr("This selects what Myth uses to draw. If you have decent hardware, select OpenGL. Changing this requires a restart."));
+ gc->setHelpText(QObject::tr("This selects what Myth uses to draw. If you have decent hardware, select OpenGL. Changing this requires a restart."));
return gc;
}
@@ -453,8 +453,9 @@ static HostCheckBox *HostRunFrontend()
static HostComboBox *HostMysqlserverip_listbox()
{
HostComboBox *gc = new HostComboBox("HostMysqlServer",true);
- gc->setLabel(QObject::tr("Mysql server"));
+ gc->setLabel(QObject::tr("MySQL Server"));
+ myth_system("avahi-browse -l -r -t _mysql._tcp > /tmp/mysqllist");
QString currentitem;
QString prevline;
QString line;
@@ -479,8 +480,8 @@ static HostComboBox *HostMysqlserverip_listbox()
file.close();
//system ("rm -f /tmp/mysqllist");
}
- gc->addSelection("Manual: type ip here");
- gc->setHelpText(QObject::tr(""));
+ gc->addSelection("Manual: Enter IP Address");
+ gc->setHelpText(QObject::tr("The IP address of the MasterBackend MySQL server."));
QString NETBOOT = getenv("NETBOOT");
NETBOOT=NETBOOT.stripWhiteSpace();
@@ -1151,9 +1152,18 @@ static HostCheckBox *HostHuluDesktop()
static HostCheckBox *HostXBMC()
{
HostCheckBox *gc = new HostCheckBox("HostXBMC");
- gc->setLabel(QObject::tr("XBMC"));
+ gc->setLabel(QObject::tr("Kodi"));
gc->setValue(false);
- gc->setHelpText(QObject::tr("A software media player and entertainment hub for digital media."));
+ gc->setHelpText(QObject::tr("Kodi (formerly known as XBMC) is an award-winning free and open source (GPL) software media player and entertainment hub, featuring a 10-foot user interface for use with televisions and remote controls."));
+ return gc;
+};
+
+static HostCheckBox *HostPLEXHT()
+{
+ HostCheckBox *gc = new HostCheckBox("HostPLEXHT");
+ gc->setLabel(QObject::tr("Plex Home Theater"));
+ gc->setValue(false);
+ gc->setHelpText(QObject::tr("Plex organizes all of your personal media, wherever you keep it, so you can enjoy it on any device."));
return gc;
};
@@ -3603,7 +3613,7 @@ int runsettings (bool mysqlonly , bool shownetwork , bool showhostype,
int retc = 0 ;
displaymysqlonly = mysqlonly;
- if (displaymysqlonly )
+ if (displaymysqlonly)
{
MythInstallSettings mysqlsettings;
mysqlsettings.Load();
@@ -3636,7 +3646,7 @@ int runsettings (bool mysqlonly , bool shownetwork , bool showhostype,
displayshownetwork = false;
};
- if ( showhostype && continuerun )
+ if ( showhostype && continuerun )
{
displayshowhostype = showhostype;
system ("avahi-browse -l -r -t _mysql._tcp > /tmp/mysqllist");
@@ -3993,6 +4003,7 @@ void writesettings ()
hostparm.ThisHostHuluDesktop = gCoreContext->GetSetting("HostHuluDesktop");
hostparm.ThisHostwebonlinhes = gCoreContext->GetSetting("HostWebonlinhes");
hostparm.ThisHostXBMC = gCoreContext->GetSetting("HostXBMC");
+ hostparm.ThisHostPLEXHT = gCoreContext->GetSetting("HostPLEXHT");
hostparm.ThisHostfoldingathome = gCoreContext->GetSetting("Hostfoldingathome");
hostparm.ThisHostfoldingusername = gCoreContext->GetSetting("Hostfoldingusername");
@@ -4325,7 +4336,8 @@ void writesettings ()
// myfile << "miro=\"" + hostparm.ThisHostMiro + "\"\n";
myfile << "webonlinhes=\"" + hostparm.ThisHostwebonlinhes + "\"\n";
myfile << "huludesktop=\"" + hostparm.ThisHostHuluDesktop + "\"\n";
- myfile << "xbmc=\"" + hostparm.ThisHostXBMC + "\"\n";
+ myfile << "kodi=\"" + hostparm.ThisHostXBMC + "\"\n";
+ myfile << "plexhometheater=\"" + hostparm.ThisHostPLEXHT + "\"\n";
myfile << "foldingathome=\"" + hostparm.ThisHostfoldingathome + "\"\n";
myfile << "foldingusername=\"" + hostparm.ThisHostfoldingusername + "\"\n";
myfile << "foldingworksize=\"" + hostparm.ThisHostfoldingworksize + "\"\n";
@@ -4420,6 +4432,7 @@ MythInstallSettings::MythInstallSettings()
denied->addChild(deniedlabel);
if ( displaymysqlonly )
{
+ vcg->setLabel(QObject::tr("Run MythFrontend Settings"));
vcg->addChild(HostMysqlserverip_listbox());
vcg->addChild(ThemePainter());
addChild(vcg);
@@ -4748,6 +4761,7 @@ MythInstallSettings::MythInstallSettings()
//GridShowPlugin4->addChild(HostMiro());
//GridShowPlugin4->addChild(HostXine());
GridShowPlugin4->addChild(HostHuluDesktop());
+ GridShowPlugin4->addChild(HostPLEXHT());
GridShowPlugin4->addChild(Hostwebmin());
GridShowPlugin4->addChild(Hostwebonlinhes());
GridShowPlugin4->addChild(HostXBMC());
diff --git a/abs/core/mythinstall/MythVantage-app/mythinstall/installsettings.h b/abs/core/mythinstall/MythVantage-app/mythinstall/installsettings.h
index 6ce0eff..cd2983b 100755
--- a/abs/core/mythinstall/MythVantage-app/mythinstall/installsettings.h
+++ b/abs/core/mythinstall/MythVantage-app/mythinstall/installsettings.h
@@ -524,6 +524,7 @@ struct HostParms
// QString ThisHostMiro;
QString ThisHostwebonlinhes;
QString ThisHostXBMC;
+ QString ThisHostPLEXHT;
QString ThisHostHuluDesktop;
QString ThisHostpluginmythgameMame;
diff --git a/abs/core/mythinstall/MythVantage-app/mythinstall/main.cpp b/abs/core/mythinstall/MythVantage-app/mythinstall/main.cpp
index a9f0aa9..4c243b5 100755
--- a/abs/core/mythinstall/MythVantage-app/mythinstall/main.cpp
+++ b/abs/core/mythinstall/MythVantage-app/mythinstall/main.cpp
@@ -319,7 +319,7 @@ int main(int argc, char **argv)
"fceux",
"sdlmame",
"mednafen",
- "mupen64plus-svn",
+ "mupen64plus",
"romdb",
"snes9x",
"xe",
@@ -330,7 +330,8 @@ int main(int argc, char **argv)
"mythweather",
"mythzoneminder",
"huludesktop",
- "xbmc",
+ "plex-home-theater",
+ "kodi",
"webmin",
"web-on-linhes",
"foldingathome"};
@@ -354,6 +355,7 @@ int main(int argc, char **argv)
"Hostpluginmythweather",
"Hostpluginmythzoneminder",
"HostHuluDesktop",
+ "HostPLEXHT",
"HostXBMC",
"Hostwebmin",
"Hostwebonlinhes",
diff --git a/abs/core/mythinstall/PKGBUILD b/abs/core/mythinstall/PKGBUILD
index c37757d..901f6ad 100644
--- a/abs/core/mythinstall/PKGBUILD
+++ b/abs/core/mythinstall/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Jams
pkgname=mythinstall
-pkgver=8.2
-pkgrel=7
+pkgver=8.3
+pkgrel=6
pkgdesc="LinHES installer/systemconfig GUI."
arch=('i686' 'x86_64')
depends=('mythtv>=0.27')
@@ -14,7 +14,7 @@ build() {
rsync -au $startdir/MythVantage-app $srcdir
msg "Building mythinstall"
- cd $srcdir/MythVantage-app/mythinstall && qmake
+ cd $srcdir/MythVantage-app/mythinstall && qmake-qt4
make || exit 1
}