summaryrefslogtreecommitdiffstats
path: root/abs/core/mythtv/old/stable-0.21/mytharchive/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/mythtv/old/stable-0.21/mytharchive/PKGBUILD')
-rw-r--r--abs/core/mythtv/old/stable-0.21/mytharchive/PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/abs/core/mythtv/old/stable-0.21/mytharchive/PKGBUILD b/abs/core/mythtv/old/stable-0.21/mytharchive/PKGBUILD
new file mode 100644
index 0000000..4862a1f
--- /dev/null
+++ b/abs/core/mythtv/old/stable-0.21/mytharchive/PKGBUILD
@@ -0,0 +1,35 @@
+# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# Maintainer: Juergen Hoetzel <juergen@archlinux.org>
+# Contributor: kleptophobiac@gmail.com
+
+pkgname=mytharchive
+pkgver=0.21
+pkgrel=10
+pkgdesc="MythTV plugin that lets you create DVDs from or archive your recorded shows."
+arch=('i686' 'x86_64')
+url="http://www.mythtv.org"
+license=('GPL')
+depends=("mythtv>=${pkgver}" 'libxmu' 'libjpeg6' 'mysql-python' 'pil' 'dvdauthor' 'mjpegtools' 'transcode')
+source=("ftp://ftp.knoppmyth.net/R6/sources/mythplugins-$pkgver-fixes.tar.bz2")
+md5sums=('1b3e2a97b7ecf7373e162fe20b6faabe')
+groups=('mythtv-extras')
+
+build() {
+ cd $startdir/src/mythplugins
+ . /etc/profile.d/qt3.sh
+ svn update
+ # use QT3 qmake
+ export PATH=$QTDIR/bin:$PATH
+
+ sed -i 's#kde3#kde#' configure || return 1
+ ./configure --prefix=/usr --enable-opengl --disable-all \
+ --enable-create-archive --enable-create-dvd --enable-mytharchive || return 1
+
+ qmake mythplugins.pro || return 1
+ make qmake || return 1
+ sed -i 's#kde3#kde#' ./mytharchive/mytharchive/Makefile || return 1
+ make -j 2 || return 1
+
+ make INSTALL_ROOT=$startdir/pkg install
+}
+