summaryrefslogtreecommitdiffstats
path: root/abs/core/mythtv/stable/mythstream
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/mythtv/stable/mythstream')
-rw-r--r--abs/core/mythtv/stable/mythstream/PKGBUILD35
-rw-r--r--abs/core/mythtv/stable/mythstream/mythstream.diff79
-rw-r--r--abs/core/mythtv/stable/mythstream/mythstream.install23
3 files changed, 137 insertions, 0 deletions
diff --git a/abs/core/mythtv/stable/mythstream/PKGBUILD b/abs/core/mythtv/stable/mythstream/PKGBUILD
new file mode 100644
index 0000000..275afa8
--- /dev/null
+++ b/abs/core/mythtv/stable/mythstream/PKGBUILD
@@ -0,0 +1,35 @@
+# $Id: PKGBUILD 356 2008-04-18 22:56:27Z aaron $
+# Maintainer: Juergen Hoetzel <juergen@archlinux.org>
+# Contributor: kleptophobiac@gmail.com
+
+pkgname=mythstream
+pkgver=0.18_1
+pkgrel=8
+pkgdesc="Unofficial MythTV plugin for Internet audio and video streams."
+arch=('i686' 'x86_64')
+url="http://home.kabelfoon.nl/~moongies/streamtuned.html"
+license=('GPL')
+depends=('mythtv' 'perl-xml-simple')
+source=("http://home.kabelfoon.nl/~moongies/sw9vc4htz2/mythstream-v0.18_1.tar.gz" "http://home.kabelfoon.nl/~moongies/sw9vc4htz2/mythstream.cpp.patch_svn20071123" "mythstream.diff")
+md5sums=('')
+install=mythstream.install
+groups=('mythtv-extras')
+install=mythstream.install
+
+build() {
+ cd $startdir/src/mythstream-0.18_1
+ patch -p1 < ../mythstream.diff
+ patch -p0 < ../mythstream.cpp.patch_svn20071123
+ ln -s ../../../mythtv/src/mythtv-0.21/libs/lib* .
+ . /etc/profile.d/qt3.sh
+
+ # use QT3 qmake
+ export PATH=$QTDIR/bin:$PATH
+ echo "INCLUDEPATH += /usr/include/mythtv" >> mythstream/mythstream.pro
+
+ qmake mythstream.pro
+ make qmake || return 1
+ make -j 2 || return 1
+
+ make INSTALL_ROOT=$startdir/pkg install
+}
diff --git a/abs/core/mythtv/stable/mythstream/mythstream.diff b/abs/core/mythtv/stable/mythstream/mythstream.diff
new file mode 100644
index 0000000..477881c
--- /dev/null
+++ b/abs/core/mythtv/stable/mythstream/mythstream.diff
@@ -0,0 +1,79 @@
+diff -ruaN mythstream-0.18_1.orig/libs/fft.cpp mythstream-0.18_1/libs/fft.cpp
+--- mythstream-0.18_1.orig/libs/fft.cpp 2006-11-06 22:50:22.000000000 +0000
++++ mythstream-0.18_1/libs/fft.cpp 2009-01-26 02:44:33.000000000 +0000
+@@ -23,7 +23,7 @@
+ // development snapshot, many todo's
+
+ #include <iostream>
+-
++#include <math.h>
+
+ #include <qapplication.h>
+ #include <unistd.h>
+diff -ruaN mythstream-0.18_1.orig/libs/harvester.cpp mythstream-0.18_1/libs/harvester.cpp
+--- mythstream-0.18_1.orig/libs/harvester.cpp 2007-09-25 22:58:20.000000000 +0000
++++ mythstream-0.18_1/libs/harvester.cpp 2009-01-26 02:44:55.000000000 +0000
+@@ -47,6 +47,7 @@
+ #include <qdom.h>
+
+ #include <sys/stat.h>
++#include <cstdlib>
+
+ #include "harvester.h"
+
+diff -ruaN mythstream-0.18_1.orig/libs/recorder.cpp mythstream-0.18_1/libs/recorder.cpp
+--- mythstream-0.18_1.orig/libs/recorder.cpp 2005-05-14 13:22:51.000000000 +0000
++++ mythstream-0.18_1/libs/recorder.cpp 2009-01-26 02:45:14.000000000 +0000
+@@ -34,6 +34,7 @@
+ #include <qvbox.h>
+ #include <qlayout.h>
+ #include <qregexp.h>
++#include <cstdlib>
+
+ #include <qurl.h>
+
+diff -ruaN mythstream-0.18_1.orig/libs/storageconfig.cpp mythstream-0.18_1/libs/storageconfig.cpp
+--- mythstream-0.18_1.orig/libs/storageconfig.cpp 2007-09-05 21:03:14.000000000 +0000
++++ mythstream-0.18_1/libs/storageconfig.cpp 2009-01-26 02:45:35.000000000 +0000
+@@ -26,6 +26,7 @@
+ #include <qlayout.h>
+ #include <qcursor.h>
+ #include <qregexp.h>
++#include <cstdlib>
+
+ #include "storageconfig.h"
+
+diff -ruaN mythstream-0.18_1.orig/libs/streamconfig.cpp mythstream-0.18_1/libs/streamconfig.cpp
+--- mythstream-0.18_1.orig/libs/streamconfig.cpp 2007-09-05 20:36:21.000000000 +0000
++++ mythstream-0.18_1/libs/streamconfig.cpp 2009-01-26 02:45:48.000000000 +0000
+@@ -28,6 +28,7 @@
+ #include <qregexp.h>
+ #include <qtextedit.h>
+ #include <qtextstream.h>
++#include <cstdlib>
+
+ #include "streamconfig.h"
+
+diff -ruaN mythstream-0.18_1.orig/libs/streamstatus.cpp mythstream-0.18_1/libs/streamstatus.cpp
+--- mythstream-0.18_1.orig/libs/streamstatus.cpp 2007-09-19 00:13:45.000000000 +0000
++++ mythstream-0.18_1/libs/streamstatus.cpp 2009-01-26 02:46:05.000000000 +0000
+@@ -38,7 +38,7 @@
+ #include <qregexp.h>
+ #include <qurl.h>
+ #include <math.h>
+-
++#include <cstdlib>
+
+ #include "streamstatus.h"
+
+diff -ruaN mythstream-0.18_1.orig/libs/streamstorage.cpp mythstream-0.18_1/libs/streamstorage.cpp
+--- mythstream-0.18_1.orig/libs/streamstorage.cpp 2007-09-23 18:26:15.000000000 +0000
++++ mythstream-0.18_1/libs/streamstorage.cpp 2009-01-26 02:46:28.000000000 +0000
+@@ -34,6 +34,7 @@
+
+ #include "streamstorage.h"
+ #include "configelements.h"
++#include <cstdlib>
+
+ #include <sys/stat.h>
+
diff --git a/abs/core/mythtv/stable/mythstream/mythstream.install b/abs/core/mythtv/stable/mythstream/mythstream.install
new file mode 100644
index 0000000..5af96f2
--- /dev/null
+++ b/abs/core/mythtv/stable/mythstream/mythstream.install
@@ -0,0 +1,23 @@
+# arg 1: the new package version
+post_install() {
+ mv /usr/share/mythtv/is.xml /tmp
+ grep -v -e /mythmenu /tmp/is.xml > /tmp/is.xml.tmp
+ echo "<!--#MythStream-->" >> /tmp/is.xml.tmp
+ echo " <button>" >> /tmp/is.xml.tmp
+ echo " <type>STREAM</type>" >> /tmp/is.xml.tmp
+ echo " <text>MythStream</text>" >> /tmp/is.xml.tmp
+ echo " <action>PLUGIN mythstream</action>" >> /tmp/is.xml.tmp
+ echo " </button>" >> /tmp/is.xml.tmp
+ echo "<!--#MythStream-->" >> /tmp/is.xml.tmp
+ echo "" >> /tmp/is.xml.tmp
+ echo "</mythmenu>" >> /tmp/is.xml.tmp
+ mv /tmp/is.xml.tmp /usr/share/mythtv/is.xml
+}
+post_remove() {
+ mv /usr/share/mythtv/is.xml /tmp/is.xml.tmp
+ sed -e '/\#MythStream/,/\#MythStream/d' < /tmp/is.xml.tmp > /usr/share/mythtv/is.xml
+}
+
+op=$1
+shift
+$op $*