summaryrefslogtreecommitdiffstats
path: root/abs/core/nasm/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/nasm/PKGBUILD')
-rw-r--r--abs/core/nasm/PKGBUILD29
1 files changed, 15 insertions, 14 deletions
diff --git a/abs/core/nasm/PKGBUILD b/abs/core/nasm/PKGBUILD
index eff9c02..e9f285f 100644
--- a/abs/core/nasm/PKGBUILD
+++ b/abs/core/nasm/PKGBUILD
@@ -1,29 +1,30 @@
-# $Id$
-# Maintainer: Eric Bélanger <eric@archlinux.org>
+# Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
+# Contributor: Eric Bélanger <eric@archlinux.org>
pkgname=nasm
-pkgver=2.11.08
+pkgver=2.14.02
pkgrel=1
-pkgdesc="An 80x86 assembler designed for portability and modularity"
-arch=('i686' 'x86_64')
-url="http://www.nasm.us"
+pkgdesc='80x86 assembler designed for portability and modularity'
+url='https://www.nasm.us'
+arch=('x86_64')
license=('BSD')
depends=('glibc')
-install=nasm.install
-source=(http://www.nasm.us/pub/nasm/releasebuilds/${pkgver}/${pkgname}-${pkgver}.tar.xz)
-sha1sums=('6908296ac437b3ade79fadfaad0efcfd99582f70')
+makedepends=('perl-font-ttf' 'perl-sort-versions' 'fontconfig' 'adobe-source-sans-pro-fonts'
+ 'ttf-liberation' 'ghostscript' 'xmlto' 'asciidoc')
+source=(https://www.nasm.us/pub/nasm/releasebuilds/${pkgver}/${pkgname}-${pkgver}.tar.xz)
+sha512sums=('c7a228095f37321d57f2813d04f58ee66949e8f81fc49ef6c4ecd391301e308217583ce1a265d4fe8c13d54b5b9c72aeb132caa3caee36e31b6555fbfff34c81')
build() {
cd ${pkgname}-${pkgver}
./configure --prefix=/usr
make
- make -C doc info
+ make -C doc
}
package() {
cd ${pkgname}-${pkgver}
- make INSTALLROOT="${pkgdir}" install install_rdf
- install -dm755 "${pkgdir}"/usr/share/info
- install -m644 doc/info/* "${pkgdir}"/usr/share/info/
- install -D -m644 LICENSE "${pkgdir}"/usr/share/licenses/nasm/LICENSE
+ make DESTDIR="${pkgdir}" install install_rdf
+ install -Dm 644 LICENSE -t "${pkgdir}"/usr/share/licenses/nasm
}
+
+# vim: ts=2 sw=2 et: