summaryrefslogtreecommitdiffstats
path: root/abs/core/pacman/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'abs/core/pacman/PKGBUILD')
-rw-r--r--abs/core/pacman/PKGBUILD67
1 files changed, 16 insertions, 51 deletions
diff --git a/abs/core/pacman/PKGBUILD b/abs/core/pacman/PKGBUILD
index e30c4bd..582d60e 100644
--- a/abs/core/pacman/PKGBUILD
+++ b/abs/core/pacman/PKGBUILD
@@ -1,32 +1,35 @@
# vim: set ts=2 sw=2 et:
-# $Id$
# Maintainer: Dan McGee <dan@archlinux.org>
# Maintainer: Dave Reisner <dreisner@archlinux.org>
pkgname=pacman
-pkgver=5.0.2
-pkgrel=2
+pkgver=5.2.2
+pkgrel=1
pkgdesc="A library-based package manager with dependency support"
arch=('x86_64')
-url="http://www.archlinux.org/pacman/"
+url="https://www.archlinux.org/pacman/"
license=('GPL')
-groups=('base' 'base-devel')
+groups=('base-devel')
depends=('bash' 'glibc' 'libarchive' 'curl'
'gpgme' 'pacman-mirrorlist' 'archlinux-keyring')
makedepends=('asciidoc')
-checkdepends=('python2' 'fakechroot')
-provides=('pacman-contrib')
-conflicts=('pacman-contrib')
-replaces=('pacman-contrib')
-backup=(etc/pacman.conf etc/makepkg.conf)
+checkdepends=('python' 'fakechroot')
+optdepends=('perl-locale-gettext: translation support in makepkg-template')
+provides=('libalpm.so')
+backup=(etc/pacman.conf
+ etc/makepkg.conf)
options=('strip' 'debug')
validpgpkeys=('6645B0A8C7005E78DB1D7864F99FFE0FEAE999BD' # Allan McRae <allan@archlinux.org>
'B8151B117037781095514CA7BBDFFC92306B1121') # Andrew Gregory (pacman) <andrew@archlinux.org>
source=(https://sources.archlinux.org/other/pacman/$pkgname-$pkgver.tar.gz{,.sig}
- pacman.conf.i686
- pacman.conf.x86_64
+ pacman.conf
makepkg-asroot.patch
makepkg.conf)
+sha256sums=('bb201a9f2fb53c28d011f661d50028efce6eef2c1d2a36728bdd0130189349a0'
+ 'SKIP'
+ '3353f363088c73f1f86a890547c0f87c7473e5caf43bbbc768c2e9a7397f2aa2'
+ '8a7019948c0917d70937a518a131b330a0adab66c1bd367ff4073046acf4c8a7'
+ '9c769f13c09a6f24c393a9762474eded2f269d8966e7764d9160d62232a7919b')
build() {
@@ -37,7 +40,6 @@ build() {
--with-scriptlet-shell=/usr/bin/bash \
--with-ldconfig=/usr/bin/ldconfig
make V=1
- make -C contrib
}
check() {
@@ -48,51 +50,14 @@ package() {
cd "$pkgname-$pkgver"
make DESTDIR="$pkgdir" install
- make DESTDIR="$pkgdir" -C contrib install
# install Arch specific stuff
install -dm755 "$pkgdir/etc"
- install -m644 "$srcdir/pacman.conf.$CARCH" "$pkgdir/etc/pacman.conf"
-
- case $CARCH in
- i686)
- mycarch="i686"
- mychost="i686-pc-linux-gnu"
- myflags="-march=i686"
- ;;
- x86_64)
- mycarch="x86_64"
- mychost="x86_64-pc-linux-gnu"
- myflags="-march=x86-64"
- ;;
- esac
-
- # set things correctly in the default conf file
+ install -m644 "$srcdir/pacman.conf" "$pkgdir/etc"
install -m644 "$srcdir/makepkg.conf" "$pkgdir/etc"
- sed -i "$pkgdir/etc/makepkg.conf" \
- -e "s|@CARCH[@]|$mycarch|g" \
- -e "s|@CHOST[@]|$mychost|g" \
- -e "s|@CARCHFLAGS[@]|$myflags|g"
-
- # put bash_completion in the right location
- install -dm755 "$pkgdir/usr/share/bash-completion/completions"
- mv "$pkgdir/etc/bash_completion.d/pacman" "$pkgdir/usr/share/bash-completion/completions"
- rmdir "$pkgdir/etc/bash_completion.d"
-
- for f in makepkg pacman-key; do
- ln -s pacman "$pkgdir/usr/share/bash-completion/completions/$f"
- done
-
- install -Dm644 contrib/PKGBUILD.vim "$pkgdir/usr/share/vim/vimfiles/syntax/PKGBUILD.vim"
#restore --asroot makepkg option
cd $pkgdir/usr/bin/
patch -p0 -i "$srcdir/makepkg-asroot.patch"
rm $pkgdir/usr/bin/makepkg.orig
}
-md5sums=('f36f5e7e95a89436febe1bcca874fc33'
- 'SKIP'
- 'bdb40c76225c2fd8874bd34b6a3f6ad7'
- 'c511ee4c7a86a37e8841440ede89300d'
- '4950b7c5adf80e082a726dd11b9cb12f'
- 'ce959232a30f1fbd33f536c76a9df198')